Выгрузка табеля учета посещаемости детей с формулами в Excel

Тема в разделе "Обмен данными в "1С:Предприятие 8"", создана пользователем АлексейБобков, 10 авг 2017.

  1. TopicStarter Overlay
    АлексейБобков
    Offline

    АлексейБобков

    Регистрация:
    20 авг 2015
    Сообщения:
    4
    Симпатии:
    0
    Баллы:
    1
    Добрый день народ, Проблема такая пытаюсь сделать выгрузку из 1с БГУ 1.0 табеля учета посещаемости детей в файл excel с формулами, но не могу доделать до конца. Сделал следующее (имеется кнопка на форме табеля сохранить в Excel) выгружает в Excel и заполняет формулами три столбца( Пропущено дней(всего,в том числе засчитываемых) , Дни посещения, подлежащие оплате). Три формулы проходит циклом все нормально проставляет формулы. Но внизу где запись ( Всего отсутствует детей по каждому дню) не могу сделать формулу для расчета неявок то есть букву н.
    Кусочек кода где не могу разобраться:

    Для СчСтолбцов1=10 По 40 Цикл
    Для Сч1=13 По ВсегоСтрок1 Цикл


    Если СокрЛП(Лист.Cells(Сч1,3).Text)="Всего отсутствует детей" ТОГДА


    Лист.Cells(Сч1,СчСтолбцов1).FormulaLocal = "=СЧЁТЕСЛИ(J"+Сч1+":J"+Сч1+";""н"")"; //вот тут надо думать

    Иначе
    Продолжить;
    КонецЕсли;
    Сч1= Сч1+1;
    КонецЦикла;
    КонецЦикла;
    КонецЕсли;
    Помогите пожалуйста разобраться и доделать садов много 70 учреждений в нашем районе.

    Вложения:

  2. TopicStarter Overlay
    АлексейБобков
    Offline

    АлексейБобков

    Регистрация:
    20 авг 2015
    Сообщения:
    4
    Симпатии:
    0
    Баллы:
    1
    Сам табель Ексель файл из 1С бгу 1.0 то что получилось

    Вложения:

Похожие темы
  1. AndrosovEvgeniy
    Ответов:
    2
    Просмотров:
    3.155
  2. Андрей brutal-86
    Ответов:
    1
    Просмотров:
    2.133
  3. MarkovRoman
    Ответов:
    3
    Просмотров:
    2.577
  4. Gala65
    Ответов:
    1
    Просмотров:
    1.143
  5. Yuzer
    Ответов:
    0
    Просмотров:
    763
Загрузка...

Поделиться этой страницей