8.х Выгрузка регистров сведений

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Morgan_Black, 16 мар 2011.

  1. TopicStarter Overlay
    Morgan_Black
    Offline

    Morgan_Black

    Регистрация:
    10 ноя 2010
    Сообщения:
    2
    Симпатии:
    0
    Баллы:
    1
    Всем привет :)
    Столкнулся с такой проблемой, нужно выгрузить в XML пару справочников и непериодический РегистрСведений. Справочники то я выгрузил, написал обработку, а вот в Регистрами что то не выходит. Толкните на путь истинный :)

    Вот листинг выгрузки справочников:
    Код:
    Процедура Кнопка1Нажатие(Элемент)
    Диалог = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Сохранение);
    Диалог.Заголовок = "Укажите файл для обмена:";
    Диалог.Расширение = ".xml";
    Диалог.Фильтр = "Файл данных (*.xml)|*.xml|"; 
    Если Диалог.Выбрать()Тогда
    ЗаписьXML = Новый ЗаписьXML;
    ЗаписьXML.ОткрытьФайл(Диалог.ПолноеИмяФайла);
    ЗаписьXML.ЗаписатьНачалоЭлемента("Главный");
    
    //Выгрузка справочника
    Выборка = Справочники.Клиенты.Выбрать();
    Пока Выборка.Следующий () Цикл
    ЗаписьXML.ЗаписатьНачалоЭлемента("Справочник");
    ЗаписатьXML(ЗаписьXML, Выборка.ПолучитьОбъект());
    ЗаписьXML.ЗаписатьКонецЭлемента();
    КонецЦикла;
    
    ЗаписьXML.ЗаписатьКонецЭлемента();
    ЗаписьXML.Закрыть();
    Сообщить ("Выгружено");
    КонецЕсли;
    КонецПроцедуры
    
    Что мне нужно в коде поменять для выгрузки регистра сведений?
  2. Oleg_NSK
    Offline

    Oleg_NSK Опытный в 1С

    Регистрация:
    25 окт 2010
    Сообщения:
    164
    Симпатии:
    0
    Баллы:
    26
    используйте обработку ВыгрузкаЗагрузкаДанныхXML81.epf идущую с конфой конвертация данных

Поделиться этой страницей