8.х Выгрузка проводок из 1С 8 (УПП)

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем ZlydenGL, 1 ноя 2006.

  1. TopicStarter Overlay
    ZlydenGL
    Offline

    ZlydenGL

    Регистрация:
    1 ноя 2006
    Сообщения:
    2
    Симпатии:
    0
    Баллы:
    1
    Доброго времени суток всем посетителям форума! :D

    Появилась задача сравнения проводок в системах 1С 7.7 (Комплексная конфигурация) и 1С 8 (УПП). Нужно сравнение именно набора введенных за период проводок и больше ничего!

    В случае с 7.7 разобрался довольно быстро:
    Код:
    Док=СоздатьОбъект("Операция");
    Док.ВыбратьОперации(ДатаНачала,ДатаКонца); 
    Пока Док.ПолучитьОперацию()=1 Цикл
    Если (Док.ПометкаУдаления()=0) Тогда
    Док.ВыбратьПроводки();
    Пока Док.ПолучитьПроводку()=1 Цикл
    // Обработчик выгрузки
    КонецЦикла;
    КонецЕсли;
    КонецЦикла;
    
    А вот как подобную же вещь реализовать в восьмерке? :unsure:

    Может хотя бы есть совет - в какую сторону надо копать?

    Спасибо B)
  2. TopicStarter Overlay
    ZlydenGL
    Offline

    ZlydenGL

    Регистрация:
    1 ноя 2006
    Сообщения:
    2
    Симпатии:
    0
    Баллы:
    1
    Сам же себе и отвечаю - благодаря наводки ребят из другого форума :unsure:

    Код:
    Запрос = Новый Запрос;
    Запрос.Текст =
    "ВЫБРАТЬ
    | *
    |ИЗ
    | РегистрБухгалтерии.Хозрасчетный.ОборотыДтКт(&ДатаНач, &ДатаКон, , , , , , )";
    Запрос.УстановитьПараметр("ДатаКон", КонецДня(ДатаКон));
    Запрос.УстановитьПараметр("ДатаНач", ДатаНач);
    ТаблицаЗначений = Запрос.Выполнить().Выгрузить();
    Для каждого СтрокаТЗ из ТаблицаЗначений Цикл
    //Обработчик выгрузки
    КонецЦикла;
    
    Мож кому еще потребуется...

Поделиться этой страницей