7.7 выгрузка периодического реквизита в xml

Тема в разделе "Обмен данными в "1С:Предприятие 7.7"", создана пользователем o_O, 7 июл 2010.

  1. dedalx7
    Offline

    dedalx7 Опытный в 1С

    Регистрация:
    20 май 2009
    Сообщения:
    97
    Симпатии:
    0
    Баллы:
    26
    В Сообщении №2 :
    Что вам непонятно?

    В синтаксис-помощнике все понятно описано. Все что вам нужно сделать это создать объект "Периодический", сопоставить ему периодический реквизит, и перебором получать Значение и ДатаЗнач для каждой записи.

    Если очень хотите - вот как это выглядит в коде:

    Код:
    //выше идет тело обработки
    //в нем вы перебираете нужные позиции, нужные цены, категории цен и т.д. и т.п.
    //не забывайте при выборе подчиненных справочников о методе .ИспользоватьВладельца(Владелец,ФлагИзменения), а дальше:
    ЦеныНаДату = СоздатьОбъект("Периодический");
    ЦеныНаДату.ИспользоватьОбъект("Цена",СправочникЦен);
    ЦеныНаДату.ВыбратьЗначения();
    Пока ЦеныНаДату.ПолучитьЗначение() = 1 Цикл
    //вставляем нужный для подготовки к сохранению значений код, а потом:
    Перем1 = ЦеныНаДату.Значение; // Перем1 - это то куда вы сохраняете значение - переменная, поле ТЗ, поле файла, что угодно
    Перем2 = ЦеныНаДату.ДатаЗнач; // Перем2 - это то куда вы сохраняете дату изменения значения
    КонецЦикла;
    //продолжение тела обработки
    
    Пожалуй все что можно выдать в качестве подсказки. И то это уже процентов 70 работы.
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Вот кусок кода выгрузки. Разбирайтесь....
    Код:
    ...
    //анализатор
    Анализатор=СоздатьОбъект("AddIn.XMLParser");
    Корень=Анализатор.СоздатьДокумент();
    //данные
    Данные=Корень.СоздатьПодчиненныйЭлемент("Данные");
    //наполнение
    С.ВыбратьЭлементы();
    Пока С.ПолучитьЭлемент()=1 Цикл
    Если С.ЭтоГруппа()=0 Тогда
    Эл=Данные.СоздатьПодчиненныйЭлемент("Элемент");
    Эл.Значение=С.Код;
    Эл.УстановитьАтрибут("Наименование",С.Наименование);
    //здесть применяем код приведенный выше
    Эл.УстановитьАтрибут("Дата",Перем1);
    Эл.УстановитьАтрибут("Знач",Перем2);
    КонецЕсли;
    КонецЦикла;
    //запись
    Корень.Записать("C:\цены.xml");
    
    

Поделиться этой страницей