8.х Выгрузка категорий номенклатуры в .xml файл

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем skillful, 11 фев 2013.

  1. TopicStarter Overlay
    skillful
    Offline

    skillful

    Регистрация:
    7 май 2010
    Сообщения:
    3
    Симпатии:
    0
    Баллы:
    1
    Здравствуйте! Помогите пожалуйста с кодом 1С выгружающим в .xml файл категории номенклатуры. Версия 1С 8.2 УТ 10.3

    Нужно чтобы файл получался таким

    [xml]<?xml version="1.0" encoding="UTF-8"?>
    <КоммерческаяИнформация ВерсияСхемы="2.04" ДатаФормирования="2013-02-09T22:35:56">
    <Классификатор>
    <Группы>
    <Группа>
    <Код>84d6cffb-6695-11e1-9628-0022156ae823</Код>
    <Наименование>25. Портативная электроника</Наименование>
    <Группы>
    <Группа>
    <Код>84d6d02b-6695-11e1-9628-0022156ae823</Код>
    <Наименование>02. Навигаторы</Наименование>
    </Группа>
    <Группа>
    <Код>11658121-f98b-11e0-9bbf-0022156ae823</Код>
    <Наименование>04. Диктофоны</Наименование>
    </Группа>
    <Группа>
    <Код>11658145-f98b-11e0-9bbf-0022156ae823</Код>
    <Наименование>06. Плееры, FM-модуляторы</Наименование>
    </Группа>
    <Группа>
    <Код>1165814b-f98b-11e0-9bbf-0022156ae823</Код>
    <Наименование>07. Графические планшеты</Наименование>
    </Группа>
    </Группы>
    </Группа>
    <Группа>
    <Код>116580bf-f98b-11e0-9bbf-0022156ae823</Код>
    <Наименование>46. Видеонаблюдение</Наименование>
    <Группы>
    <Группа>
    <Код>84d6cffc-6695-11e1-9628-0022156ae823</Код>
    <Наименование>01. Видеорегистраторы</Наименование>
    </Группа>
    <Группа>
    <Код>116580f5-f98b-11e0-9bbf-0022156ae823</ИдКод
    <Наименование>02. Камеры наблюдения</Наименование>
    </Группа>
    <Группа>
    <Код>1165810c-f98b-11e0-9bbf-0022156ae823</Код>
    <Наименование>03. Блоки питания</Наименование>
    </Группа>
    <Группа>
    <Код>1165811f-f98b-11e0-9bbf-0022156ae823</Код>
    <Наименование>04. Аксессуары</Наименование>
    </Группа>
    </Группы>
    </Группа>
    </Группы>

    </Классификатор>
    </КоммерческаяИнформация>[/xml]
    Вот пример кода, но он не делает то, что нужно. Вы можите мне помочь?

    Код:
    ЗаписьXML = Новый ЗаписьXML;
    ЗаписьXML.ОткрытьФайл("C:/groups.xml");
    
    ЗаписьXML.ЗаписатьОбъявлениеXML();
    ЗаписьXML.ЗаписатьНачалоЭлемента("КоммерческаяИнформация");
    
    // Записать атрибут элемента КоммерческаяИнформация
    ЗаписьXML.ЗаписатьАтрибут("ВерсияВыгрузки", "8.2");
    ЗаписьXML.ЗаписатьАтрибут("ДатаФормирования", Формат(ТекущаяДата(), "ДФ = ""дд.ММ.гггг ЧЧ:мм:сс""; ДП = ""..."""));
    ЗаписьXML.ЗаписатьНачалоЭлемента("Классификатор");
    ЗаписьXML.ЗаписатьНачалоЭлемента("Группы"); //Начинаем запись "<Группы>"
    //ЗаписьXML.ЗаписатьКомментарий("Элементы справочника:");
    
    ВыборкаГруппы = Справочники.Номенклатура.Выбрать();
    
    ПорядковыйНомер2 = 0;
    Пока ВыборкаГруппы.Следующий() Цикл
    Если ВыборкаГруппы.ЭтоГруппа Тогда
    ПорядковыйНомер2 = 1 + ПорядковыйНомер2;
    
    Если ВыборкаГруппы.Ссылка.Уровень() = 0 тогда
    ЗаписьXML.ЗаписатьНачалоЭлемента("Группа");
    
    ЗаписьXML.ЗаписатьНачалоЭлемента("Код");
    ЗаписьXML.ЗаписатьТекст(ВыборкаГруппы.Код);
    ЗаписьXML.ЗаписатьКонецЭлемента();
    
    ЗаписьXML.ЗаписатьНачалоЭлемента("Наименование");
    ЗаписьXML.ЗаписатьТекст(ВыборкаГруппы.Наименование);
    ЗаписьXML.ЗаписатьКонецЭлемента();
    ЗаписьXML.ЗаписатьКонецЭлемента(); // <Группа>
    Иначе
    Сообщить("");
    КонецЕсли;
    
    Сообщить(строка(Формат(ПорядковыйНомер2, "ЧГ=0")) + ": Группа: " + ВыборкаГруппы.Наименование + ". Уровень группы: " + ВыборкаГруппы.Ссылка.Уровень());
    КонецЕсли;
    
    КонецЦикла;  
    
    ЗаписьXML.ЗаписатьКонецЭлемента(); // Глобальный "<Группы>"
    ЗаписьXML.ЗаписатьКонецЭлемента(); // Классификатор
    ЗаписьXML.ЗаписатьКонецЭлемента(); // КоммерческаяИнформация
    ЗаписьXML.Закрыть();
  2. Dmitriy_76
    Offline

    Dmitriy_76 Опытный в 1С Команда форума

    Регистрация:
    26 мар 2011
    Сообщения:
    2.174
    Симпатии:
    13
    Баллы:
    29
    покажи различия... что формирует твой кусок кода.

Поделиться этой страницей