8.х Выгрузка из журнала регистрации событий отправки писем

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем JediAlex, 31 май 2017.

  1. TopicStarter Overlay
    JediAlex
    Offline

    JediAlex Опытный в 1С

    Регистрация:
    27 авг 2011
    Сообщения:
    181
    Симпатии:
    0
    Баллы:
    26
    Здравствуйте. Возникла задача сделать следующее: из журнала регистрации ЗУП 3.1 выгрузить за заданный период события отправки расчетных листков по электронной почте. Я делал обработку выгрузки событий входа в систему:
    Код:
    &НаСервере
    Процедура ВывестиЖурналРегистрацииНаСервере();
     Фильтр=Новый Структура;
     //Фильтр.Очистить();
     Если ЗначениеЗаполнено(Объект.Пользователь) Тогда
     //Сообщить(Объект.Пользователь.Код, СтатусСообщения.Информация);
     //МассивЮзеров = Новый Массив;
     //МассивЮзеров.Добавить(Объект.Пользователь.Код);
     Фильтр.Вставить("Пользователь", ПользователиИнформационнойБазы.НайтиПоУникальномуИдентификатору(Объект.Пользователь.ИдентификаторПользователяИБ));
     КонецЕсли;
     
     Если ЗначениеЗаполнено(Объект.НачалоПериода) Тогда
     Фильтр.Вставить("ДатаНачала", Объект.НачалоПериода);
     КонецЕсли;
     
     Если ЗначениеЗаполнено(Объект.ОкончаниеПериода) Тогда  
     Фильтр.Вставить("ДатаОкончания", КонецДня(Объект.ОкончаниеПериода));
     КонецЕсли;
     МассивСобытий = Новый Массив;
     МассивСобытий.Добавить("_$Session$_.Authentication");
     Фильтр.Вставить("Событие", МассивСобытий);
     СобытияЖурнала = Новый ТаблицаЗначений;
     СобытияЖурнала.Очистить();
     Объект.ЖурналСобытий.Очистить();
     ВыгрузитьЖурналРегистрации(СобытияЖурнала,Фильтр);
     //ВыгрузитьЖурналРегистрации(СобытияЖурнала);
     Для Каждого Стр Из СобытияЖурнала Цикл
     //Если ЗначениеЗаполнено(Стр.Пользователь) Тогда 
     ТекСтрока=Объект.ЖурналСобытий.Добавить();
     ТекСтрока.Дата=Строка(Стр.Дата);
     ТекСтрока.Событие=Строка(Стр.Событие);
     ТекСтрока.Пользователь=Строка(Стр.ИмяПользователя);
     ТекСтрока.Компьютер=Строка(Стр.Компьютер);
     ТекСтрока.МетаДанные=Строка(Стр.МетаДанные);
     ТекСтрока.Данные=Строка(Стр.Данные);
     //КонецЕсли;
     КонецЦикла;
    КонецПроцедуры
    событие входа:
    Код:
    МассивСобытий.Добавить("_$Session$_.Authentication");
    Для расчетных листков можно фильтр по метаданным добавить, а
    по какому событию вывести отправку по почте? Помогите пожалуйста...
  2. nomad_irk
    Offline

    nomad_irk Гуру в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    9.247
    Симпатии:
    963
    Баллы:
    204
    Ни по какому. нет такого предопределенного события как "Отправка писем по электронной почте"
  3. TopicStarter Overlay
    JediAlex
    Offline

    JediAlex Опытный в 1С

    Регистрация:
    27 авг 2011
    Сообщения:
    181
    Симпатии:
    0
    Баллы:
    26
    события в журнале есть. Значит по какому то признаку они туда заносятся. Вопрос - по какому?
  4. nomad_irk
    Offline

    nomad_irk Гуру в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    9.247
    Симпатии:
    963
    Баллы:
    204
    Записывать в журнал можно любые события.
    Отбор событий при выгрузке журнала ограничен набором предопределенных значений.

Поделиться этой страницей