8.х Выгрузить на клиенте Табличную часть

Тема в разделе "Общие вопросы "1С:Предприятие 8"", создана пользователем Aston, 11 фев 2013.

  1. TopicStarter Overlay
    Aston
    Offline

    Aston Опытный в 1С

    Регистрация:
    6 июн 2012
    Сообщения:
    467
    Симпатии:
    3
    Баллы:
    29
    Привет всем!
    Есть код который не могу додуматься как сделать правильно - тоесть он работает но чтоб работал правильно.
    Код:
    &НаКлиенте
    Процедура ЗаполнитьТекущуюРасшифровкуЭтажа(УИТекущегоЭтажа)
    
    ЭтаФорма.ТЗРасшифровкаЭтажей.Очистить();
    
    МассивНайденныхРасшифровок = Объект.РасшифровкаЭтажей.НайтиСтроки(Новый Структура("УиОбъекта", УИТекущегоЭтажа));
    //1)То что тут обращается на сервер мне всё равно без этого никак.
    
    //3) Хотел бы тут получить коллекцию которую можно было бы фильтровать, чтоб обратится на сервер 1 раз, подскажите как плиз)
    
    Для Каждого РасшифровкаЭтажа ИЗ МассивНайденныхРасшифровок ЦИКЛ
    НоваяСтрока = ЭтаФорма.ТЗРасшифровкаЭтажей.Добавить();
    ЗаполнитьЗначенияСвойств(НоваяСтрока, РасшифровкаЭтажа);
    
    НайденныеПлощади = Объект.Площади.НайтиСтроки(Новый Структура("УИТекущейРасшифровки", РасшифровкаЭтажа.УИТекущейРасшифровки));
    //Тут не верно - 100 раз обращается на сервер - хотя этого не нужно - смотреть 3)
    Для Каждого Площадь ИЗ НайденныеПлощади ЦИКЛ
    Если Элементы.Найти("ТЗРасшифровкаЭтажей"+ПолучитьИмяКолонки(Площадь.ВидПлощади)) <> Неопределено Тогда
    НоваяСтрока[ПолучитьИмяКолонки(Площадь.ВидПлощади)] = Площадь.РазмерПлощади;
    КонецЕсли;
    КонецЦикла;
    КонецЦикла;
    
    ТЗРасшифровкаЭтажей.Сортировать("НомСтроки Возр");
    КонецПроцедуры
    Не могу додумать как на клиенте получить табличную часть 1 раз но всю и работать с ней только?
  2. TopicStarter Overlay
    Aston
    Offline

    Aston Опытный в 1С

    Регистрация:
    6 июн 2012
    Сообщения:
    467
    Симпатии:
    3
    Баллы:
    29
    Тема закрыта - решение проблемы - всё выполнить на сервере а результат прислать :)

Поделиться этой страницей