8.х Выгонялка

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Maks21, 23 сен 2008.

  1. TopicStarter Overlay
    Maks21
    Offline

    Maks21

    Регистрация:
    17 сен 2008
    Сообщения:
    32
    Симпатии:
    0
    Баллы:
    1
    Помогите разобраться в работе выгонялки..
    Создаю константу, в которую загоняю сообщение и создаю кнопку.. в процедуре кнопки пишу:
    Код:
    Процедура ОтключитьПозователейНажатие(Элемент)
    КонтрольРежимаЗавершения();
    КонецПроцедуры
    
    Далее в модуле приложения пишу:
    Код:
    Процедура КонтрольРежимаЗавершения() ЭКСПОРТ
    СообщПользователям=Константы.СообщениеПользователям.Получить();
    ПодключитьОбработчикОжидания("ЗавершениеРаботы", 600);
    Вопросик=Вопрос(""+СообщПользователям+""+Символы.ПС+"Программа завершит свою работы через 10 минут"+Символы.ПС+"«ОК» - завершенить сейчас работу программы"+Символы.ПС+"«Отмена» - продолжение работы", РежимДиалогаВопрос.ОКОтмена);
    Если Вопросик=КодВозвратаДиалога.ОК Тогда
    ПрекратитьРаботуСистемы();
    Иначе Если Вопросик=КодВозвратаДиалога.Отмена Тогда
    Предупреждение("Поскорее завершайте работу!!!");
    ОтключитьОбработчикОжидания("ЗавершениеРаботы");
    КонецЕсли;
    КонецЕсли;
    
    КонецПроцедуры
    Процедура ЗавершениеРаботы() ЭКСПОРТ
    ПрекратитьРаботуСистемы();
    КонецПроцедуры
    
    Почему она именно у меня срабатывает?? :(
  2. opkc
    Offline

    opkc Опытный в 1С

    Регистрация:
    28 янв 2008
    Сообщения:
    149
    Симпатии:
    0
    Баллы:
    26
    пусть все на кнопку нажимают, тогда у них тоже будет выскакивать.
  3. tunec
    Offline

    tunec Опытный в 1С

    Регистрация:
    2 июн 2008
    Сообщения:
    469
    Симпатии:
    0
    Баллы:
    26
    точно :)
  4. TopicStarter Overlay
    Maks21
    Offline

    Maks21

    Регистрация:
    17 сен 2008
    Сообщения:
    32
    Симпатии:
    0
    Баллы:
    1
    а как же тогда быть?
  5. BabySG
    Offline

    BabySG Администраторы Команда форума Администратор

    Регистрация:
    10 июн 2007
    Сообщения:
    11.853
    Симпатии:
    12
    Баллы:
    29
    Посмотри, как в типовой УПП сделано
  6. KiberMath
    Offline

    KiberMath Опытный в 1С

    Регистрация:
    22 сен 2008
    Сообщения:
    61
    Симпатии:
    0
    Баллы:
    26
    Пипец ))))
    OpKc, Пасиб Поржал )))))))))

    Дык можно проверять от какого пользователя была запущенна процедура "КонтрольРежимаЗавершения", кажись с помощью Пользователь... Синтаксис помошник те может помочь в более точном написании кода =)
  7. KiberMath
    Offline

    KiberMath Опытный в 1С

    Регистрация:
    22 сен 2008
    Сообщения:
    61
    Симпатии:
    0
    Баллы:
    26
    Ну у меня например есть вот такая непонятная идея

    Взять создать константы по принцупу - каждому пользователю соответствует своя константа с типом булево... и ...
    короче вот пример =)

    Код:
    перем ГЫ;    перем ФЛАГ;
    
    Процедура ПриНачалеРаботыСистемы()
    Гы = 0;
    ФЛАГ = ИСТИНА;
    константы.ВыкидываемыйЖив.Установить(ИСТИНА);
    ПодключитьОбработчикОжидания("О_О",1);
    КонецПроцедуры
    
    Процедура О_О()   Экспорт
    Если ФЛАГ = ИСТИНА Тогда
    ГЫ = ГЫ +1;
    Если  ПользователиИнформационнойБазы.ТекущийПользователь().Имя = ПользователиИнформационнойБазы.НайтиПоИмени("Выкидываемый").Имя
    и Константы.ВыкидываемыйЖив.Получить()=ЛОЖЬ
    Тогда 
    ФЛАГ = ЛОЖЬ;
    Предупреждение("ПОКА ПОКА");
    ЗавершитьРаботуСистемы();
    КОнецЕсли;
    КонецЕсли;
    КонецПроцедуры
    
    
    Терь, чтобы выкинуть моего пользователя с именем Выкидываемый нужно только соответствующую ему константу сделать ложно и аллелуяя
  8. opkc
    Offline

    opkc Опытный в 1С

    Регистрация:
    28 янв 2008
    Сообщения:
    149
    Симпатии:
    0
    Баллы:
    26
    :unsure: не за что, спасибо автору темы :)
  9. Pencroff
    Offline

    Pencroff

    Регистрация:
    9 сен 2009
    Сообщения:
    31
    Симпатии:
    0
    Баллы:
    1
    Доброго всем вечера.
    Написал вот еще одну выгонялку.
    Прошу пользовать, тестировать и критиковать.
  10. mialord
    Offline

    mialord Модераторы Команда форума Модератор

    Регистрация:
    31 июл 2009
    Сообщения:
    5.398
    Симпатии:
    40
    Баллы:
    54
    Я бы порекомендовал зафиксировать ее в ветке"Обработки"

Поделиться этой страницей