8.х Выделить строку (изменить фон строки)

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем polzovatel1994, 20 апр 2014.

  1. TopicStarter Overlay
    polzovatel1994
    Offline

    polzovatel1994

    Регистрация:
    8 окт 2013
    Сообщения:
    15
    Симпатии:
    0
    Баллы:
    1
    На форме документа выполняю обработку проверки уникальности значений табличной части:
    Код:
    &НаКлиенте
    Процедура ОбучающиесяПриОкончанииРедактирования(Элемент, НоваяСтрока, ОтменаРедактирования)
         Если Элементы.Обучающиеся.ТекущиеДанные.Обучающиеся.Пустая()=Истина Тогда
            Отказ=Истина;
        Иначе
            ПараметрыОтбора = Новый Структура;
            ПараметрыОтбора.Вставить("Обучающиеся", Элементы.Обучающиеся.ТекущиеДанные.Обучающиеся);
            НайденныеСтроки = объект.Обучающиеся.НайтиСтроки(ПараметрыОтбора);
            Если НайденныеСтроки.Количество()>1 Тогда
                Отказ=Истина;
                Сообщить("в табличной части уже встречается: "+Элементы.Обучающиеся.ТекущиеДанные.Обучающиеся);
             
            КонецЕсли;
        КонецЕсли;
    КонецПроцедуры
    
    Мне необходимо если строки совпадают (то есть не уникальные) выделить эту строку в табЧасти, не получается изменить фон строки
    Заранее благодарен
    Последнее редактирование модератором: 20 апр 2014
  2. Tiger86
    Offline

    Tiger86 Модераторы Команда форума Модератор

    Регистрация:
    24 мар 2011
    Сообщения:
    6.407
    Симпатии:
    108
    Баллы:
    104
    испоьзуйте обработчик ПриПолученииДанных у табполя

Поделиться этой страницей