8.х Выделенная строка в регистре сведений (8.3)

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Rassvetniy, 7 фев 2016.

  1. TopicStarter Overlay
    Rassvetniy
    Offline

    Rassvetniy

    Регистрация:
    26 июн 2015
    Сообщения:
    3
    Симпатии:
    0
    Баллы:
    1
    День добрый. Подскажите с наверное примитивным вопросом.
    Задумка в регистре сведений выделить строку, запомнить данные по этой строке и передать их в документ. В форме списка отображаются поля номенклатура (название товара) и Шкод (код справочника номенклатура), к номенклатуре доступ есть как и другим полям цена, период, а к коду ни в какую, в чем тут ошибка?

    &НаКлиенте
    перем ВыделеннаяСтрока;
    &НаКлиенте
    Процедура выборЦены(Команда)
    // сообщить(ВыделеннаяСтрока.ШКод); ВЫДАЕТ ОШИБКУ
    Парамет = Новый Структура("номенклатура", ВыделеннаяСтрока.номенклатура) ;
    сообщить(парамет.номенклатура) ; // отображает название
    сообщить(ВыделеннаяСтрока.ЦенаРозн); // отображает цену

    КонецПроцедуры
    &НаКлиенте
    Процедура СписокПриАктивизацииСтроки(Элемент)

    ВыделеннаяСтрока = Элемент.ТекущиеДанные;
    Сообщить(Элемент.ТекущиеДанные.номенклатура);

    КонецПроцедуры
  2. Annie
    Offline

    Annie Опытный в 1С Команда форума

    Регистрация:
    10 фев 2010
    Сообщения:
    949
    Симпатии:
    23
    Баллы:
    29
    Для начала было бы неплохо посмотреть отладчиком, что у вас в переменной ВыделеннаяСтрока, при вызове обработчика выборЦены
    И почему сразу при вызове команды не сделать
    Код:
    &НаКлиенте
    Процедура выборЦены(Команда)
    
    ВыделеннаяСтрока = Список.ТекущиеДанные
    // сообщить(ВыделеннаяСтрока.ШКод); ВЫДАЕТ ОШИБКУ
    Парамет = Новый Структура("номенклатура", ВыделеннаяСтрока.номенклатура) ;
    сообщить(парамет.номенклатура) ; // отображает название
    сообщить(ВыделеннаяСтрока.ЦенаРозн); // отображает цену
    
    КонецПроцедуры

Поделиться этой страницей