7.7 Выделение строки

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем Peroman, 12 авг 2009.

  1. TopicStarter Overlay
    Peroman
    Offline

    Peroman Опытный в 1С

    Регистрация:
    26 май 2009
    Сообщения:
    879
    Симпатии:
    13
    Баллы:
    29
    Есть такая внешняя обработка Посмотреть вложение 2519
    Как сделать в этом документе чтобы если в колнке:"Коментарий" есть слово акция
    тогда вся строка выделялась бы другим цветом?

    Вложения:

  2. Хряк
    Offline

    Хряк Профессионал в 1С

    Регистрация:
    26 сен 2007
    Сообщения:
    1.447
    Симпатии:
    37
    Баллы:
    54
    Скопируй секцию строка в таблице, задай ей красный цвет, обзови строкаКр

    При выводе
    Таб.ВывестиСекцию("Строка");
    анализируй комментарий и при надобности выводи
    Таб.ВывестиСекцию("СтрокаКр");
  3. TopicStarter Overlay
    Peroman
    Offline

    Peroman Опытный в 1С

    Регистрация:
    26 май 2009
    Сообщения:
    879
    Симпатии:
    13
    Баллы:
    29
    Мне надо в таблице диалога чтоб подсвечивалось,а не в печатной таблице

    Можно же как то по аналогии как:"выделить НДС 10%"?
  4. dianofob
    Offline

    dianofob (-_-)y-.o0O

    Регистрация:
    3 июл 2009
    Сообщения:
    711
    Симпатии:
    0
    Баллы:
    26
    интересный вопрос... если в таблице на форме есть колонка с комменатрием тогда возможно как-то так:
    Код:
    Процедура Печать()
    Таб=СоздатьОбъект("Таблица");
    Таб.ВывестиСекцию("Шапка");
    НПП=0;
    СуммаUSD=0;
    СуммаEUR=0;
    Суммаруб=0;
    Итог=0;
    ТекстОтбора=ВыбКонтрагент;
    ТД.ВыбратьСтроки();
    Пока ТД.ПолучитьСтроку()=1 Цикл
    НПП=НПП+1;
    СуммаUSD=СуммаUSD+ТД.ВсегоUSD;
    СуммаEUR=СуммаEUR+ТД.ВсегоEUR;
    Суммаруб=Суммаруб+ТД.ВсегоРуб;
    Итог=Итог+ТД.ОбщаяСумма;
    Если Find(ТД.Коментарий, "акция")>0 Тогда
    Таб.BackgroundColor(12345);
    КонецЕсли;
    Таб.ВывестиСекцию("Строка");
    КонецЦикла;
    Таб.ВывестиСекцию("Итого");
    Таб.ТолькоПросмотр(1);
    Таб.Показать("Реестр реализации");
    
    КонецПроцедуры 
    
    
    
    хотя, конечно, могу ошибиться



    в таблице формы нельзя, там нет такого параметра.. можно лишь добавить какую-нибудь пиктограмму в какую нибудь колонку...)
  5. TopicStarter Overlay
    Peroman
    Offline

    Peroman Опытный в 1С

    Регистрация:
    26 май 2009
    Сообщения:
    879
    Симпатии:
    13
    Баллы:
    29
    Еще как можно там же в модуле при выгрузке выгружается колонка коментарий,
    Просто я не понимаю как реализовать тоже самое как при "выделить НДС 10%".
    Я понимаю что нужно поставить флаг в форму там в дополнительно допустим подставить
    Подсветка1() и добавить такую процедуру по аналогии с "выделить НДС 10%",
    но как реализовать чтобы он у меня пробегался по выгруженой таблице в колонке коментарий
    и находил слово акция при чем с учетом того чо перед словом акция стоит еще число. я не знаю.
  6. dianofob
    Offline

    dianofob (-_-)y-.o0O

    Регистрация:
    3 июл 2009
    Сообщения:
    711
    Симпатии:
    0
    Баллы:
    26
    тогда попробуй в Процедура Сформировать()
    Код:
    Если Ставка10=1 тогда 
    ВрТЗ.Цвет  = "BRUSH[16755267]";
    КонецЕсли;
    Если Find(ВрТЗ.Коментарий, "акция")>0 Тогда
    ВрТЗ.Цвет  = "BRUSH[16755267]";
    КонецЕсли;
    
    
    
  7. Хряк
    Offline

    Хряк Профессионал в 1С

    Регистрация:
    26 сен 2007
    Сообщения:
    1.447
    Симпатии:
    37
    Баллы:
    54
    мда... хотелки
    для чё всё это нужно, в конечном итоге
  8. TopicStarter Overlay
    Peroman
    Offline

    Peroman Опытный в 1С

    Регистрация:
    26 май 2009
    Сообщения:
    879
    Симпатии:
    13
    Баллы:
    29
    не получится так как комментарий это не реквизит.а поле ввода в документе "ПакетПродаж".


    Для главбуха ей плохо видно какая заявка проходит по акции а какая нет.
    а так видно будет. :unsure:
  9. dianofob
    Offline

    dianofob (-_-)y-.o0O

    Регистрация:
    3 июл 2009
    Сообщения:
    711
    Симпатии:
    0
    Баллы:
    26
    ну тогда наверное вместо ВрТЗ.Комментарий ВрТЗ.ТекДокумент.Комментарий :)
  10. TopicStarter Overlay
    Peroman
    Offline

    Peroman Опытный в 1С

    Регистрация:
    26 май 2009
    Сообщения:
    879
    Симпатии:
    13
    Баллы:
    29
    Выделяет строки не только с акциями .
    тепер при установке флага на "выделить НДС 10%"
    Выделяются строки и с акциями и с 10%,
    тоже самое происходит, кода ставлю флаг на "выделить акции"
    Почему?
    И что такое Find?
  11. Хряк
    Offline

    Хряк Профессионал в 1С

    Регистрация:
    26 сен 2007
    Сообщения:
    1.447
    Симпатии:
    37
    Баллы:
    54
    Ну а кто будет условие установки флага описывать?
    В приведенном коде этого нет.
    Дерзай
  12. dianofob
    Offline

    dianofob (-_-)y-.o0O

    Регистрация:
    3 июл 2009
    Сообщения:
    711
    Симпатии:
    0
    Баллы:
    26
    все верно, на форме флаг добавляешь для акций.. ну и в процедуре Подсветка прописываешь..
    а вообще тут какая-то внешняя компонента загружена.. нет в обычном 1С смены цвета таблиц формы вроде как... Find() - это Найти().. вместо него еще здесь можно было использовать еще СтрЧислоВхождений()>0
  13. Хряк
    Offline

    Хряк Профессионал в 1С

    Регистрация:
    26 сен 2007
    Сообщения:
    1.447
    Симпатии:
    37
    Баллы:
    54
    Хотелось бы узнать, почему ты занимаешься тем, чего не умеешь.
    Ты не знаешь элементарных вещей. Открывай ЖКК и хотя бы раз прочитай.
    А лучче иди полы мой, будет больше толку.
  14. dianofob
    Offline

    dianofob (-_-)y-.o0O

    Регистрация:
    3 июл 2009
    Сообщения:
    711
    Симпатии:
    0
    Баллы:
    26
    зачем так грубо) человек стремится к знаниям.. видимо нет штатного программиста и обстоятельства вынуждают)
  15. TopicStarter Overlay
    Peroman
    Offline

    Peroman Опытный в 1С

    Регистрация:
    26 май 2009
    Сообщения:
    879
    Симпатии:
    13
    Баллы:
    29
    Хамишь однако,сам чо гением родился?
  16. Andrus_
    Offline

    Andrus_

    Регистрация:
    21 июл 2009
    Сообщения:
    10
    Симпатии:
    0
    Баллы:
    1
    Подключаем 1cpp.dll или FormEx.dll Последних версий
    В глобальном модуле

    Код:
    Функция глПолучитьЦвет(Красный = 0,Зеленый = 0,Синий = 0) Экспорт
    // функция для формирования значения цвета из составляющих (RGB)
    Возврат Макс(0,Синий)*65536 + Макс(0,Зеленый)*256 + Макс(0,Красный);
    КонецФункции
    
    
    На таблицу или на форму вешаем функцию и пишем ее в модуль формы
    глПолучитьЦвет(R,G,B ) и раскрашивай как хочешь
    Код:
    Функция Цвет()
    Если ТЗ.Акция = Перечисление.ДаНет.Да Тогда
    Возврат "FONT["+глПолучитьЦвет(0,0,0)+"] BRUSH["+глПолучитьЦвет(0,0,0)+"]";
    КонецЕсли
    КонецФункции
    
    
    Мы так когда то баловались по крайней мере
  17. Хряк
    Offline

    Хряк Профессионал в 1С

    Регистрация:
    26 сен 2007
    Сообщения:
    1.447
    Симпатии:
    37
    Баллы:
    54
    >человек стремится к знаниям
    Человек стремится к получению результата поставленной ему задачи за чужой счет, не прикладывая к этому ни грамма усилий.
    Можно просить подсказку, алгоритм, и проч. если хочется что-то освоить узнать и т.п.
    Здесь же чел работает с Ашанами, Грандами и т.п., при этом них. не знает и не умеет... и не хочет уметь. А ты ему вынь и положь.
    Нет уж, пусть полы моет
  18. MaxxaM
    Offline

    MaxxaM Опытный в 1С

    Регистрация:
    16 окт 2007
    Сообщения:
    288
    Симпатии:
    2
    Баллы:
    29
    Используй ExtForm там как раз есть такая возможность Сайт 1с ++ :unsure:
  19. TopicStarter Overlay
    Peroman
    Offline

    Peroman Опытный в 1С

    Регистрация:
    26 май 2009
    Сообщения:
    879
    Симпатии:
    13
    Баллы:
    29
    Да я и стремлюсь к знаниям, и не прошу готовых решений я прошу совета т.к. пока не фига особо не въезжаю, а без практики одной теории маловато и под рукой никого нету тобишь помочь некому.
    Плюс ко всему у меня по мимо 1С , ещё работы море(это ты может быть сидишь в носу ковыряешь),
    так что просто не успеваю.
    А вот такие как ты так где то на курсики сгонял и почувствовал себя пупом земли.

Поделиться этой страницей