7.7 Выдает ошибку

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем Sepegka, 23 июл 2008.

  1. TopicStarter Overlay
    Sepegka
    Offline

    Sepegka Опытный в 1С

    Регистрация:
    18 июн 2008
    Сообщения:
    67
    Симпатии:
    0
    Баллы:
    26
    Выдает ошибку

    глПолучитьЦену<<?>>
    Переменная не определена (глПолучитьЦену)

    Вложения:

  2. Stado_adama
    Offline

    Stado_adama Модераторы Модератор

    Регистрация:
    27 ноя 2007
    Сообщения:
    1.086
    Симпатии:
    0
    Баллы:
    26
    глПолучитьЦену у тебя там в формуле или глПолучитьЦену()?
  3. TopicStarter Overlay
    Sepegka
    Offline

    Sepegka Опытный в 1С

    Регистрация:
    18 июн 2008
    Сообщения:
    67
    Симпатии:
    0
    Баллы:
    26
    Код:
    //*****************************************************************************
    // Пересчет(ИмяРеквизита)
    //
    // Параметры:
    //  ИмяРеквизита - Строка. Идентификатор колонки из формулы которой вызывается
    //                 процедура.
    //
    // Вызывается из формул элементов диалога:
    //  Колонка "Товар",
    //  Колонка "Количество",
    //  Колонка "Цена",
    //  Колонка "Сумма",
    //  Колонка "НДС",
    //  Колонка "НП",
    //  Колонка "Всего".
    //
    // Описание:
    //  Пересчитывает значения численных реквизитов табличной части документа.
    //
    Процедура Пересчет(ИмяРеквизита="")
    
    Если ИмяРеквизита = "" Тогда // вызов из формулы колонки табличной части
    ИмяРеквизита = Форма.ТекущаяКолонка();
    КонецЕсли;
    
    Если Товар.Выбран() = 1 Тогда
    Если (ИмяРеквизита = "Товар") Тогда
    **************Цена = глПолучитьЦену(Контекст,Товар,ТипЦен,ДатаДок,Валюта);******************
    //глСуммаДокумента(Контекст, Товар);
    Если Количество <> 0 Тогда
    Пересчет("Цена");
    КонецЕсли;
    ИначеЕсли (ИмяРеквизита = "Количество") Тогда
    Сумма = Цена*Количество;
    РассчитатьНалоги();
    ИначеЕсли (ИмяРеквизита = "Цена") Тогда
    Сумма = Цена*Количество;
    РассчитатьНалоги();
    ИначеЕсли (ИмяРеквизита = "Сумма") Тогда
    РассчитатьНалоги();
    Цена = ?(Количество = 0, Сумма, Сумма/Количество);
    ИначеЕсли (ИмяРеквизита = "НДС") или (ИмяРеквизита = "НП") Тогда
    Всего = глПоказательДокумента(Контекст, "СуммаСНалогами");
    КонецЕсли;
    КонецЕсли;
    
    КонецПроцедуры // Пересчет()
    
    где стоят *********** на этом месте выдает ошибку,что делать?
  4. Stado_adama
    Offline

    Stado_adama Модераторы Модератор

    Регистрация:
    27 ноя 2007
    Сообщения:
    1.086
    Симпатии:
    0
    Баллы:
    26
    глянь есть ли у тебя процедура глПолучитьЦену() в глобальном модуле

Поделиться этой страницей