7.7 Выбрать все файлы из папки

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем Samouchka, 3 апр 2015.

  1. TopicStarter Overlay
    Samouchka
    Offline

    Samouchka Опытный в 1С

    Регистрация:
    20 мар 2013
    Сообщения:
    214
    Симпатии:
    1
    Баллы:
    29
    Как выбрать все файлы из папки? Пытаюсь написать код для выбора всех файлов из папки ДобПапка и добавления их в ТЗ, но вот этот код не рабочий, просьба помочь:

    Код:
    Процедура ДобавитьПапку()
        ДобПапка=СокрЛП(Константа.КаталогФайловЭлПочты);
        ВыбПапка=ФС.ВыбратьКаталог(ДобПапка,"Выберите папку для добавления",);
        Если ВыбПапка=1 Тогда
            ФС.НайтиПервыйФайл(ДобПапка);
            Пока ФС.НайтиСледующийФайл()=1 Цикл
            ИмФайл=ФС.НайтиСледующийФайл();
            ТЗ.НоваяСтрока();
            ТЗ.ПутьФайла=ИмФайл;
            КонецЦикла;
        КонецЕсли;
    КонецПроцедуры
  2. LordMaverick
    Offline

    LordMaverick Профессионал в 1С

    Регистрация:
    17 мар 2014
    Сообщения:
    3.440
    Симпатии:
    374
    Баллы:
    104
    а по такому примеру?
    Код:
    НужныйФайл = фс.НайтиПервыйФайл("*.exe");
    Пока НужныйФайл <> "" Цикл
       Сообщить(НужныйФайл);
       НужныйФайл = ФС.НайтиСледующийФайл();
    КонецЦикла;
    
    --- Объединение сообщений, 3 апр 2015 ---
    http:// kb. mista. ru/ article.php?id=194
    Samouchka нравится это.

Поделиться этой страницей