7.7 Выборка

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем Peroman, 4 июн 2009.

  1. TopicStarter Overlay
    Peroman
    Offline

    Peroman Опытный в 1С

    Регистрация:
    26 май 2009
    Сообщения:
    879
    Симпатии:
    13
    Баллы:
    29
    Помогите кто,чем может. :unsure: Есть внешняя обработка, для проверки на наличие штрихкодов :
    Код:
    //*******************************************
    Процедура Сформировать()  
    
    СпрН=СоздатьОбъект("Справочник.Номенклатура");
    
    
    Таб=СоздатьОбъект("Таблица");
    Таб.ВывестиСекцию("Шапка"); 
    
    СпрН.ВыбратьЭлементы();
    Пока СпрН.ПолучитьЭлемент()=1 цикл
    Если СпрН.ЭтоГруппа()=1 Тогда 
    Наимен=СпрН.Наименование; 
    Таб.ВывестиСекцию("Группа");
    Иначе  
    ШтрихКод=СпрН.БазоваяЕдиница.ШтрихКод;
    Если ПустоеЗначение(ШтрихКод)=1 тогда
    Ном=СпрН.Наименование; 
    Артикул=СпрН.Артикул;
    Таб.ВывестиСекцию("Строка");
    КонецЕсли;
    КонецЕсли;
    
    //	КонецЦикла;
    
    КонецЦикла;
    
    Таб.ТолькоПросмотр(1);                     
    Таб.ПараметрыСтраницы(1,100,1);
    Таб.Показать("");   
    
    КонецПроцедуры
    
    Надо сделать фильтр,чтобы не выводились некоторые позиции и каталоги в справочнике номенклатура и не выводились позиции помеченные на удаление и удаленые.
  2. Хряк
    Offline

    Хряк Профессионал в 1С

    Регистрация:
    26 сен 2007
    Сообщения:
    1.447
    Симпатии:
    37
    Баллы:
    54
    Код:
    Пока СпрН.ПолучитьЭлемент()=1 цикл
    Если СпрН.ПометкаУдаления()=1 Тогда
    Продолжить;
    КонецЕсли;
    Если Найти(СокрЛП(Константа.НеПоказывать), СокрЛП(СпрН.Наименование))<>0 Тогда
    Продолжить;
    КонецЕсли;
    
    Если СпрН.ЭтоГруппа()=1 Тогда 
    
    ...

    Добавь константу, в неё пиши наименования непоказываемых
    Или сам думай как этот признак отслеживать
  3. Vlad
    Offline

    Vlad Модераторы Команда форума Модератор

    Регистрация:
    16 авг 2006
    Сообщения:
    3.517
    Симпатии:
    19
    Баллы:
    29
    Господа, пользутесь тэгами. Хряк, ты-то уж должен это знать.
Похожие темы
  1. Diversant
    Ответов:
    1
    Просмотров:
    573
Загрузка...

Поделиться этой страницей