8.х выборка всех элементов справочников всех справочников и проверка их реквизитов

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем andrenko, 18 янв 2011.

  1. TopicStarter Overlay
    andrenko
    Offline

    andrenko Опытный в 1С

    Регистрация:
    20 ноя 2008
    Сообщения:
    310
    Симпатии:
    0
    Баллы:
    26
    Сабж собственно нужно сделать, а как чотбы руками каждый не прописывать?
  2. shurikvz
    Offline

    shurikvz Модераторы Команда форума Модератор

    Регистрация:
    1 окт 2009
    Сообщения:
    8.410
    Симпатии:
    316
    Баллы:
    104
    Код:
    Для каждого Справочник Из Метаданные.Справочники Цикл
    
    ...
    
    КонецЦикла;
    
    
  3. TopicStarter Overlay
    andrenko
    Offline

    andrenko Опытный в 1С

    Регистрация:
    20 ноя 2008
    Сообщения:
    310
    Симпатии:
    0
    Баллы:
    26
    Ок!
    А как к этому еще пребрать все реквизиты на предмет находящихся в них значений?
  4. shurikvz
    Offline

    shurikvz Модераторы Команда форума Модератор

    Регистрация:
    1 окт 2009
    Сообщения:
    8.410
    Симпатии:
    316
    Баллы:
    104
    Код:
    	Для каждого Справочник Из Метаданные.Справочники Цикл
    
    ВыборкаЭлементы = Справочники[Справочник.Имя].Выбрать();
    Пока ВыборкаЭлементы.Следующий() Цикл
    ОбработкаПрерыванияПользователя();
    
    Для Каждого Реквизит из Справочник.Реквизиты Цикл
    Сообщить("Реквизит: " + Строка(Реквизит) + ", значение: " + Строка(ВыборкаЭлементы[Реквизит.Имя]));
    КонецЦикла;
    
    КонецЦикла;
    
    КонецЦикла;
    
    
  5. TopicStarter Overlay
    andrenko
    Offline

    andrenko Опытный в 1С

    Регистрация:
    20 ноя 2008
    Сообщения:
    310
    Симпатии:
    0
    Баллы:
    26
    Спасибо! Буду пробывать.
    И еще, а можно определить реквизиты с типом "строка"?
  6. shurikvz
    Offline

    shurikvz Модераторы Команда форума Модератор

    Регистрация:
    1 окт 2009
    Сообщения:
    8.410
    Симпатии:
    316
    Баллы:
    104
    andrenko ну блин... :angry: Есть же С-П. :D
    Код:
    Если ТипЗнч(ВыборкаЭлементы[Реквизит.Имя]) = Тип("Строка") Тогда
    ...
    КонецЕсли;
    
  7. TopicStarter Overlay
    andrenko
    Offline

    andrenko Опытный в 1С

    Регистрация:
    20 ноя 2008
    Сообщения:
    310
    Симпатии:
    0
    Баллы:
    26
    Спасибо!
    Я так и сделал, но небыл уверен, что правильно работает:)
  8. TopicStarter Overlay
    andrenko
    Offline

    andrenko Опытный в 1С

    Регистрация:
    20 ноя 2008
    Сообщения:
    310
    Симпатии:
    0
    Баллы:
    26
    а можно как-то выбрать все элементы конфигурации?

Поделиться этой страницей