7.7 выборка в 7.7

Тема в разделе "Типовые решения "1С:Предприятие 7.7"", создана пользователем Snegur, 27 июн 2017.

  1. TopicStarter Overlay
    Snegur
    Offline

    Snegur Опытный в 1С

    Регистрация:
    20 июн 2016
    Сообщения:
    249
    Симпатии:
    0
    Баллы:
    26
    Добрый день
    делаю выгрузку в дбф файл в 1с 7.7 торговли
    подскажите как запустить цикл чтобы номенклатуру перебрать ?
    на 8.3 понятно выборка.следующий и все ,а в 7.7 как ?
    Процедура Сформировать()
    //Создаем объект
    База = СоздатьОбъект("XBASE");


    База.КодоваяСтраница(1);


    База.ДобавитьПоле("kod","s",15,);

    База.ДобавитьПоле("artkl","s",15,);

    База.ДобавитьПоле("Name","s",200,);

    База.ДобавитьПоле("namef","s",200,);

    База.ДобавитьПоле("shtrh","s",20,);

    База.ДобавитьПоле("vid","s",20,);

    База.ДобавитьПоле("ed","s",20,);

    База.ДобавитьПоле("rod","s",20,);


    База.СоздатьФайл("d:\nomkl.dbf");

    ;
    //Создание объекта типа Запрос
    Запрос = СоздатьОбъект("Запрос");
    ТекстЗапроса =
    "//{{ЗАПРОС(запрс)
    |Номенклатура = Справочник.Номенклатура.ТекущийЭлемент;
    |"//}}ЗАПРОС
    ;
    // Если ошибка в запросе, то выход из процедуры
    Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
    Возврат;
    КонецЕсли;

    Пока Цикл
    База.Добавить();
    База.УстановитьЗначениеПоля("kod",Запрос.Номенклатура.Код);
    База.УстановитьЗначениеПоля("artkl",Запрос.Номенклатура.Артикул);
    База.УстановитьЗначениеПоля("Name",Запрос.Номенклатура.Наименование);
    База.УстановитьЗначениеПоля("namef",Запрос.Номенклатура.ПолнНаименование);
    База.УстановитьЗначениеПоля("shtrh",Запрос.Номенклатура.ОсновнаяЕдиница.ШтрихКод);
    База.УстановитьЗначениеПоля("vid",Запрос.Номенклатура.ВидНоменклатуры);
    База.УстановитьЗначениеПоля("ed",Запрос.Номенклатура.БазоваяЕдиница.ОКЕИ.Наименование);
    База.УстановитьЗначениеПоля("rod",Запрос.Номенклатура.Родитель.Код);

    КонецЦикла;

    База.Записать();

    КонецПроцедуры
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    22.452
    Симпатии:
    523
    Баллы:
    204
    Пример
    Код:
    Процедура ИнициироватьDBF()
        DBFБанк = СоздатьОбъект("XBase");
        DBFБанк.ДобавитьПоле("CODE",    "S", 9,  );   
        DBFБанк.ДобавитьПоле("NAME",    "S", 100, );   //Наименование       
        DBFБанк.ДобавитьПоле("mesto",    "S", 50, );   //Местонахождение
        DBFБанк.ДобавитьПоле("adress",    "S", 255, );   //Адрес
        DBFБанк.ДобавитьПоле("kor",    "S",20, );   //КоррСчет       
        DBFБанк.ДобавитьПоле("tlf",    "S", 30, );   //Телефоны   
        DBFБанк.СоздатьФайл(СокрЛП(КаталогВыгрузки)+"Банк.Dbf",СокрЛП(КаталогВыгрузки));
    КонецПроцедуры
    
  3. TopicStarter Overlay
    Snegur
    Offline

    Snegur Опытный в 1С

    Регистрация:
    20 июн 2016
    Сообщения:
    249
    Симпатии:
    0
    Баллы:
    26
    Подскажите пожалуйста как по коду документа найти документ? (на скриншоте это же ИнвентаризацияТМЦ правильно ? а то может и не по тому документу ищу)
    и как перебрать всю табличную часть
    НомерДокумента = "0000000005";
    ДатаДокумента = Дата(17,06,24);
    док=СоздатьОбъект("Документ.ИнвентаризацияТМЦ");
    док.НайтиПоНомеру(НомерДокумента,ДатаДокумента);
    док.ВыбратьСтроки();

    Пока док.ПолучитьСтроку()=1 Цикл

    КонецЦикла;

    Вложения:

    • 2.png
      2.png
      Размер файла:
      101,1 КБ
      Просмотров:
      2
  4. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    22.452
    Симпатии:
    523
    Баллы:
    204
    Вид документа верный (название документа в журнале зависит от реквизита)
    Далее
    Код:
    Док=СоздатьОбъект("Документ.ИнвентаризацияТМЦ");
    Если док.НайтиПоНомеру(НомерДокумента,ДатаДокумента)=0 Тогда
    Возврат;
    КонецЕсли;
    док.ВыбратьСтроки();
    Пока док.ПолучитьСтроку()=1 Цикл
    
    КонецЦикла;

Поделиться этой страницей