7.7 Выборка по справочнику для e-mail рассылки

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем SvitlaChek, 17 авг 2016.

  1. TopicStarter Overlay
    SvitlaChek
    Offline

    SvitlaChek

    Регистрация:
    17 авг 2016
    Сообщения:
    1
    Симпатии:
    0
    Баллы:
    1
    Добрый день!
    Помогите новечку.
    У нас есть справочник "Клиенты", из него необходимо получить
    данные \день рождения, пол, просрочка \ для рассылки поздравительных и
    уведомительных писем.
    Но саму выборку сделать не получается.
    Выбирает или всех, или никого.
    [​IMG]

    Процедура Сформировать()

    ТЗ = СоздатьОбъект ("ТаблицаЗначений");
    ТЗ.НоваяКолонка("ФИО","строка");
    ТЗ.НоваяКолонка("МобТел","Строка");
    ТЗ.НоваяКолонка("Почта","строка");
    ТЗ.НоваяКолонка("Просрочка","Дата");
    ТЗ.НоваяКолонка("ДР","Дата");
    ТЗ.НоваяКолонка("ПолМ","");
    ТЗ.НоваяКолонка("ПолЖ","");
    Спр = СоздатьОбъект ("Справочник.Клиенты");
    Спр.ВыбратьЭлементы();

    Пока Спр.ПолучитьЭлемент() = 1 Цикл

    Если Муж = 1 Тогда
    ТЗ.НоваяСтрока();
    ТЗ.ПолМ = Спр.Пол.Мужской;
    ТЗ.ФИО = СокрЛП(Спр.Фамилия+" "+Спр.Имя+" "+Спр.Отчество);
    ТЗ.МобТел = СокрЛП(Спр.Моб_Тел);
    ТЗ.Почта = СокрЛП(Спр.ЭлектроннаяПочта);

    ИначеЕсли Просрочка = 2 Тогда
    ТЗ.НоваяСтрока();
    ТЗ.Просрочка = СокрЛП(Спр.ДатаУвольнения);
    ТЗ.ФИО = СокрЛП(Спр.Фамилия+" "+Спр.Имя+" "+Спр.Отчество);
    ТЗ.МобТел = СокрЛП(Спр.Моб_Тел);
    ТЗ.Почта = СокрЛП(Спр.ЭлектроннаяПочта);

    ИначеЕсли Жен = 3 Тогда
    ТЗ.НоваяСтрока();
    ТЗ.ПолЖ = Спр.Пол.Женский;
    ТЗ.ФИО = СокрЛП(Спр.Фамилия+" "+Спр.Имя+" "+Спр.Отчество);
    ТЗ.МобТел = СокрЛП(Спр.Моб_Тел);
    ТЗ.Почта = СокрЛП(Спр.ЭлектроннаяПочта);

    ИначеЕсли ДР = 4 Тогда
    ТЗ.ДР = Спр.Дата_рождения;
    Если ТЗ.ДР = ТекущаяДата() Тогда
    ТЗ.НоваяСтрока();
    ТЗ.ФИО = СокрЛП(Спр.Фамилия+" "+Спр.Имя+" "+Спр.Отчество);
    ТЗ.МобТел =СокрЛП(Спр.Моб_Тел);
    ТЗ.Почта = СокрЛП(Спр.ЭлектроннаяПочта);
    КонецЕсли;
    КонецЕсли;
    КонецЦикла;


    ТЗ.Сортировать(СокрЛП("ФИО"));
    ТЗ.Выгрузить(СписокКлиентов);

    КонецПроцедуры
    Последнее редактирование: 17 авг 2016
  2. chehonte
    Offline

    chehonte Опытный в 1С

    Регистрация:
    26 фев 2007
    Сообщения:
    174
    Симпатии:
    0
    Баллы:
    26
    Вродебы чекбокс имеет значение 0 или 1.
    У вас например ИначеЕсли Жен = 3 Тогда
    попробуйте ИначеЕсли Жен = 1 Тогда
  3. Хряк
    Offline

    Хряк Профессионал в 1С

    Регистрация:
    26 сен 2007
    Сообщения:
    1.447
    Симпатии:
    37
    Баллы:
    54
    как по мне, так надо не радио кнопки, а чек боксы
    ну, да ладно
    условия не верные

    если муж=1 тогда
    если спр.пол.мужской=1 тогда // только в этом случае проверяем
    тз.новаястрока

    ну и т.д.

Поделиться этой страницей