8.х Выборка информации

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем OIT, 30 июн 2008.

  1. TopicStarter Overlay
    OIT
    Offline

    OIT Опытный в 1С

    Регистрация:
    7 май 2007
    Сообщения:
    347
    Симпатии:
    0
    Баллы:
    26
    При выполнении запроса выдает сообщение:
    Ошибка при вызове метода контекста(Выполнить)
    Синтаксическая ошибка
    "ХозрасчетныйОстаткиИОбороты.Счет"
    ХозрасчетныйОстаткиИОбороты.Счет КАК Счет
    Скажите пожалуйста в чем дело
    Благодарю Вас
  2. TopicStarter Overlay
    OIT
    Offline

    OIT Опытный в 1С

    Регистрация:
    7 май 2007
    Сообщения:
    347
    Симпатии:
    0
    Баллы:
    26
    Извините другую ошибку

    При выполнении запроса выдает сообщение:
    Ошибка при вызове метода контекста(Выполнить)
    Поле не входит в группу
    "ХозрасчетныйОстаткиИОбороты.Счет"
    ХозрасчетныйОстаткиИОбороты.Счет КАК Счет
    Скажите пожалуйста в чем дело
    Благодарю Вас
  3. BabySG
    Offline

    BabySG Администраторы Команда форума Администратор

    Регистрация:
    10 июн 2007
    Сообщения:
    11.853
    Симпатии:
    12
    Баллы:
    29
    Запрос то покажи
  4. TopicStarter Overlay
    OIT
    Offline

    OIT Опытный в 1С

    Регистрация:
    7 май 2007
    Сообщения:
    347
    Симпатии:
    0
    Баллы:
    26
    Я исправила эту ошибку
    но как правильно выбрать информацию
    в ХозрасчетныеОстаткиИОбороты в СубКонто2 находятся документы Поступление
    товаров и услуг как выбрать информацию только за 2007 год
    Благодарю Вас
  5. LxS
    Offline

    LxS Разработчик

    Регистрация:
    5 апр 2007
    Сообщения:
    680
    Симпатии:
    0
    Баллы:
    26
    Параметры виртуальной таблицы:
    Дата начала;
    Дата окончания.

    Конструктор запроса - правой кнопкой по выбранной таблице.
  6. TopicStarter Overlay
    OIT
    Offline

    OIT Опытный в 1С

    Регистрация:
    7 май 2007
    Сообщения:
    347
    Симпатии:
    0
    Баллы:
    26
    Код:
    Запрос.Текст="ВЫБРАТЬ
    |    ХозрасчетныйОстаткиИОбороты.Субконто2 КАК Субконто2,
    |    СУММА(ХозрасчетныйОстаткиИОбороты.СуммаНачальныйОстатокКт) КАК СуммаНачальныйОстатокКт,
    |    СУММА(ХозрасчетныйОстаткиИОбороты.СуммаОборотДт) КАК СуммаОборотДт,
    |    СУММА(ХозрасчетныйОстаткиИОбороты.СуммаОборотКт) КАК СуммаОборотКт,
    |    СУММА(ХозрасчетныйОстаткиИОбороты.СуммаКонечныйОстатокКт) КАК СуммаКонечныйОстатокКт,
    |    ХозрасчетныйОстаткиИОбороты.Счет,
    |    ХозрасчетныйОстаткиИОбороты.СуммаНачальныйОстатокДт,
    |    ХозрасчетныйОстаткиИОбороты.СуммаКонечныйОстатокДт
    |ИЗ
    |    РегистрБухгалтерии.Хозрасчетный.ОстаткиИОбороты(&Датан, &Датак, Период, 
    , Счет  В ИЕРАРХИИ (&Cчет), , , ,) КАК ХозрасчетныйОстаткиИОбороты
    |ГДЕ
    |    ХозрасчетныйОстаткиИОбороты.Субконто2.Ссылка.ДатаВходящегоДокумента <= &Датап
    |
    |СГРУППИРОВАТЬ ПО
    |    ХозрасчетныйОстаткиИОбороты.Счет,
    |    ХозрасчетныйОстаткиИОбороты.Субконто2,
    |    ХозрасчетныйОстаткиИОбороты.СуммаНачальныйОстатокДт,
    |    ХозрасчетныйОстаткиИОбороты.СуммаКонечныйОстатокДт";
    Запрос.УстановитьПараметр("Счет",ПланыСчетов.Хозрасчетный.НДСпоПриобретеннымЦенностям);
    Запрос.УстановитьПараметр("Датан", НачПериода);  
    Запрос.УстановитьПараметр("Датак", КонПериода); 
    Запрос.УстановитьПараметр("Датап", Дата(2007, 12, 31)); 
    
    Выдает сообщение неверно заданы параметры 
    это после того когда указала счет в иерархии
    а по конкретному счету работало
    Благодарю Вас
    
    
  7. LxS
    Offline

    LxS Разработчик

    Регистрация:
    5 апр 2007
    Сообщения:
    680
    Симпатии:
    0
    Баллы:
    26
    В параметрах Период уберите.
  8. TopicStarter Overlay
    OIT
    Offline

    OIT Опытный в 1С

    Регистрация:
    7 май 2007
    Сообщения:
    347
    Симпатии:
    0
    Баллы:
    26
    Выдает сообщение неверно задан параметр счет
    Благодарю Вас
  9. LxS
    Offline

    LxS Разработчик

    Регистрация:
    5 апр 2007
    Сообщения:
    680
    Симпатии:
    0
    Баллы:
    26
    Тип значения параметра Счет вы какой указали?
  10. TopicStarter Overlay
    OIT
    Offline

    OIT Опытный в 1С

    Регистрация:
    7 май 2007
    Сообщения:
    347
    Симпатии:
    0
    Баллы:
    26
    Когда устанавливаем параметр счета обращаемся к плану счетов и выбираем
    нужный счет и не понятно почему не работает
    Благодарю Вас
  11. LxS
    Offline

    LxS Разработчик

    Регистрация:
    5 апр 2007
    Сообщения:
    680
    Симпатии:
    0
    Баллы:
    26
    Переименуйте название параметра. например счет1

    Код:
    Запрос.Текст="ВЫБРАТЬ
    |	ХозрасчетныйОстаткиИОбороты.Субконто2 КАК Субконто2,
    |	СУММА(ХозрасчетныйОстаткиИОбороты.СуммаНачальныйОстатокКт) КАК СуммаНачальныйОстатокКт,
    |	СУММА(ХозрасчетныйОстаткиИОбороты.СуммаОборотДт) КАК СуммаОборотДт,
    |	СУММА(ХозрасчетныйОстаткиИОбороты.СуммаОборотКт) КАК СуммаОборотКт,
    |	СУММА(ХозрасчетныйОстаткиИОбороты.СуммаКонечныйОстатокКт) КАК СуммаКонечныйОстатокКт,
    |	ХозрасчетныйОстаткиИОбороты.Счет,
    |	ХозрасчетныйОстаткиИОбороты.СуммаНачальныйОстатокДт,
    |	ХозрасчетныйОстаткиИОбороты.СуммаКонечныйОстатокДт
    |ИЗ
    |	РегистрБухгалтерии.Хозрасчетный.ОстаткиИОбороты(&Датан, &Датак, , , Счет В ИЕРАРХИИ (&Счет1), , ) КАК ХозрасчетныйОстаткиИОбороты
    |ГДЕ
    |	ХозрасчетныйОстаткиИОбороты.Субконто2.Ссылка.ДатаВходящегоДокумента <= &Датап
    |
    |СГРУППИРОВАТЬ ПО
    |	ХозрасчетныйОстаткиИОбороты.Счет,
    |	ХозрасчетныйОстаткиИОбороты.Субконто2,
    |	ХозрасчетныйОстаткиИОбороты.СуммаНачальныйОстатокДт,
    |	ХозрасчетныйОстаткиИОбороты.СуммаКонечныйОстатокДт";
    Запрос.УстановитьПараметр("Счет1", ПланыСчетов.Хозрасчетный.НДСпоПриобретеннымЦенностям);
    Запрос.УстановитьПараметр("Датан", НачПериода);
    Запрос.УстановитьПараметр("Датак", КонПериода);
    Запрос.УстановитьПараметр("Датап", Дата(2007, 12, 31));
    
    
  12. TopicStarter Overlay
    OIT
    Offline

    OIT Опытный в 1С

    Регистрация:
    7 май 2007
    Сообщения:
    347
    Симпатии:
    0
    Баллы:
    26
    Когда я указываю счет 19.01 или 19.03 то информация выводится
    если указываю счет 19 в иерархии чтобы получить общую информацию
    по 19.01 и 19.03 вместе то формируется пустая информация
    В чем же здесь причина
    Благодарю Вас
  13. LxS
    Offline

    LxS Разработчик

    Регистрация:
    5 апр 2007
    Сообщения:
    680
    Симпатии:
    0
    Баллы:
    26
    А каким образом обрабатывается таблица, полученная в результате выполнения запроса?
    Выгрузите результаты запроса в таблицу значений, при помощи метода ВыбратьСтроку() посмотрите, действительно ли результат пустой.

    пока мыслей никаких нет. :unsure:
  14. TopicStarter Overlay
    OIT
    Offline

    OIT Опытный в 1С

    Регистрация:
    7 май 2007
    Сообщения:
    347
    Симпатии:
    0
    Баллы:
    26
    Если выборка сделана и из нее необходимо выбрать документы на определенную
    дату , то есть как в условном операторе указать конкретную дату и сравнить ее с датой документов
    Благодарю Вас
  15. TopicStarter Overlay
    OIT
    Offline

    OIT Опытный в 1С

    Регистрация:
    7 май 2007
    Сообщения:
    347
    Симпатии:
    0
    Баллы:
    26
    Запрос.Текст="ВЫБРАТЬ
    | ХозрасчетныйОстаткиИОбороты.Субконто2 КАК Субконто2,
    | СУММА(ХозрасчетныйОстаткиИОбороты.СуммаНачальныйОстатокКт) КАК СуммаНачальныйОстатокКт,
    | СУММА(ХозрасчетныйОстаткиИОбороты.СуммаОборотДт) КАК СуммаОборотДт,
    | СУММА(ХозрасчетныйОстаткиИОбороты.СуммаОборотКт) КАК СуммаОборотКт,
    | СУММА(ХозрасчетныйОстаткиИОбороты.СуммаКонечныйОстатокКт) КАК СуммаКонечныйОстатокКт,
    | ХозрасчетныйОстаткиИОбороты.Счет,
    | ХозрасчетныйОстаткиИОбороты.СуммаНачальныйОстатокДт,
    | ХозрасчетныйОстаткиИОбороты.СуммаКонечныйОстатокДт,
    | ХозрасчетныйОстаткиИОбороты.Субконто1,
    | ХозрасчетныйОстаткиИОбороты.Субконто2.Ссылка.ДатаВходящегоДокумента КАК ДАТАВ
    |ИЗ
    | РегистрБухгалтерии.Хозрасчетный.ОстаткиИОбороты(&Датан, &Датак, Период, , Счет = &Счет, , ) КАК ХозрасчетныйОстаткиИОбороты
    |
    |СГРУППИРОВАТЬ ПО
    | ХозрасчетныйОстаткиИОбороты.Счет,
    | ХозрасчетныйОстаткиИОбороты.Субконто2,
    | ХозрасчетныйОстаткиИОбороты.СуммаНачальныйОстатокДт,
    | ХозрасчетныйОстаткиИОбороты.СуммаКонечныйОстатокДт,
    | ХозрасчетныйОстаткиИОбороты.Субконто1";
    Запрос.УстановитьПараметр("Счет",ПланыСчетов.Хозрасчетный.НДСприПриобретенииОсновныхСредств);
    Запрос.УстановитьПараметр("Датан", НачПериода);
    Запрос.УстановитьПараметр("Датак", КонПериода);

    Табдок = Новый ТабличныйДокумент;
    Макет = ПолучитьМакет("Макет");
    шапка = Макет.ПолучитьОбласть("шапка");
    ТабДок.Вывести(шапка);
    Дата = Макет.ПолучитьОбласть("Дата");
    КонПериода=ДобавитьМесяц(КонПериода, 1);
    месяц=формат(КонПериода,"ДФ=""'на 1 'ММММ ' 'гггг' года'""");
    Дата.Параметры.месяц=месяц;
    ТабДок.Вывести(Дата);
    Заголовок1 = Макет.ПолучитьОбласть("Заголовок1");
    ТабДок.Вывести(Заголовок1);
    СтрокаВывода = Макет.ПолучитьОбласть("СтрокаВывода");

    Выборка = Запрос.Выполнить().Выбрать();
    Пока Выборка.Следующий()Цикл
    Если Год(Выборка.ДАТАВ)< Год(НачПериода) Тогда
    СтрокаВывода.Параметры.ДАТАВ=Выборка.ДАТАВ;
    СтрокаВывода.Параметры.СубКонто1=Выборка.СубКонто1;
    СтрокаВывода.Параметры.СубКонто2=Выборка.СубКонто2;
    СтрокаВывода.Параметры.СуммаНачальныйОстатокКт=Выборка.СуммаНачальныйОстатокКт;
    СтрокаВывода.Параметры.СуммаНачальныйОстатокДт=Выборка.СуммаНачальныйОстатокДт;
    СтрокаВывода.Параметры.СуммаОборотКт=Выборка.СуммаОборотКт;
    СтрокаВывода.Параметры.СуммаОборотДт=Выборка.СуммаОборотДт;
    СтрокаВывода.Параметры.СуммаКонечныйОстатокКт=Выборка.СуммаКонечныйОстатокКт;
    СтрокаВывода.Параметры.СуммаКонечныйОстатокДт=Выборка.СуммаКонечныйОстатокДт;

    ТабДок.Вывести(СтрокаВывода);
    КонецЕсли;
    КонецЦикла;
    Табдок.Показать();
    КонецПроцедуры

    Процедура ВыбПериодНажатие(Элемент)
    НастройкаПериода = Новый НастройкаПериода;
    НачПериода=ТекущаяДата();
    КонПериода=ТекущаяДата();
    НастройкаПериода.УстановитьПериод(НачПериода,, КонПериода);
    НастройкаПериода.РедактироватьКакИнтервал = Истина;
    НастройкаПериода.РедактироватьКакПериод = Истина;
    НастройкаПериода.ВариантНастройки = ВариантНастройкиПериода.Период;
    НастройкаПериода.Редактировать();
    НачПериода = НастройкаПериода.ПолучитьДатуНачала();
    КонПериода = НастройкаПериода.ПолучитьДатуОкончания();
    КонецПроцедуры
    В этом запросе выдает Сообщение
    Преобразование значения к типу Дата не может быть выполнено
    Это в операторе сравнения но как исправить
    Подскажите Пожалуйста
    Благодарю Вас
  16. LxS
    Offline

    LxS Разработчик

    Регистрация:
    5 апр 2007
    Сообщения:
    680
    Симпатии:
    0
    Баллы:
    26
    Пардон, а Вы читаете мои вопросы?
    Таблица после запроса пуста, если вы указываете 19ый?
  17. TopicStarter Overlay
    OIT
    Offline

    OIT Опытный в 1С

    Регистрация:
    7 май 2007
    Сообщения:
    347
    Симпатии:
    0
    Баллы:
    26
    Этот вопрос разрешился я и не поняла в чем дело просто заработал запрос
    а вот в операции сравнения с датой выдает сообщение что преобразование
    не может быть выполнено
    Благодарю Вас за участие
  18. LxS
    Offline

    LxS Разработчик

    Регистрация:
    5 апр 2007
    Сообщения:
    680
    Симпатии:
    0
    Баллы:
    26
    Выорка.ДатаВ принимает значение NULL, которое не может быть преобразовано к типу Дата.
    Поставьте проверку на этот случай. И ошибки не будет.

    И старайтесь код оформлять в соответствующих тегах, читать неудобно.
  19. TopicStarter Overlay
    OIT
    Offline

    OIT Опытный в 1С

    Регистрация:
    7 май 2007
    Сообщения:
    347
    Симпатии:
    0
    Баллы:
    26
    С датой все нормально Огромное Вам спасибо
    но у меня новый вопрс возник
    В справочнике Номенклатурные группы у нас находятся наименование
    заказов в конфигурации 8.0 при выполнении запроса выходили
    а в конфигурации 8.1 исчезли
    Поскажите в чем же дело
    Благодарю Вас
  20. LxS
    Offline

    LxS Разработчик

    Регистрация:
    5 апр 2007
    Сообщения:
    680
    Симпатии:
    0
    Баллы:
    26
    1. Уважаемая OIT! Дабы ваш текст был разборчив, пишите со знаками препинания.
    2. Давайте определимся с понятиями: 8.0 и 8.1 это версии платформы. И к конфигурацям они никакого(почти!) отношения не имеют.
    3. Вы умеете пользоваться отладчиком?
    Без наездов, но по существу.

    Многие проблемные ситуации выявляются при помощи отладчика.
    Можно даже посмотреть на результаты запроса!

    По поводу последнего вопроса. Я не понял ничего. Если не сложно(!) напишите более внятно.

    Ну, и напоследок, кнопка "Огромное Вам спасибо!" находится под каждым моим постом :unsure:

    P.S. Посмотрите в настройку списка в окне справочника. Возможно колонка не отображается, потому что ее отображение отключено. (Это в режиме предприятия).

Поделиться этой страницей