7.7 Выборка элементов из группы

Тема в разделе "Типовые решения "1С:Предприятие 7.7"", создана пользователем Saxarok, 24 май 2009.

  1. TopicStarter Overlay
    Saxarok
    Offline

    Saxarok

    Регистрация:
    31 мар 2009
    Сообщения:
    9
    Симпатии:
    0
    Баллы:
    1
    Добрый вечер!!!
    Помогите пожалуйта допетрать.
    Нужно сдать так: в Справочнике Товары в группе есть флажок "Образец".Если этот флажок установлен(т.е. равен 1), тогда нужно чтобы во всех элементах, приналежащих этой группе тоже Флажок "Образец" стал равен 1(в форме элемнта уже есть Флажок "Образец" )
    Вот эта процедурка,но она немного делает не то и сил уже нет разобраться ПОЧЕМУ!!!!
    Код:
    Процедура ИзмОбраз()
    Товар=СоздатьОбъект("Справочник.Товары");
    Если Образец = 1 тогда
    Если Вопрос("Нужно ли сделать изменение во всех элементах, входящих в эту группу?",
    "Да+Нет") = "Да" тогда
    
    ТекГруппа = Родитель;	  	 
    Товар.ИспользоватьРодителя(ТекГруппа);
    Товар.ВыбратьЭлементы(); 
    Пока Товар.ПолучитьЭлемент() = 1 цикл 
    Состояние("Обработка товара " + Товар);
    Если Товар.Образец = 1 тогда
    Продолжить;
    КонецЕсли;
    Если Товар.ЭтоГруппа() = 1 тогда
    Продолжить;
    КонецЕсли; 
    Если Товар.Родитель <> ТекГруппа тогда
    Продолжить;
    КонецЕсли;
    
    Товар.Образец = 1;
    Товар.Образ = "ОБРАЗЕЦ";
    Товар.Записать();
    КонецЦикла;
    Конецесли;			
    КонецЕсли; 
    КонецПроцедуры
    
    
  2. Kaboom
    Offline

    Kaboom Опытный в 1С

    Регистрация:
    2 июл 2007
    Сообщения:
    158
    Симпатии:
    0
    Баллы:
    26
    Если процедуру размещать в модуле формы группы, тогда измените
    Код:
    ТекГруппа = Родитель;
    
    на
    Код:
    ТекГруппа = ТекущийЭлемент(); 
    
    Дальше, вроде, все верно.
  3. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Ага, если ТекущийЭлемент() является группой....
    Иначе
    ТекущийЭлемент().Родитель
  4. Kaboom
    Offline

    Kaboom Опытный в 1С

    Регистрация:
    2 июл 2007
    Сообщения:
    158
    Симпатии:
    0
    Баллы:
    26

Поделиться этой страницей