7.7 выбор значений по текстовому совпадению в отчет

Тема в разделе "Отчеты и обработки для "1С:Предприятие 7.7"", создана пользователем colanah, 23 фев 2012.

  1. TopicStarter Overlay
    colanah
    Offline

    colanah

    Регистрация:
    23 фев 2012
    Сообщения:
    4
    Симпатии:
    0
    Баллы:
    1
    Здравствуйте.

    Возник вопрос у начинающего 1с'ника)

    Есть Журнал Приходные Накладные, где собственно эти самые накладные создаются.
    Есть Журнал Документов, где выводится список приходных накладных в таблице.
    Хочу сделать Отчет, что бы он выводил мне только те накладные, у которых колонка поставщик содержит тестовое поле "магазин".

    То есть если название поставщика ООО Вася, то не надо выводить, а если Магазин "Лента", то надо.

    Так вот вопрос, каким образом осуществляется доступ к тому месту, где храняться эти самые постащики, это же не реквизит, а какая то временная таблица уже созданная и соответсвенно мы собираемся ее еще раз отсортировать по заданному параметру для отчета.

    Код:
    Процедура ОтчетПоМагазинам()  
    ном_закл = Форма.Закладки.ТекущаяСтрока();	
    Таб = СоздатьОбъект("Таблица");
    Таб.ИсходнаяТаблица("ОтчетПоМагазинам");	  
    прих = СоздатьОбъект("Документ.ПриходнаяНакладная");  
    прих.ВыбратьДокументы(ДатаНач, ДатаКон);  
    пн = 0;
    Пока прих.ПолучитьДокумент() = 1 Цикл  // прих
    
    
    пн = пн + 1;
    
    Если пн = 1 Тогда
    Таб.ВывестиСекцию("Шапка");	
    КонецЕсли;		  
    
    
    Сообщить(прих.Клиент);
    
    Если прих.Клиент = "Магазин" Тогда
    Таб.ВывестиСекцию("ПрихДок");  
    КонецЕсли;
    
    КонецЦикла;	 // прих	  
    Таб.ТолькоПросмотр(1);  
    Таб.ПовторятьПриПечатиСтроки(4,4);
    Таб.Опции(0, 0, 4, 0, "ОтчетПоМагазинам");
    Таб.Показать("ОтчетПоМагазинам","");	  
    Таб.ПараметрыСтраницы(2,100, , 10, 0, 0, 0, 5, 5,  1);	
    
    КонецПроцедуры  
    
    Вот данный код выводит мне одно название магазина во всех колонках, а надо, что бы были соответствующие приходным накладным.

    В таблице вывожу Выражение прих.Клиент.

    Я так понимаю нужен какой то перебор еще добавить?
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Это строка, сформированная из имени того или иного реквизита....
    Если я правильно понял вашу "хочуху", то нужно так:
    Код:
    Процедура ОтчетПоМагазинам()
    ном_закл = Форма.Закладки.ТекущаяСтрока();
    Таб = СоздатьОбъект("Таблица");
    Таб.ИсходнаяТаблица("ОтчетПоМагазинам");  
    прих = СоздатьОбъект("Документ.ПриходнаяНакладная");
    прих.ВыбратьДокументы(ДатаНач, ДатаКон);
    Таб.ВывестиСекцию("Шапка"); //шапку лучше выводить до цикла - пропадает лишнее условие
    Пока прих.ПолучитьДокумент() = 1 Цикл  // прих
    //Сообщить(прих.Клиент);
    Если Найти(ВРег(прих.Клиент.Наименование),"МАГАЗИН")<>0 Тогда
    Таб.ВывестиСекцию("ПрихДок");
    КонецЕсли;
    КонецЦикла;  // прих  
    Таб.ТолькоПросмотр(1);
    Таб.ПовторятьПриПечатиСтроки(4,4);
    Таб.Опции(0, 0, 4, 0, "ОтчетПоМагазинам");
    Таб.Показать("ОтчетПоМагазинам","");  
    Таб.ПараметрыСтраницы(2,100, , 10, 0, 0, 0, 5, 5,  1);
    КонецПроцедуры  
    + неплохо было бы увидеть ваш макет
  3. TopicStarter Overlay
    colanah
    Offline

    colanah

    Регистрация:
    23 фев 2012
    Сообщения:
    4
    Симпатии:
    0
    Баллы:
    1
    Спасибо! Помогло.
  4. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Для "спасибо" есть кнопка.
    Обращайтесь

Поделиться этой страницей