8.х Выбор по умолчанию

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем akelllo, 10 авг 2009.

  1. TopicStarter Overlay
    akelllo
    Offline

    akelllo

    Регистрация:
    26 июл 2009
    Сообщения:
    49
    Симпатии:
    0
    Баллы:
    1
    Подскажите пожалуйста как сделать чтобы тип данных был выставлен по умолчанию.
    Например надо чтобы в форме Телефон, поумолчаниюю стоял "Телефон контрагента"
    Посмотреть вложение 2486

    Вложения:

    • 2342334.JPG
      2342334.JPG
      Размер файла:
      167,8 КБ
      Просмотров:
      61
  2. PavelBaryshev
    Offline

    PavelBaryshev Опытный в 1С

    Регистрация:
    9 сен 2008
    Сообщения:
    316
    Симпатии:
    0
    Баллы:
    26
    как понять по умолчанию?
  3. e.kogan
    Offline

    e.kogan

    Регистрация:
    2 окт 2008
    Сообщения:
    42
    Симпатии:
    0
    Баллы:
    1
    ПриОткрытии формы Если ЭтоНовый() Тогда ВидТелефонаКонтрагента=НужноеЗначение КонецЕсли;

    Ещё можно проверять на незаполненность реквизита (чтобы копирование элементов нормально проходило).
  4. TopicStarter Overlay
    akelllo
    Offline

    akelllo

    Регистрация:
    26 июл 2009
    Сообщения:
    49
    Симпатии:
    0
    Баллы:
    1
    А можно по конкретнее для чайника куда и что вставлять и прописывать.. не получается
  5. wiranata
    Offline

    wiranata Опытный в 1С

    Регистрация:
    21 янв 2009
    Сообщения:
    80
    Симпатии:
    0
    Баллы:
    26
    Ищите в свойствах необходимые обработчики событий (по названию соориентируетесь) у нужных элементов формы, либо самой формы, туда и напишите.
  6. TopicStarter Overlay
    akelllo
    Offline

    akelllo

    Регистрация:
    26 июл 2009
    Сообщения:
    49
    Симпатии:
    0
    Баллы:
    1

    Вложения:

    • 111.JPG
      111.JPG
      Размер файла:
      141,8 КБ
      Просмотров:
      34
  7. PavelBaryshev
    Offline

    PavelBaryshev Опытный в 1С

    Регистрация:
    9 сен 2008
    Сообщения:
    316
    Симпатии:
    0
    Баллы:
    26
    Процедура ПриИзмененииКонтрагент()
    Если ДанныеКонтрагента.Телефон.Пустая() Тогда
    ДанныеКонтрагента.Телефон = Контрагент.Телефон;
    КонецЕсли;
    КонецПроцедуры;

    Наверное примерно так!
  8. TopicStarter Overlay
    akelllo
    Offline

    akelllo

    Регистрация:
    26 июл 2009
    Сообщения:
    49
    Симпатии:
    0
    Баллы:
    1

    ошибку выдаёт - Процедура или функция с указанным именем не определена (ЭтоНовый)

    что забыл сделать?
  9. mialord
    Offline

    mialord Модераторы Команда форума Модератор

    Регистрация:
    31 июл 2009
    Сообщения:
    5.400
    Симпатии:
    40
    Баллы:
    54
    Все на самом деле очень просто...

    Откройте Сервис\Настройка учета\Настройка параметров учета

    На вкладке "Общие", выбирите пункт "Настройка шаблонов "быстрой" регистрации нового контрагента". В результате Вы получите шаблон регистрации конграгента изображенный ниже.

    Заполните шаблон так, как считаете нужно, укажите виды контактной информации, и т.д.

    Вот в принципе и все :) до регистрации информации в справочнике, открывается обработка регистрации, однако она по умолчанию подгружает Ваш шаблон и не кода програмирования. На будущее. Модифицировать конфигурацию стоит лишь в том случае, когда другого выхода просто нет, но при возможности решить вопрос желательно штатными средствами. Ибо рано или поздно конфига настолько будет расходиться с поставкой, что обновления будут занимать непозволительно много времени, а с нашим переменчивым законодательством - это роскошь не позволительная. Удачи!!! :unsure:

    Вложения:

    • 1.JPG
      1.JPG
      Размер файла:
      75,3 КБ
      Просмотров:
      16
    • 1.JPG
      1.JPG
      Размер файла:
      42,6 КБ
      Просмотров:
      20
  10. TopicStarter Overlay
    akelllo
    Offline

    akelllo

    Регистрация:
    26 июл 2009
    Сообщения:
    49
    Симпатии:
    0
    Баллы:
    1
    Сам бы туда некогда не полез))
    Большое спасибо!!!!!

    Для полного удовлетворения хотелось бы добавить 1)Метро 2)Подъезд 3)Этаж 4)Домофон
    и 5) Представление куда всё бы выводилось

    Посмотреть вложение 2530



    квартиру добавил - но там просто дописать одну
    строчку - НоваяЗапись.Поле9 = Запись.КвартираКонтрагента;
    т.к. в "РедактированиеКонтактнойИнформации" поле квартира уже существует
    Посмотреть вложение 2532


    а вот как создать новые
    Скажите самому это реально сделать???(я 0 в конфикурировании)

    Вложения:

    • поля.JPG
      поля.JPG
      Размер файла:
      56,5 КБ
      Просмотров:
      18
    • xxx.JPG
      xxx.JPG
      Размер файла:
      29,5 КБ
      Просмотров:
      38
  11. TopicStarter Overlay
    akelllo
    Offline

    akelllo

    Регистрация:
    26 июл 2009
    Сообщения:
    49
    Симпатии:
    0
    Баллы:
    1
    может есть обработка готовая, для розничных клиентов????
    помогите плз, знаю что работы минут на 5,а что и куда незнаю))))))
  12. mialord
    Offline

    mialord Модераторы Команда форума Модератор

    Регистрация:
    31 июл 2009
    Сообщения:
    5.400
    Симпатии:
    40
    Баллы:
    54
    Дяденька дайте попить, а то есть хочется, даже переночевать негде. :unsure:

    Там не просто, если Вы хотите использовать какие - либо дополнительные реквизиты, то Вам стоит очень серьезно задуматься, а где Вы хотите эту информацию хранить. Существует ряд регистров сведений в которые записываются те, или иные данные.

    Можно, но не желательно, лучше обратитесь к специалистам для решения поставленной задачи. Думаю, при желании Вы сможете сделать самостоятельно, но вопрос качества выполненных работ останется не решенным.
  13. TopicStarter Overlay
    akelllo
    Offline

    akelllo

    Регистрация:
    26 июл 2009
    Сообщения:
    49
    Симпатии:
    0
    Баллы:
    1
    Думаю Вы правы)) каждую минуту приходят мысли по улучшению, хотя все их реализовать всё равно не удастья с моими знаниями. А так хочется и бесплатно))) Большое спасибо!!
Похожие темы
  1. ИринаСМ
    Ответов:
    0
    Просмотров:
    424
Загрузка...

Поделиться этой страницей