[РЕШЕНО] Выбор перечисления

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем kisol, 23 мар 2015.

  1. TopicStarter Overlay
    kisol
    Offline

    kisol Профессионал в 1С

    Регистрация:
    25 июл 2012
    Сообщения:
    394
    Симпатии:
    41
    Баллы:
    54
    Имеется два перечисления, они используются в табличной части документа.
    В каждом перечислении по 2 значения, 1 значение перечисления соответствует 1 значению второго перечисления, а второе второму.

    Как заставить 1с если я выбрал первое перечисление подставить в соседнее поле второе.

    Вложения:

    Последнее редактирование: 23 мар 2015
  2. TopicStarter Overlay
    kisol
    Offline

    kisol Профессионал в 1С

    Регистрация:
    25 июл 2012
    Сообщения:
    394
    Симпатии:
    41
    Баллы:
    54
    Пытаюсь обратиться к реквизитам табличной части в модуле формы, но

    Код:
    &НаКлиенте
      Процедура СоотечественникиТабПриглашениеНаРаботуПриИзменении(Элемент)
        СоотечественникиТабПриглашениеНаРаботуПриИзмененииНаСервере();
      КонецПроцедуры
    &НаСервере
      Процедура СоотечественникиТабПриглашениеНаРаботуПриИзмененииНаСервере()
        Если Объект.СоотечественникиТаб.ПриглашениеНаРаботу = Перечисления.Приглашения.Предоставляется Тогда
        Объект.СоотечественникиТаб.МестоРаботы = Перечисления.МестоРаботы.ГотовыПринять;
            Документы.Исполнение
       
        КонецЕсли;
      КонецПроцедуры

    {Документ.Исполнение.Форма.ФормаДокумента.Форма(37)}: Поле объекта не обнаружено (ПриглашениеНаРаботу)
    Если Объект.СоотечественникиТаб.ПриглашениеНаРаботу = Перечисления.Приглашения.Предоставляется Тогда
  3. TopicStarter Overlay
    kisol
    Offline

    kisol Профессионал в 1С

    Регистрация:
    25 июл 2012
    Сообщения:
    394
    Симпатии:
    41
    Баллы:
    54
    Код:
    &НаКлиенте
      Процедура СоотечественникиТабПриглашениеНаРаботуПриИзменении(Элемент)
         
        ТекущиеДанные = Элементы.СоотечественникиТаб.ТекущиеДанные;
             
        Если ТекущиеДанные.ПриглашениеНаРаботу = ПредопределенноеЗначение("Перечисление.Приглашения.Предоставляется") Тогда
             ТекущиеДанные.МестоРаботы = ПредопределенноеЗначение("Перечисление.МестоРаботы.ГотовыПринять");
        ИначеЕсли
            ТекущиеДанные.ПриглашениеНаРаботу = ПредопределенноеЗначение("Перечисление.Приглашения.ВыбралДругую") Тогда
            ТекущиеДанные.МестоРаботы = ПредопределенноеЗначение("Перечисление.МестоРаботы.НеГотовы");
        КонецЕсли;
      КонецПроцедуры
    
    Ответ получаем через текущие данные

Поделиться этой страницей