7.7 Выбор определенного товара из реализации

Тема в разделе "Отчеты и обработки для "1С:Предприятие 7.7"", создана пользователем PSbest, 15 янв 2010.

  1. TopicStarter Overlay
    PSbest
    Offline

    PSbest

    Регистрация:
    15 янв 2010
    Сообщения:
    26
    Симпатии:
    0
    Баллы:
    1
    Здравствуйте, только начинаю изучение товара и вот возникла проблема..
    задача вывести все реализации и количество одного товара в них
    помогите, как из реализации выбрать определенный товар(по артикулу) и вывести количество этого товара
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Для начала укажите какая у вас конфигурация...
  3. TopicStarter Overlay
    PSbest
    Offline

    PSbest

    Регистрация:
    15 янв 2010
    Сообщения:
    26
    Симпатии:
    0
    Баллы:
    1
    ээ...Торговля и Склад или вам не это нужно? соори но я не сильно понимаю пока
    Вот это то что я сделал...вывожу заявки, реализации если есть для этих заявок и дату отгрузки..теперь нужно как-то проверить есть ли в реализации товар с артикулом напр 588703 и если есть то вывести его количество...



    Код:
    Процедура Сформировать()
    ОчиститьОкноСообщений(); 
    НачДата=01012008;
    КонДата=ТекущаяДата();
    ТЗ.НоваяКолонка("ЗПК",,,,"Заявка");
    ТЗ.НоваяКолонка("Клиент",,,,"Клиент");   
    ТЗ.НоваяКолонка("Реализация",,,,"реализация");
    ТЗ.НоваяКолонка("ОтгрузкаС",,,,"Отгрузка с");
    ТЗ.НоваяКолонка("Товр",,,,"588703");
    Док=СоздатьОбъект("Документ.ЗаявкаПокупателя");
    Док.ВыбратьДокументы(НачДата,КонДата);  
    Пока Док.ПолучитьДокумент()=1 Цикл
    Если Док.ПометкаУдаления()=1 Тогда Продолжить; КонецЕсли;
    ЗПК=Док.ТекущийДокумент();
    Клиент=ЗПК.Контрагент; 
    ОтгрузкаС=ЗПК.ДатаОтгрузки;
    Код=ЗПК.Номенклатура.Код;
    
    ДокПодч = СоздатьОбъект("Документ"); 
    ДокПодч.ВыбратьПодчиненныеДокументы(,,Док);
    Если ДокПодч.Вид()="Реализация" тогда 
    ПодчРеализ=ДокПодч;
    иначе ПодчРеализ="Нет";
    конецесли;
    
    ТЗ.НоваяСтрока();
    ТЗ.ЗПК=ЗПК; 
    ТЗ.Клиент=Клиент; 
    ТЗ.Реализация=ПодчРеализ;
    ТЗ.ОтгрузкаС=ОтгрузкаС;
    
    Конеццикла;	
    ТЗ.Сортировать("+Реализация");
    КонецПроцедуры
    
    
    
    
  4. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Функция вернет количество товара в базовых единицах измерения
    Код:
    Функция ВернутьКоличество(Док,Артикул)
    Кол=0;
    Док.ВыбратьСтроки();
    Пока Док.ПолучитьСтроку()=1 Цикл
    Если Найти(Док.Номенклатура.Артикул,Артикул)<>0 Тогда
    Кол=Кол+Док.Количество*Док.Коэффициент;
    КонецЕсли;
    КонецЦикла;
    Возврат Кол;
    КонецФункции
    
    
  5. TopicStarter Overlay
    PSbest
    Offline

    PSbest

    Регистрация:
    15 янв 2010
    Сообщения:
    26
    Симпатии:
    0
    Баллы:
    1
    Спасибо, буду пробовать что-нито сотворить!

Поделиться этой страницей