7.7 Выбор операций из документов по элементу справочника?

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем Mirvel, 15 апр 2008.

  1. TopicStarter Overlay
    Mirvel
    Offline

    Mirvel

    Регистрация:
    14 апр 2008
    Сообщения:
    10
    Симпатии:
    0
    Баллы:
    1
    У меня стоит вопрос: как сделать Выбор операций из документов по элементу справочника?

    Более детально:

    Имеются однотипные документы... В этих документах есть шапка и табличная часть...в табличной части в поле "Наименование" подставляется значение из справочника "Клиенты"....
    Например:

    ДОКУМЕНТ №1
    Наименование: Кол-во: Цена: Сумма:
    --------------------|------------|----------|-------------|-
    Вова 20 3 60
    Миша 5 3 15
    Сережа 10 6 60
    --------------------|------------|----------|-------------|-




    ДОКУМЕНТ №2
    Наименование: Кол-во: Цена: Сумма:
    --------------------|------------|----------|-------------|-
    Сережа 1 6 6
    Вова 5 5 25
    Аня 20 3 60
    Алексей 4 30 120
    --------------------|------------|----------|-------------|-

    ДОКУМЕНТ №3
    Наименование: Кол-во: Цена: Сумма:
    --------------------|------------|----------|-------------|-
    Вова 5 5 25
    Аня 2 3 6
    Миша 5 3 15
    --------------------|------------|----------|-------------|-

    ===================================================================

    Задача №1: Необходимо сделать так....чтобы я смог посмотреть операции по "Клиенту" - Вова во всех документах....т.е. должен получить следующее....

    Клиент - Вова
    Вова 20 3 60 Документ №1
    Вова 5 5 25 Документ №2
    Вова 5 5 25 Документ №3


    ====================================================================
    Задача №2: Чтобы я мог получить целый список по движениям Клиентов......
    Вова 20 3 60 Документ №1
    Вова 5 5 25 Документ №2
    Вова 5 5 25 Документ №3
    Миша 5 3 15 Документ №...
    Миша 5 3 15 Документ №...
    Аня 2 3 6 Документ №...
    Аня 20 3 60 Документ №...
    Сережа 10 6 60 Документ №...
    Сережа 1 6 6 Документ №...
    ====================================================================
    А вообще было бы очень удобно нажать на элементе справочника....и сразу же получить данные по этому элементу.....
    ====================================================================
  2. Stado_adama
    Offline

    Stado_adama Модераторы Модератор

    Регистрация:
    27 ноя 2007
    Сообщения:
    1.086
    Симпатии:
    0
    Баллы:
    26
    если буха - то через какой счет с субконто контрагент...
    если тис - то через регистр...
  3. Seeker
    Offline

    Seeker

    Регистрация:
    10 апр 2008
    Сообщения:
    19
    Симпатии:
    0
    Баллы:
    1

    Что-то типа этого:
    Код:
    Запрос = СоздатьОбъект("Запрос");
    ТекстЗапроса = "
    |Период с ДатаНач по ДатаКон;
    |ОбрабатыватьДокументы Проведенные;
    |Док = Документ.МойОднотипныйДокумент.ТекущийДокумент;
    |Клиент = Документ.МойОднотипныйДокумент.Клиент;
    |Кво = Документ.МойОднотипныйДокумент.Количество;
    |Цена = Документ.МойОднотипныйДокумент.Цена;
    |Сумма = Документ.МойОднотипныйДокумент.Сумма;
    |
    |Группировка Клиент без групп;
    |Группировка Цена;
    |Группировка Док;
    |";
    
    Запрос.Выполнить(ТекстЗапроса);
    
    Пока Запрос.Группировка(1)=1 Цикл //Получаем по клиентам - они у нас первая группировка
    // Здесь можно вывести шапку клиента, получая его по "Запрос.Клиент"
    Пока Запрос.Группировка(2)=1 Цикл  // По ценам - они ведь могут быть разные
    Пока Запрос.Группировка(3)=1 Цикл  //По документам
    // Здесь можно вывести документы ("Запрос.Док")
    КонецЦикла;
    КонецЦикла;
    КонецЦикла;
    
    
    //Ну, а если по конкретному клиенту, то в текст запроса добавляется
    
    Условие(Клиент=ВыбКлиент);
    
    
    
    ... где ВыбКлиент - переменная, где у тебя твой выбранный клиент.
    Соответственно, ДатаНач, ДатаКон - период, за который выбираешь документы (имена переменных, то есть).

Поделиться этой страницей