8.х Выбор новогосозданного элемента....

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем AugustBlack, 20 мар 2011.

  1. TopicStarter Overlay
    AugustBlack
    Offline

    AugustBlack Опытный в 1С

    Регистрация:
    9 янв 2011
    Сообщения:
    89
    Симпатии:
    0
    Баллы:
    26
    Подскажите как делается такое:
    Есть у мня реквизит с выбором объекта из списка...
    дык вот при определенным условиях мне не нужно выбирать а создать объект и....после нажатия кнопки "Ок" сделать новосозданный выбранным....

    Код:
    Процедура ОбъектНачалоВыбора(Элемент, СтандартнаяОбработка)
    Если ТипЗнч(ЭлементыФормы.Объект.Значение) = Тип("СправочникСсылка.Объекты") Тогда 
    Если(ЭлементыФормы.НаОснованииИзвещения.Значение) = Перечисления.ТипИзвещения.ОНачале Тогда
    СтандартнаяОбработка = Ложь; 
    Режим = РежимДиалогаВопрос.ДаНет;
    Ответ = Вопрос("Создать объект?", Режим, 0,,"Подтверждение..");
    Если Ответ = КодВозвратаДиалога.Да Тогда        СоздатьОбъект=Справочники.Объекты.ПолучитьФормуНовогоЭлемента();
    СоздатьОбъект.Открыть(); //вот тут что то...после заполнения данных о новом объекте,
    //юзер кликает "Ок" или "Записать" и новосозданный объект передается в выбранный....
    
    Иначе
    СтандартнаяОбработка = Истина;
    ОбъектПриИзменении(Элемент);
    Справочники.Объекты.ПолучитьФормуСписка(); //выбор из списка
    
    КонецЕсли;
    КонецЕсли;
    КонецЕсли;
    КонецПроцедуры
    
    
    
    Дайте пример или так скажите...подозреваю чтото тут с модальными окнами или все таки с передачей параметров в окна придется мутится?:(
  2. has
    Offline

    has Опытный в 1С

    Регистрация:
    18 июн 2009
    Сообщения:
    708
    Симпатии:
    0
    Баллы:
    26
    Код:
    Если Ответ = КодВозвратаДиалога.Да Тогда
    СозданныйОбъект=Справочники.Объекты.СоздатьЭлемент();
    //здесь заполняем справочник
    .....
    СозданныйОбъект.Записать();
    //получаем ссылку на созданный элемент
    ВыбранныйОбъект = СозданныйОбъект.Ссылка;
    
    

Поделиться этой страницей