8.х Выбор и получение документа из журнала

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Сорпов, 22 авг 2006.

  1. TopicStarter Overlay
    Сорпов
    Offline

    Сорпов

    Регистрация:
    22 авг 2006
    Сообщения:
    4
    Симпатии:
    0
    Баллы:
    1
    Здравствуйте. Каким образом в 8.0 можно получить в поле выбора документ из заданного журнала документов (т.е. выбрать документ в нужном журнале).
    Спасибо.
  2. 1010011010
    Offline

    1010011010 [1cworld]

    Регистрация:
    1 авг 2006
    Сообщения:
    582
    Симпатии:
    0
    Баллы:
    26
    в смысле, есть формочка на ней поле выбора, есть батон который открывает журнал документов для выбора документа и помещает на него ссылку в поле выбора?

    или просто

    ВыборкаДок = ЖурналыДокументов.Общий.Выбрать();
    ВыборкаДок.ссылка // итд
  3. TopicStarter Overlay
    Сорпов
    Offline

    Сорпов

    Регистрация:
    22 авг 2006
    Сообщения:
    4
    Симпатии:
    0
    Баллы:
    1
    Первый вариант. Есть поле выбора (как вариант, поле ввода с кнопкой выбора). Далее я пишу:

    Код:
    Процедура ДокументНачалоВыбора(Элемент, СтандартнаяОбработка)
    Журнал = ЖурналыДокументов.ОперативныйЖурнал.ПолучитьФорму();
    Журнал.ВладелецФормы = ЭтаФорма;
    Журнал.Открыть();
    КонецПроцедуры
    
    
    
    Журнал-то открывается, а вот как мне из него вернуть выбранный докуммент, вот в чем вопрос... :unsure:
  4. 1010011010
    Offline

    1010011010 [1cworld]

    Регистрация:
    1 авг 2006
    Сообщения:
    582
    Симпатии:
    0
    Баллы:
    26
    хм... пока не нашел, где то рядом блужу.... а вообще самый простой способ через глобальную переменную. пусть журнал пишет в неё выбранный док
  5. TopicStarter Overlay
    Сорпов
    Offline

    Сорпов

    Регистрация:
    22 авг 2006
    Сообщения:
    4
    Симпатии:
    0
    Баллы:
    1
    Хорошо, перефразирую вопрос: создал поле ввода с именем Документ, с типом значения ДокументСсылка. В процедуре НачалоВыбора пишу:

    Код:
    Процедура ДокументНачалоВыбора(СтандартнаяОбработка)
    СтандартнаяОбработка = ложь;    
    ...
    
    КонецПроцедуры
    
    
    
    :unsure:
    Вопрос, что тут дописать, чтобы документ выбирался из заданного журнала? Спасибо.
  6. TopicStarter Overlay
    Сорпов
    Offline

    Сорпов

    Регистрация:
    22 авг 2006
    Сообщения:
    4
    Симпатии:
    0
    Баллы:
    1
    Мдя.. сам же отвечаю... :)

    Код:
    Процедура ДокументНачалоВыбора(СтандартнаяОбработка)
    СтандартнаяОбработка = ложь;    
    Журнал = ЖурналыДокументов.ОперативныйУчет.ПолучитьФорму();
    Журнал.РежимВыбора = истина;
    ЭлементыФормы.Документ = Журнал.ОткрытьФормуМодально();
    КонецПроцедуры
    
    
    
    Все, всем спасибо :)
  7. 1010011010
    Offline

    1010011010 [1cworld]

    Регистрация:
    1 авг 2006
    Сообщения:
    582
    Симпатии:
    0
    Баллы:
    26
    журнал.ТекущийЭлемент.ТекущиеДанные.Ссылка

Поделиться этой страницей