7.7 Выбор группы в справочнике номенклатуры

Тема в разделе "Общие вопросы "1С:Предприятие 7.7"", создана пользователем fob, 18 окт 2009.

  1. TopicStarter Overlay
    fob
    Offline

    fob

    Регистрация:
    22 фев 2007
    Сообщения:
    22
    Симпатии:
    0
    Баллы:
    1
    Здравствуйте. Помогите, плз, а то что-то я жутко туплю :smile:
    1С 7.7 ТиС. На форму кидаю поле "Реквизит диалога" с типом "Справочник.Номенклатура" и хочу что бы в списке номенклатуры можно было вибирать не только единицу номенклатуры, но и группу (как это сделано, например, в разных отчетах, тип "Остатки ТМЦ"). Не могу понять что еще нужно сделать, что бы такая штука получилась - пока что выбирает только конкретные единицы номенклатуры, но не группы.
    Помогите, плз. :unsure:
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Есть 2 варианта:

    1) Использовать процедуру
    Код:
    ПриНачалеВыбораЗначения(Ид,Фл)
    Если Ид="Товар" Тогда
    зн=""
    Если ВВестиЗначение(Зн,"Введите товар/группу","Справочник.Номенклатура")=1 Тогда
    Товар=Зн;
    КонецЕсли;
    Фл=0;
    КонецЕсли;
    КонецПроцедуры
    
    
    
    2) В самом справочнике Номенклатура в модуле формы списка (ДляВыбора) у тебя должно быть:
    Код:
    Процедура ПриОткрытии()
    ...
    ВыборГруппы(<Режим>)
    ...
    КонецПроцедуры
    
    
    
  3. TopicStarter Overlay
    fob
    Offline

    fob

    Регистрация:
    22 фев 2007
    Сообщения:
    22
    Симпатии:
    0
    Баллы:
    1
    Спасибо, но мне понравился другой вариант :unsure:

    Процедура ПриОткрытии() //В форме, из которой вызывается вызов номенклатуры
    Форма.ИдентификаторРеквизита.ВыборГруппы(1)
    КонецПроцедуры

    Спасибо, за участие )))
  4. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    обратите внимание, что метод не всегда должен быть вкючен - иначе группы будут попадать в документы))))))

Поделиться этой страницей