8.х Выбор элементов справочника по реквизиту в поле ввода

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Legion, 30 июл 2009.

  1. TopicStarter Overlay
    Legion
    Offline

    Legion Опытный в 1С

    Регистрация:
    3 мар 2009
    Сообщения:
    57
    Симпатии:
    1
    Баллы:
    29
    Доброго времени суток. Помогите пожалуйста с такой проблемой: в документе нужно выбирать элементы справочника ТипыЦенНоменклатуры со значением реквизита "Стандартный" - Истина.
    Попытка решить задачу - следующая: на форме документа сущ поле ввода, тип значения - справочникссылка.типыценноменклатуры, процедура начала выбора:
    Код:
    Процедура СписокТиповЦенНачалоВыбора(Элемент, СтандартнаяОбработка)
    
    СтандартнаяОбработка = Ложь;
    Форма = Справочники.ТипыЦенНоменклатуры.ПолучитьФорму("ФормаВыбора");
    Форма.ВыборНеСтандартныхТипов = "ага";
    Форма.РежимВыбора = Истина;
    Форма.Открыть();
    
    КонецПроцедуры
    
    
    В Форме выбора справочника ТипыЦенНоменклатуры

    Код:
    Процедура ПередОткрытием(Отказ, СтандартнаяОбработка)
    
    Если НЕ ПустаяСтрока(ВыборНеСтандартныхТипов) Тогда
    СправочникСписок.Отбор.Стандартный.Установить(Ложь);	
    КонецЕсли;
    
    КонецПроцедуры
    
    В итоге при нажатии на выбор (поля ввода) открывается форма выбора справочника, с нужными элементами, но при выборе элемента справочника он не заносится в СписокТиповЦен. Или может есть другой способ решения задачи :unsure:
  2. tirk
    Offline

    tirk Опытный в 1С

    Регистрация:
    1 сен 2008
    Сообщения:
    1.142
    Симпатии:
    0
    Баллы:
    26
    а нет никакого доп ксловия по которому он не заноситься?
    Или может где нить отключачешь СтандартнуюОбработку?
  3. TopicStarter Overlay
    Legion
    Offline

    Legion Опытный в 1С

    Регистрация:
    3 мар 2009
    Сообщения:
    57
    Симпатии:
    1
    Баллы:
    29
    стадартную отключаю
    СтандартнаяОбработка = Ложь; (первый пример кода)
  4. tirk
    Offline

    tirk Опытный в 1С

    Регистрация:
    1 сен 2008
    Сообщения:
    1.142
    Симпатии:
    0
    Баллы:
    26
    когда стандартную отключаешь отклчается и действия при выборе)) Сам теперь прописывай
  5. TopicStarter Overlay
    Legion
    Offline

    Legion Опытный в 1С

    Регистрация:
    3 мар 2009
    Сообщения:
    57
    Симпатии:
    1
    Баллы:
    29
    А для новичка можно подробнее пояснить :unsure:

Поделиться этой страницей