7.7 Выбор элемента спрваочника

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем lamer1C, 13 июн 2007.

  1. TopicStarter Overlay
    lamer1C
    Offline

    lamer1C

    Регистрация:
    26 фев 2007
    Сообщения:
    36
    Симпатии:
    0
    Баллы:
    1
    Пишу следующие инструкции:
    //----------------------------------------------------------------------------
    перем ИмяПотребителя;

    Процедура ПодборСвязи()
    Потребитель=СоздатьОбъект("Справочник.Потребитель");
    Если Потребитель.ВыбратьЭлемент()=1 тогда
    ИмяПотребителя=Потребитель.Наименование;
    КонецЕсли;
    КонецПроцедуры
    //---------------------------------------------------------------------

    При попытке выполнить эту процедуру по нажатии кнопки на форме списка возникает ошибка:
    Если Потребитель.ВыбратьЭлемент()=1 тогда
    {Справочник.Потребитель.ФормаСписка.ФормаСписка.Модуль(5)}: Поле агрегатного объекта не обнаружено (ВыбратьЭлемент)

    Подскажите пожалуйста в чем мои действия неправильны.
  2. Steel Rain
    Offline

    Steel Rain Опытный в 1С

    Регистрация:
    29 сен 2006
    Сообщения:
    408
    Симпатии:
    2
    Баллы:
    29
    Вместо етого надо написать:

    Код:
    Потребитель.ВыбратьЭлементы()
    Пока Потребитель.ПолучитьЭлемент()=1 Цикл
    ИмяПотребителя=Потребитель.Наименование;
    КонецЦикла
    
    Смысл в том, что сначала нужно открыть выборку элементов справочника методом ВыбратьЭлементы(), а уже потом обращаться к этой выборки с помощью других методов работы со справочником. Юзай синтаксис помошник.
  3. TopicStarter Overlay
    lamer1C
    Offline

    lamer1C

    Регистрация:
    26 фев 2007
    Сообщения:
    36
    Симпатии:
    0
    Баллы:
    1
    Спасибо за помощь.

    А вот еще такой вопрос. Как можно сделать так, чтобы в программном модуле получать доступ к полям того справочника, который выделен на форме списка? Т.е. я выделяю, какой-либо элемент справочника и при нажатии на кнопку произвожу нужные мне операции с исползованием значенийй полей данного элемента.
  4. Aptem
    Offline

    Aptem

    Регистрация:
    15 май 2007
    Сообщения:
    38
    Симпатии:
    0
    Баллы:
    1
    в параметр вызова добавь текущийЭлемент, это только для формы списка.
    Например:
    Вызов(ТекущийЭлемент(),1)
    Вызов(ТекущийЭлемент(),2)
    Вызов(ТекущийЭлемент(),3)

    Процедура Вызов(товар,п)
    Если п=1 Тогда
    Сообщить(Товар.ЦенаЗакупки);
    ЕначеЕсли п=2 тогда
    Сообщить(товар.ценаПродажи);
    ИначеЕсли п=3 Тогда
    Сообщить(Товар.ПроцентНаценки);
    КонецЕсли
    КонецПроцедуры

Поделиться этой страницей