8.х Выбор элемента отмеченные

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Drakonchegg, 17 мар 2012.

  1. TopicStarter Overlay
    Drakonchegg
    Offline

    Drakonchegg Опытный в 1С

    Регистрация:
    17 мар 2012
    Сообщения:
    117
    Симпатии:
    0
    Баллы:
    26
    Здравствуйте, что написать на процедуру Выбор, когда элементы отмечены флажками?
  2. vartanet
    Offline

    vartanet Опытный в 1С Команда форума

    Регистрация:
    16 ноя 2010
    Сообщения:
    2.698
    Симпатии:
    15
    Баллы:
    29
    все татарин кроме я.. нефига не понятно - задайте правильно вопрос.
  3. TopicStarter Overlay
    Drakonchegg
    Offline

    Drakonchegg Опытный в 1С

    Регистрация:
    17 мар 2012
    Сообщения:
    117
    Симпатии:
    0
    Баллы:
    26
    Вообщем, когда из справочника выберешь элементы. Там выбирается по одному элементы. Сделал что бы они отмечались по флажкам элементы. Выделил, и нажимаю на кнопку выбрать. Появляется только один элемент. Мне нужно что бы появилось которые отмеченные.
  4. nbIpKuH_BaH9I
    Offline

    nbIpKuH_BaH9I Модераторы Команда форума Модератор

    Регистрация:
    16 сен 2009
    Сообщения:
    6.978
    Симпатии:
    397
    Баллы:
    104
    Где сделал? Здесь телепатов нету. Опиши задачу целиком и полностью. Вопрос очень плохо сформулирован.
  5. TopicStarter Overlay
    Drakonchegg
    Offline

    Drakonchegg Опытный в 1С

    Регистрация:
    17 мар 2012
    Сообщения:
    117
    Симпатии:
    0
    Баллы:
    26
    В поле выборе, выбрать несколько элементов которые отмечены флажками из справочника.
    Код:
    Процедура СправочникСписокПриПолученииДанных(Элемент, ОформленияСтрок)
    
    Для Каждого ОформлениеСтроки Из ОформленияСтрок Цикл
    ДанныеСтроки = ОформлениеСтроки.ДанныеСтроки;
    Если ДанныеСтроки = Неопределено Тогда
    Продолжить;
    Иначе
    Значение = ЗначенияСсылок.Получить(ДанныеСтроки.Ссылка);
    Если Значение = Неопределено Тогда
    Значение = Ложь;
    КонецЕсли;
    ОформлениеСтроки.Ячейки.Флаг.УстановитьФлажок(Значение);
    КонецЕсли;
    КонецЦикла;
    
    КонецПроцедуры[/font][/color]
    [color=#000000][font=verdana]Процедура СправочникСписокПриИзмененииФлажка(Элемент, Колонка)
    
    Если Колонка.Имя = "Флаг" Тогда
    Строка = ЭлементыФормы.СправочникСписок.ТекущиеДанные;
    Если Строка <> Неопределено Тогда
    Значение = ЗначенияСсылок.Получить(Строка.Ссылка);
    Если Значение = Неопределено Тогда
    Значение = Ложь;
    КонецЕсли;
    ЗначенияСсылок.Вставить(Строка.Ссылка, Не Значение);
    КонецЕсли;
    КонецЕсли;
    
    КонецПроцедуры[/font][/color]
    [color=#000000][font=verdana]ЭлементыФормы.СправочникСписок.Колонки.Добавить("Флаг");
    ЗначенияСсылок = Новый Соответствие;

Поделиться этой страницей