7.7 выбор документов в бухгалтерском запросе

Тема в разделе "Отчеты и обработки для "1С:Предприятие 7.7"", создана пользователем Cooper-Mixal, 30 июл 2010.

  1. TopicStarter Overlay
    Cooper-Mixal
    Offline

    Cooper-Mixal Опытный в 1С

    Регистрация:
    29 июн 2008
    Сообщения:
    193
    Симпатии:
    0
    Баллы:
    26
    Добрый день!

    Нужно вытащить в бухгалтерском запросе документы и смотреть в них. Когда делаю такой запрос, показывает только по одному документу, а нужно по всем документам контрагента пройтись.

    Код:
    Ит = СоздатьОбъект("БухгалтерскиеИтоги");
    Ит.ИспользоватьСубконто(ВидыСубконто.Контрагенты,, 1);
    
    
    Ит.ИспользоватьКорСубконто(ВидыСубконто.ВидыНоменклатуры,, 1); 	Ит.ВыполнитьЗапрос(ВыбНачПериода, ВыбКонПериода, "62.1", "90.1.1",, 3,"проводка", "СК");
    Таб.ВывестиСекцию("Заголовок");
    Ит.ВыбратьСубконто(1);
    Пока Ит.ПолучитьСубконто(1) = 1 Цикл 
    Ит.ВыбратьКорСубконто(1, -1, 1);
    Пока Ит.ПолучитьКорСубконто(1) = 1 Цикл  
    Ит.ВыбратьКорСчета(1, 1);
    Пока Ит.ПолучитьКорСчет() = 1 Цикл   
    Док = Ит.Операция.Документ.ТекущийДокумент();  
    Если  (Док.Вид()="РасходнаяНакладная") или (Док.Вид()="ВыполнениеЭтапаРабот") или (Док.Вид()="ОказаниеУслуг")Тогда
    Док.ВыбратьСтроки();
    Пока Док.ПолучитьСтроку()=1 Цикл      
    ТЗ.НоваяСтрока();   
    КонецЦикла;
    Иначе
    Продолжить;
    КонецЕсли;
    КонецЦикла;
    КонецЦикла;
    КонецЦикла; 
    
  2. dedalx7
    Offline

    dedalx7 Опытный в 1С

    Регистрация:
    20 май 2009
    Сообщения:
    97
    Симпатии:
    0
    Баллы:
    26
    Периодичность в ВыполнитьЗапрос() есть, а где сами ВыбратьПериоды() и ПолучитьПериод() дабы перебирать оные проводки?

Поделиться этой страницей