8.х Выбор данных из корня справочника

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем XXL, 10 июл 2009.

  1. TopicStarter Overlay
    XXL
    Offline

    XXL Опытный в 1С Команда форума

    Регистрация:
    22 янв 2007
    Сообщения:
    1.159
    Симпатии:
    19
    Баллы:
    29
    Помогите пожалуйста, что-то с утра думается плохо - как из многоуровневого справочника выбрать элементы, которые лежат в корне, при этом остальные группы и элементы в них находящиеся не должны выбираться?
  2. Tanya_22
    Offline

    Tanya_22 Опытный в 1С

    Регистрация:
    11 янв 2008
    Сообщения:
    68
    Симпатии:
    0
    Баллы:
    26
    Например так:

    Код:
     "ВЫБРАТЬ
    |	Контрагенты.Наименование
    |ИЗ
    |	Справочник.Контрагенты КАК Контрагенты
    |ГДЕ
    |	Контрагенты.Родитель = &Родитель"
    
    В параметр родитель передай пустую ссылку:

    Код:
    Запрос.УстановитьПараметр("Родитель",Справочники.Контрагенты.ПустаяСсылка());
    
  3. TopicStarter Overlay
    XXL
    Offline

    XXL Опытный в 1С Команда форума

    Регистрация:
    22 янв 2007
    Сообщения:
    1.159
    Симпатии:
    19
    Баллы:
    29
    А покороче нельзя без запроса? мне надо выбирать и сразу данные менять, с запросом возиться не хочу.
  4. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.760
    Симпатии:
    509
    Баллы:
    204
    Код:
    Выборка=Справочники.БлаБла.Выбрать();
    Если Выборка.Родитель.Пустая() Тогда
    Сообщить(Выборка.Наименование);
    КонецЕсли;
    
    
    Для изменения данных нужно получать объект:
    Код:
    Выборка=Справочники.БлаБла.Выбрать();
    Пока Выборка.Следующий() Цикл
    Объект=Выборка.ПолучитьОбъект();
    Если Объект.Родитель.Пустая() Тогда
    Сообщить(Выборка.Наименование);
    КонецЕсли;
    КонецЦикла;
    
    
  5. TopicStarter Overlay
    XXL
    Offline

    XXL Опытный в 1С Команда форума

    Регистрация:
    22 янв 2007
    Сообщения:
    1.159
    Симпатии:
    19
    Баллы:
    29
    Объект.Родитель.Пустая() - вот это мне и надо было - спасибо:)
  6. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.760
    Симпатии:
    509
    Баллы:
    204
    На кнопку жми:)
  7. LxS
    Offline

    LxS Разработчик

    Регистрация:
    5 апр 2007
    Сообщения:
    680
    Симпатии:
    0
    Баллы:
    26
    Можно быстрее..

    Код:
    Выб = Справочники.Подразделения.ВыбратьИерархически(Справочники.Подразделения.ПустаяСсылка());
    Пока Выб.Следующий() Цикл
    Сообщить(Выб);
    КонецЦикла;
    
    

Поделиться этой страницей