8.х WEB Вход на веб-сервер

Тема в разделе ""1C:Web-Сервер"", создана пользователем Алексей1989, 27 мар 2012.

  1. TopicStarter Overlay
    Алексей1989
    Offline

    Алексей1989 Опытный в 1С

    Регистрация:
    15 июл 2011
    Сообщения:
    613
    Симпатии:
    0
    Баллы:
    26
    Подскажите, пожалуйста, как мне быть в следующей ситуации: через IIS настроен доступ к 1С через веб-сервер. Но в 1С-ке стоит аутенфикация ОС. Поэтому, когда заходишь в 1С через веб-сервер пароль никто не справшивает. Как можно сделать так, чтобы появлялось стандартное окно с паролем и одновременно с этим оставалась аутенфикация ОС?
  2. BabySG
    Offline

    BabySG Администраторы Команда форума Администратор

    Регистрация:
    10 июн 2007
    Сообщения:
    11.853
    Симпатии:
    12
    Баллы:
    29
    Не очень понятно, что должно происходить для этого случая... Авторизация ОС подразумевает, что не необходимости вводить пароль.
    Проще говоря: это взаимоисключающие пункты (есть, конечно, ситуации, когда будет все равно выдано окно запроса - но это невозможность авторизации).
  3. uza
    Offline

    uza 1С, VBA (EXCEL), VB (.NET + WEB)

    Регистрация:
    10 июл 2007
    Сообщения:
    1.845
    Симпатии:
    1
    Баллы:
    29
    1) В конфигураторе пользователям сделайте смешанный режим авторизации (поставьте гыльдик "Аутентификация 1С" и задайте логин + пароль)
    2) Переопубликуйте 1Ску с убранным флагом "Использовать аутентификацию ОС на веб-сервере"

    Получаем вход через тонкий и толстый клиенты - автоматический, через вебморду - по логину/паролю.

    P.S.
    Это же очевидно!
  4. TopicStarter Overlay
    Алексей1989
    Offline

    Алексей1989 Опытный в 1С

    Регистрация:
    15 июл 2011
    Сообщения:
    613
    Симпатии:
    0
    Баллы:
    26
    Не совсем очевидно. У меня и так нет флага "Использовать аутенфикацию ОС на веб-сервере".
  5. TopicStarter Overlay
    Алексей1989
    Offline

    Алексей1989 Опытный в 1С

    Регистрация:
    15 июл 2011
    Сообщения:
    613
    Симпатии:
    0
    Баллы:
    26
    Все, проблему решил. Оказалось, надо было поставить галочку "Удостоверение пула приложений" в настройках IIS для сайта: Проверка подлинности -- Автономная проверка подлинности.

Поделиться этой страницей