[РЕШЕНО] ВводОстатковТМЦ из Excel

Тема в разделе "Отчеты и обработки для "1С:Предприятие 7.7"", создана пользователем man37, 3 дек 2015.

  1. TopicStarter Overlay
    man37
    Offline

    man37 Опытный в 1С

    Регистрация:
    10 дек 2013
    Сообщения:
    197
    Симпатии:
    5
    Баллы:
    29
    Пытаюсь загрузить начальные остатки из Excel, все работает, документ создается, заполняется, проводится и т.д., НО остатки не добавляются и названия Документа нет (рис.11 и рис.12), хотя таким же образом делал Оприходование, Реализацию, Поступление и т.д., а вот с ВводОстатковТМЦ не получается.
    В чем косяк?
    Код:
    Процедура  Сформировать()
            Попытка
            ExcelApp = СоздатьОбъект("Excel.Application");
        Исключение
            Сообщить(ОписаниеОшибки()+"; программа Excel не установлена на данном компьютере!");
            Возврат;
        КонецПопытки;
        РабочиеКниги=ExcelApp.WorkBooks;
        Попытка
            РабочаяКнига=РабочиеКниги.Open(Файл);
        Исключение
            ExcelApp.Quit();
            Сообщить("Ошибка открытия файла!");
            Возврат;
        КонецПопытки;
        Страница=РабочаяКнига.Worksheets(1);
       
        Спр=СоздатьОбъект("Справочник.Номенклатура");
        Спр.ИспользоватьДату('01.01.1980');
        ОчиститьОкноСообщений();
        Док=СоздатьОбъект("Документ.ВводОстатковТМЦ");
       
        НачатьТранзакцию();
       
       row=0; //номер строки
       /// номера колонок...
       НомКолКодТов=1;
       НомКолНаим=3;
       НомКолЦена=4;
       НомКолКоличество=6;   
      
           //создаем новый документ
           Док.Новый(); 
           Док.УстановитьНовыйНомер(""+СокрЛП(Константа.ПрефиксИБ)+СокрЛП(глПользователь.ОсновнаяФирма.ЮрЛицо.ПрефиксНомеровДокументов));  
           Док.ДатаДок = ТекущаяДата();
           Док.АвтоВремяТекущее(); 
           Док.Фирма=глПользователь.ОсновнаяФирма;
           Док.Склад=глПользователь.ОсновнойСклад;
    //    Док.Валюта=Константа.ВалютаБухУчета;
    //    Док.Курс=1;
          
       для row=ОтСтр по ДоСтр цикл
          
       КодТов=""+ExcelApp.Cells(row,НомКолКодТов).Text;  
       Наим=""+ExcelApp.Cells(row,НомКолНаим).Text; 
       ЦенаЗаказа=СтрЗаменить(""+ExcelApp.Cells(row,НомКолЦена).Text,",",".");   
       КолЗаказа=""+ExcelApp.Cells(row,НомКолКоличество).Text;   
       состояние("идет обработка данных");
       Если ПустоеЗначение(КолЗаказа)=0 Тогда
          
           Если Спр.НайтиПоКоду(КодТов)=1 Тогда 
               //создаем строки документа
            Док.НоваяСтрока();
            Док.Номенклатура=Спр.ТекущийЭлемент();
            Док.Единица=Док.Номенклатура.БазоваяЕдиница;
            Док.Коэффициент=1;
            Док.Количество=КолЗаказа; 
            ЦенаПоСпр=0;
            глВернутьЦену(Док.Номенклатура,Константа.ЗакупочныйТипЦен,ТекущаяДата(), ЦенаПоСпр,Док.Единица,Константа.ВалютаБухУчета);
           
            Док.Сумма=ЦенаПоСпр;
            Док.СуммаРуб=Док.Сумма*Док.Количество;
            Док.Записать();  
    Сообщить ("Строка" + "     " + Наим + "    "+"обработана!");
           КонецЕсли;
          
       КонецЕсли; // есть документ
           
    КонецЦикла;
    Док.Записать();
    ЗафиксироватьТранзакцию();
    Предупреждение("ДОКУМЕНТ ГОТОВ !");
    ОткрытьФорму(Док.ТекущийДокумент());
    
    ExcelApp.WorkBooks.Close();
    
    КонецПроцедуры  
    12.jpg 11.jpg
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    вид операции не указали... Заполните все реквизиты шапки
    man37 нравится это.
  3. TopicStarter Overlay
    man37
    Offline

    man37 Опытный в 1С

    Регистрация:
    10 дек 2013
    Сообщения:
    197
    Симпатии:
    5
    Баллы:
    29
    Спасибо! Тему можно закрывать!
  4. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Не за что... Обращайтесь
Похожие темы
  1. TODD22
    Ответов:
    2
    Просмотров:
    916
  2. Ivan2014
    Ответов:
    12
    Просмотров:
    1.953
Загрузка...

Поделиться этой страницей