7.7 Ввод остатков

Тема в разделе "Обмен данными в "1С:Предприятие 7.7"", создана пользователем Peroman, 2 июл 2009.

  1. TopicStarter Overlay
    Peroman
    Offline

    Peroman Опытный в 1С

    Регистрация:
    26 май 2009
    Сообщения:
    879
    Симпатии:
    13
    Баллы:
    29
    Помогите с вводом остатков для ТиС.Есть ли внешняя обработочка для ввода остатков из документа остаткиТМЦ,желательно текстового, одним документом
    из Тис в ТиС,стандартная свертка не канает т.к. база вся кривая,через пару месяцев перейдем на новую.
  2. WaRDeR
    Offline

    WaRDeR Модераторы Команда форума Модератор

    Регистрация:
    23 ноя 2006
    Сообщения:
    3.263
    Симпатии:
    14
    Баллы:
    29
    Ну если стандартная не подходит, значит надо писать свою...
  3. TopicStarter Overlay
    Peroman
    Offline

    Peroman Опытный в 1С

    Регистрация:
    26 май 2009
    Сообщения:
    879
    Симпатии:
    13
    Баллы:
    29
    Я бы рад написать свою,но неумею,поэтому и прошу помощи, т.к. я в процессе обучения(с нуля :unsure: )
  4. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Пиши, работай, задавай вопросы что не получается. ЗА БЕСПЛАТНО для тебя ПОЛНОСТЬЮ никто писать не будет.
  5. TopicStarter Overlay
    Peroman
    Offline

    Peroman Опытный в 1С

    Регистрация:
    26 май 2009
    Сообщения:
    879
    Симпатии:
    13
    Баллы:
    29
    Вот переделал стандартную,чтобы грузить остатки из эксель.
    Доходит до определенной строки и выдает ошибку
    и выдает кучу пустых строкс названием позиции в номенклатуре.

    Код:
    	Если ФС.ВыбратьФайл(0,ИмяФайла,ИмяПути,,"*.xls",,)=0 Тогда
    Возврат
    КонецЕсли;
    ПутьФ=ИмяПути+ИмяФайла;
    ЭкселФ = СоздатьОбъект("Excel.Application"); //создаем объект
    НашФайл = ЭкселФ.Workbooks.Open(СокрЛП(ПутьФ)); //Открываем файл
    НашЛист = НашФайл.Sheets(1); //Устанавливаем нужный лист  
    
    стр=2;
    Пока НашЛист.Cells(стр,1).Value<>"" Цикл
    //Сообщить("строка "+i+" из "+КонечнаяСтрока+" - "+НашЛист.Cells(i,1).Value);
    Арт = НашЛист.Cells(стр,2).Value;
    Если СпрН.НайтиПоРеквизиту("Артикул",Арт,1)=1 Тогда  
    Состояние(СпрН.Наименование);
    НоваяСтрока();        
    ВидТМЦ       = Перечисление.ВидыТМЦ.Товар;
    Номенклатура = СпрН.ТекущийЭлемент(); 
    ПриИзмененииНоменклатуры();
    Количество   = НашЛист.Cells(стр,3).Value;
    Сумма		 = глПолучитьЦену(Номенклатура, ТипЦен, ДатаДок)*Количество;
    Иначе
    Сообщить("Товар "+НашЛист.Cells(стр,1).Value+" не найден, строка -"+стр);  						
    КонецЕсли;	
    стр=стр+1;
    КонецЦикла;	
    ЭкселФ.WorkBooks.close();
    ЭкселФ.Quit();	
    ЭкселФ="";
    ЗаполнитьГТД();
    Сообщить("Загрузка завершена!");  						
    
    КонецПроцедуры	//ЗагрузитьИзФайла()
    
    
    Что здесь не так?
  6. tirk
    Offline

    tirk Опытный в 1С

    Регистрация:
    1 сен 2008
    Сообщения:
    1.142
    Симпатии:
    0
    Баллы:
    26
    а может быть у вас не пустая строка а что то типа " " (т.е. с пробелом?)
  7. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Код:
    Пока СокрЛП(НашЛист.Cells(стр,1).Value)<>"" Цикл
    
    
  8. tirk
    Offline

    tirk Опытный в 1С

    Регистрация:
    1 сен 2008
    Сообщения:
    1.142
    Симпатии:
    0
    Баллы:
    26
    Ну зачем же код? )) Пускай бы сам попробовал))

Поделиться этой страницей