8.х Вставка картинки

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем brahitoz, 31 окт 2006.

  1. TopicStarter Overlay
    brahitoz
    Offline

    brahitoz

    Регистрация:
    28 окт 2006
    Сообщения:
    2
    Симпатии:
    0
    Баллы:
    1
    Подскажите пожалуйста кто знает: задача такая была-в табличное поле списка документов добавить колонку показывающую состояние отгрузки товара... ну я сделал поле ввода и в зависимости от результат запроса по остаткам вывожу в поле либо отгружен, либо не отгружен, либо готов к отгрузке, ну так вот , начальник сказал чтобы вместо текста были 3 картинки... я начинающий программер и чет не получается их вставить текст модуля таков:
    Процедура СписокПриВыводеСтроки(Элемент, ОформлениеСтроки, ДанныеСтроки)
    // Вставить содержимое обработчика.
    ГалкаСтоит=ДанныеСтроки.ГотовКОтгрузке;
    Запрос=Новый Запрос;
    Запрос.Текст=
    "ВЫБРАТЬ
    | ЗаказыПокупателейОстаткиИОбороты.КоличествоКонечныйОстаток как кол
    |ИЗ
    | РегистрНакопления.ЗаказыПокупателей.ОстаткиИОбороты(, , , , ЗаказПокупателя = &Заказ) КАК ЗаказыПокупателейОстаткиИОбороты";
    Запрос.УстановитьПараметр("Заказ",ДанныеСтроки.Ссылка);
    РезультатЗапроса=Запрос.Выполнить().Выбрать();
    счетчик=0;
    Пока РезультатЗапроса.Следующий() Цикл
    если РезультатЗапроса.кол<>0 тогда
    счетчик=1;
    КонецЕсли;
    КонецЦикла;
    Если счетчик=0 тогда
    Значение="Отгружен";
    ОформлениеСтроки.Ячейки.Колонка1.Текст=значение;
    ИначеЕсли ГалкаСтоит тогда
    Значение="Готов к отгрузке";
    ОформлениеСтроки.Ячейки.Колонка1.Текст=значение;
    Иначе Значение="Не готов к отгрузке";
    ОформлениеСтроки.Ячейки.Колонка1.Текст=значение;
    КонецЕсли;

    КонецПроцедуры
    Что посоветуют мне асы 1с программирования????
    з.ы. ну не могу я найти влитературе как картинки в поля вставлять... помогите плиз! спс всем кто откликнется...
  2. Prospero
    Offline

    Prospero Опытный в 1С

    Регистрация:
    13 сен 2006
    Сообщения:
    111
    Симпатии:
    0
    Баллы:
    26
    Мож это тебе нуно?

    <КолонкаТабличногоПоля>
    Свойство:
    КартинкиСтрок (LinesPictures)
    Использование:
    Чтение и запись.
    Описание:
    Тип: Картинка. Содержит картинку, которая может выводиться в поле данных колонки.
    Примечание:
    Рекомендуемый размер картинки 14х14 пикселей.
    или
    <ОформлениеЯчейки>
    Определяет оформление ячейки табличного документа. Исполь­зуется для определения свойства Ячейки объекта ОформлениеСтроки.

    Свойство:
    Картинка (Picture)
    Использование:
    Чтение и запись.
    Описание:
    Тип: Картинка. Содержит картинку, выводимую в ячейке.
    Примечание:
    Рекомендуемый размер картинки 14х14 пикселей.
  3. TopicStarter Overlay
    brahitoz
    Offline

    brahitoz

    Регистрация:
    28 окт 2006
    Сообщения:
    2
    Симпатии:
    0
    Баллы:
    1
    спс... в УТ нашел как это сделано... в справочнике контрагенты...

Поделиться этой страницей