8.х Вставка фотографии

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Necrodamus, 23 окт 2008.

  1. TopicStarter Overlay
    Necrodamus
    Offline

    Necrodamus Опытный в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    57
    Симпатии:
    0
    Баллы:
    26
    Объясните,пожалуйста,каким образом в карточку сотрудника можно было добавить его фотографию.
  2. Senya
    Offline

    Senya Опытный в 1С

    Регистрация:
    6 июн 2006
    Сообщения:
    594
    Симпатии:
    0
    Баллы:
    26
    Добавьте реквизит с типом ХранилищеЗначения и пищите туда на здоровье любой файл. Кстати , например в УПП у элемента справочника ФизическиеЛица есть реквизит ОсновноеИзображение, в котором и может храниться фотография. Думаю подобный реквизит присутствует и в других конфигурациях.
  3. TopicStarter Overlay
    Necrodamus
    Offline

    Necrodamus Опытный в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    57
    Симпатии:
    0
    Баллы:
    26
    У меня "Бухгалтерия для Украины".Там не нашел.
    Мне бы пример... :unsure:
  4. BabySG
    Offline

    BabySG Администраторы Команда форума Администратор

    Регистрация:
    10 июн 2007
    Сообщения:
    11.853
    Симпатии:
    12
    Баллы:
    29
    В любой типовой (Российской) посмотри справочник номенклатуры - там есть
  5. TopicStarter Overlay
    Necrodamus
    Offline

    Necrodamus Опытный в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    57
    Симпатии:
    0
    Баллы:
    26
    Нет у меня российской.Я на Украине живу :unsure: И конфигурация у меня соответствующая...Нет в Номенклатуре такого примера... :smile:
  6. TopicStarter Overlay
    Necrodamus
    Offline

    Necrodamus Опытный в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    57
    Симпатии:
    0
    Баллы:
    26
    Скопируйте,пожалуйста,сюда эту процедуру...Кто-нибудь...
  7. BabySG
    Offline

    BabySG Администраторы Команда форума Администратор

    Регистрация:
    10 июн 2007
    Сообщения:
    11.853
    Симпатии:
    12
    Баллы:
    29
    Там весь справочник надо копировать + еще один + модуль + еще один.

    Поэтому либо покупаем литературу, либо идем на варез :)
  8. TopicStarter Overlay
    Necrodamus
    Offline

    Necrodamus Опытный в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    57
    Симпатии:
    0
    Баллы:
    26
    Надеюсь кому-то пригодится:
    Код:
     Процедура ОтобразитьКартинку() 
    ЗначениеКартинки = Фотография.Получить();
    Если ЗначениеКартинки <> Неопределено Тогда 
    ЭлементыФормы.Фото.Картинка = ЗначениеКартинки; 
    Иначе 
    ЭлементыФормы.Фото.Картинка = Новый Картинка(Неопределено); 
    КонецЕсли; 
    КонецПроцедуры
    
    Код:
    Процедура ДобавитьФото(Элемент)
    ДиалогВыбораФайла = Новый 
    ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Открытие); 
    ДиалогВыбораФайла.Каталог = ""; 
    ДиалогВыбораФайла.ПредварительныйПросмотр = Истина; 
    ДиалогВыбораФайла.Фильтр = 
    "Все картинки (*.bmp;*.dib;*.rle;*.jpg;*.jpeg;*.tif;*.gif;*.png;*.ico;*.wmf;*.emf)|*.bmp;*.dib;*.rle;*.jpg;*.jpeg;*.tif;*.gif;*.png;*.ico;*.wmf;*.emf|" 
    + "Формат bmp (*.bmp;*.dib;*.rle)|*.bmp;*.dib;*.rle|"
    + "Формат JPEG (*.jpg;*.jpeg)|*.jpg;*.jpeg|"
    + "Формат TIFF (*.tif)|*.tif|"
    + "Формат GIF (*.gif)|*.gif|"
    + "Формат PNG (*.png)|*.png|"
    + "Формат icon (*.ico)|*.ico|"
    + "Формат метафайл (*.wmf;*.emf)|*.wmf;*.emf|";
    Если ДиалогВыбораФайла.Выбрать() Тогда 
    Файл = Новый Файл(ДиалогВыбораФайла.ПолноеИмяФайла); 
    Фотография = Новый ХранилищеЗначения(Новый Картинка(ДиалогВыбораФайла.ПолноеИмяФайла)); 
    ОтобразитьКартинку(); 
    КонецЕсли; 	
    
    КонецПроцедуры;
    
    
    Где - Фотография - ХранилищеДанных, Фото - поле картинки...
  9. Elvisnya
    Offline

    Elvisnya

    Регистрация:
    30 сен 2010
    Сообщения:
    29
    Симпатии:
    0
    Баллы:
    1
    Объясните пожалуйста, что записано в Неопределено? А то как то странно сначала сравниваем с Неопределено, а потом передаём его для создания картинки.
    Код:
    ЭлементыФормы.Фото.Картинка = Новый Картинка(Неопределено); 
    
    А зачем эта строка? Ведь мы переменую с именем Файл потом негде не используем.
    Код:
    Файл = Новый Файл(ДиалогВыбораФайла.ПолноеИмяФайла);
    

Поделиться этой страницей