7.7 всем привет

Тема в разделе "Отчеты и обработки для "1С:Предприятие 7.7"", создана пользователем ZEMA, 5 окт 2007.

  1. TopicStarter Overlay
    ZEMA
    Offline

    ZEMA Опытный в 1С

    Регистрация:
    5 окт 2007
    Сообщения:
    231
    Симпатии:
    0
    Баллы:
    26
    НУ А ТОГДА ГДЕ МОЯ ОШИБКА, ПОЧЕМУ ПИШЕТ: "ПОЛЯ АГРЕГ. ОБЪЕКТА НЕ ОБНАРУЖЕНО(СОРТИРОВАТЬ) :unsure:

    Процедура Сформировать()
    Перем Пере,Запрос, ТекстЗапроса, Ист;

    Т = СоздатьОбъект("ТаблицаЗначений");

    Т.НоваяКолонка("Контрагент","Справочник.Контрагенты");
    Т.НоваяКолонка("Сумма","Число",15,2);
    Т.НоваяКолонка("Ра","Документ.ПлатежноеПоручение");

    Ра= СоздатьОбъект("Документ.ПлатежноеПоручение");
    Ра.ВыбратьДокументы(ВыбНачПериода,ВыбКонПериода);
    Таб = СоздатьОбъект("Таблица");
    Таб.ВывестиСекцию("Шапка");
    Т.Сортировать("Сумма");
    i=0;
    Пока Ра.ПолучитьДокумент()=1 Цикл
    Если ВыбКлиент.Принадлежит(Ра.ТекущийДокумент().Контрагент)=0 Тогда
    Продолжить;
    КонецЕсли;
    Т.НоваяСтрока();
    Т.Сортировать("Сумма");
    ПечКон= Ра.Контрагент;
    ПечСум=Ра.Сумма;
    ПечДок=Ра.ТекущийДокумент();
    i=i+1;
    Таб.ВывестиСекцию("Текущийдокумент");
    КонецЦикла;
    Таб.Опции(1, 1, 0, 0);
    Таб.ТолькоПросмотр(1);
    Таб.Показать("Сформировать", "");
    КонецПроцедуры B)
  2. Steel Rain
    Offline

    Steel Rain Опытный в 1С

    Регистрация:
    29 сен 2006
    Сообщения:
    408
    Симпатии:
    2
    Баллы:
    29
    Сортировать(<?>,);
    Синтаксис:
    Сортировать(<Колонки>,<ДокумПоДате>)
    Назначение:
    Сортировать таблицу значений по колонкам.
    Параметры:
    <Колонки> - строковое выражение, которое определяет колонки, порядок и направление сортировки. Формат передаваемой строки - это разделенные запятыми номера или идентификаторы колонок со знаком направления сортировки ( ''+'' - сортировать по возрастанию; ''- '' - сортировать по убыванию; ''*'' - сортировать по внутреннему значению). Знак направления сортировки можно указывать до или после обозначения колонки через пробел или без пробела. По умолчанию направление сортировки принимается по возрастанию.
    <ДокумПоДате> - необязательный параметр. Имеет смысл только в том случае, если значениями таблицы значений являются документы. В этом случае можно задавать сортировку документов по их хронологии. Число: 1 - сортировка по хронологии документов; 0 - нет. Значение по умолчанию - 0.

    Пример:
    ТаблицаСДаннымиЗапроса.Сортировать("Контрагент");

    А вообще для этого используется Группировка в запросе.
  3. iliabvf
    Offline

    iliabvf

    Регистрация:
    4 сен 2007
    Сообщения:
    30
    Симпатии:
    0
    Баллы:
    1
    Земфира ? ты ?
  4. TopicStarter Overlay
    ZEMA
    Offline

    ZEMA Опытный в 1С

    Регистрация:
    5 окт 2007
    Сообщения:
    231
    Симпатии:
    0
    Баллы:
    26
    нет ZEMA :unsure:
  5. Steel Rain
    Offline

    Steel Rain Опытный в 1С

    Регистрация:
    29 сен 2006
    Сообщения:
    408
    Симпатии:
    2
    Баллы:
    29
    Код:
    Т.НоваяКолонка("Контрагент","Справочники.Контрагенты");
    
    Не "Справочники", а Справочник.Контрагенты. Неверный тип реквизита, вот и не находит поле агрегатного объекта.

    Код:
    i=i+1;
    Т.Сортировать("Контрагент"); 
    
    Сортировку лучше сделать ДО цикла.

    И самое главное... ГДЕ ЗАПОЛНЕНИЕ ТАБЛИЦЫ!? Что ты собираешься сортировать, если там данных нет?!

Поделиться этой страницей