7.7 Время проведения документа в 7.7 тис

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем IKARS, 12 фев 2013.

  1. TopicStarter Overlay
    IKARS
    Offline

    IKARS

    Регистрация:
    20 апр 2012
    Сообщения:
    49
    Симпатии:
    0
    Баллы:
    1
    Как поменять время проведения документа в 7.7 тис при поступлении тмц..Нужно чтобы сразу ставилось в начало дня. Заранее спасибо
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    1) можно в модуле формы прописать
    Код:
    Процедура ВводНового()
    ..
    АвтоВремяНачалоДня()
    ...
    КонецПроцедуры
    2) Обработкой. Юзаем
    Код:
    УстановитьВремя
  3. TopicStarter Overlay
    IKARS
    Offline

    IKARS

    Регистрация:
    20 апр 2012
    Сообщения:
    49
    Симпатии:
    0
    Баллы:
    1
    где прописать эту форму??
  4. Vlad
    Offline

    Vlad Модераторы Команда форума Модератор

    Регистрация:
    16 авг 2006
    Сообщения:
    3.517
    Симпатии:
    19
    Баллы:
    29
    В Конфигураторе. Находишь документ Поступление ТМЦ. Открываешь форму. В модуле находишь процедуру ВводНового().
  5. TopicStarter Overlay
    IKARS
    Offline

    IKARS

    Регистрация:
    20 апр 2012
    Сообщения:
    49
    Симпатии:
    0
    Баллы:
    1
    // Документы оптовой торговли можно оформлять только с оптового склада
    Если (Склад.РозничныйСклад = 1) Тогда
    Склад = "";
    КонецЕсли;


    КонецПроцедуры //ВводНового()
    нашел а дальше что??
  6. Vlad
    Offline

    Vlad Модераторы Команда форума Модератор

    Регистрация:
    16 авг 2006
    Сообщения:
    3.517
    Симпатии:
    19
    Баллы:
    29
    Вот между
    КонецЕсли и КонецПроцедуры вставляешь

    АвтоВремяНачалоДня()
  7. TopicStarter Overlay
    IKARS
    Offline

    IKARS

    Регистрация:
    20 апр 2012
    Сообщения:
    49
    Симпатии:
    0
    Баллы:
    1
    СПАСИБО

Поделиться этой страницей