8.х ВПФ_УпаковочныйЛист

Тема в разделе "Отчеты и обработки для "1С:Предприятие 8"", создана пользователем webmastersb, 2 май 2014.

  1. TopicStarter Overlay
    webmastersb
    Offline

    webmastersb

    Регистрация:
    2 май 2014
    Сообщения:
    6
    Симпатии:
    0
    Баллы:
    1
    Здравствуйте!

    Только начал изучать 1с на уровне программирования.
    Потребовался документ Упаковочный лист.
    Решил попробовать сделать внешнюю форму
    Делал не на запросах, а с помощью СсылкаНаОбъект.

    В самом конфигураторе при проверке кода ошибок не найдено. Когда добавляю в 1с предприятие 8.3 УТ11 Возникает ошибка
    Метод объекта не обнаружен Печать
    Вот код
    Процедура Печать(МассивОбъектов, КоллекцияПечатныхФорм, ОбъектыПечати, ПараметрыВывода) Экспорт
    Если УправлениеПечатью.НужноПечататьМакет(КоллекцияПечатныхФорм, "УпаковочныйЛист") Тогда
    УправлениеПечатью.ВывестиТабличныйДокументВКоллекцию(КоллекцияПечатныхФорм, "УпаковочныйЛист", СформироватьПечатнуюФорму("УпаковочныйЛист", МассивОбъектов, ОбъектыПечати));
    КонецЕсли;
    КонецПроцедуры // Печать()

    Функция СформироватьПечатнуюФорму(Тип, МассивОбъектов, ОбъектыПечати)


    ТабДок = Новый ТабличныйДокумент;

    Макет = ПолучитьМакет("УпаковочныйЛист");

    СекцияШапка = Макет.ПолучитьОбласть("Шапка");

    СекцияТело = Макет.ПолучитьОбласть("Тело");

    СекцияПодвал = Макет.ПолучитьОбласть("Подвал");

    СекцияЗаголовок = Макет.ПолучитьОбласть("Заголовок");

    СекцияСтрока = Макет.ПолучитьОбласть("Строка");

    СекцияПодвалТаб = Макет.ПолучитьОбласть("ПодвалТаб");

    СекцияШапка.Параметры.Организация = СсылкаНаОбъект.Организация;
    СекцияШапка.Параметры.номер = СсылкаНаОбъект.Номер;
    СекцияШапка.Параметры.Дата = СсылкаНаОбъект.Дата;
    ТабДок.Вывести("СекцияШапка");

    СекцияТело.Параметры.Покупатель = СсылкаНаОбъект.Контрагент;
    СекцияТело.Параметры.АдресДоставки = СсылкаНаОбъект.АдресДоставки;
    ТабДок.Вывести("СекцияТело");

    ТабДок.Вывести("СекцияЗаголовок");

    Для каждого СтрТаб из СсылкаНаОбъект.Товары Цикл

    ЗаполнитьЗначенияСвойств(СекцияСтрока.Параметры,СтрТаб);
    ТабДок.Вывести("СекцияСтрока");

    КонецЦикла;

    СсылкаНаОбъект = СсылкаНаОбъект.Товары[0];

    ТабДок.Вывести("СекцияПодвалТаб");

    СекцияТело.Параметры.ОтветственноеЛицо = СсылкаНаОбъект.Автор;
    ТабДок.Вывести("СекцияПодвал");

    //ТабДок.ОтображатьЗаголовки=Ложь;
    //ТабДок.ОтображатьСетку=Ложь;
    //ТабДок.ТолькоПросмотр=Истина;

    ТабДок.АвтоМасштаб = Истина;


    Возврат ТабДок;

    КонецФункции //


    Также есть стандартная
    Функция СведенияОВнешнейОбработке() Экспорт

    Вложения:

  2. LordMaverick
    Offline

    LordMaverick Профессионал в 1С

    Регистрация:
    17 мар 2014
    Сообщения:
    3.443
    Симпатии:
    375
    Баллы:
    104
    так в свежей же УТ есть вроде упаковочный лист уже
  3. TopicStarter Overlay
    webmastersb
    Offline

    webmastersb

    Регистрация:
    2 май 2014
    Сообщения:
    6
    Симпатии:
    0
    Баллы:
    1
    я его там не нашел
  4. LordMaverick
    Offline

    LordMaverick Профессионал в 1С

    Регистрация:
    17 мар 2014
    Сообщения:
    3.443
    Симпатии:
    375
    Баллы:
    104
    сорри, это у них в 11.1.6 планируется

    Код:
    Планы реализации технических проектов версия УТ 11.1.6
    
    
    
    Дата актуальности: 31.03.2014
    
    Упаковочные листы на складе (выполняется, очередность 1)
    Создание упаковочных листов при отгрузке товаров.
    Печатная форма расходного ордера, где для каждой позиции указан номер упаковочного листа, в который включена эта позиция.
    Автоматизация приемки по упаковочным листам (информация о составе упаковочного листа загружается в систему).
    Прием и передача товаров по количеству (номерам) мест с регистрацией в программе факта приема/передачи по количеству (номерам) мест.
    
  5. LordMaverick
    Offline

    LordMaverick Профессионал в 1С

    Регистрация:
    17 мар 2014
    Сообщения:
    3.443
    Симпатии:
    375
    Баллы:
    104
    но в 11.1.6.16 что-то не узрел пока
  6. TopicStarter Overlay
    webmastersb
    Offline

    webmastersb

    Регистрация:
    2 май 2014
    Сообщения:
    6
    Симпатии:
    0
    Баллы:
    1
    Вот какая ошибка вылазит на самом деле после отладки
    {ОбщийМодуль.ДополнительныеОтчетыИОбработкиКлиент.Модуль(479)}: Метод объекта не обнаружен (Печать)
    ФормаОбработки.Печать(ВыполняемаяКоманда.Идентификатор, ОбъектыНазначения);
  7. LordMaverick
    Offline

    LordMaverick Профессионал в 1С

    Регистрация:
    17 мар 2014
    Сообщения:
    3.443
    Симпатии:
    375
    Баллы:
    104
    вроде в 11.1.7 реализовали
    выпуск по плану в июне, в середине

    Планы реализации технических проектов версия УТ 11.1.7
    Дата актуальности: 22.05.2014

    Склад
    Упаковочные листы на складе (выполнено)
    • Создание упаковочных листов при отгрузке товаров.
    • Печатная форма расходного ордера, где для каждой позиции указан номер упаковочного листа, в который включена эта позиция.
    • Автоматизация приемки по упаковочным листам (информация о составе упаковочного листа загружается в систему).
    • Прием и передача товаров по количеству (номерам) мест с регистрацией в программе факта приема/передачи по количеству (номерам) мест.

Поделиться этой страницей