8.х возврат нескольких значений

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Andriy, 10 мар 2017.

  1. TopicStarter Overlay
    Andriy
    Offline

    Andriy

    Регистрация:
    9 мар 2017
    Сообщения:
    18
    Симпатии:
    0
    Баллы:
    1
    Добрый день!

    Задача такова: Есть поле: СерийныйНомер, событие АвтоПодборТекста
    на него вешаем фонкцию на сервере с запросом, когда находит подходящий документ,
    должно присвоить к примеру выборка.номер к полю номер, выборка.телефон к полю "тел" и т.д.

    Но как в УФ это сделать??? как возвратить не одно, а несколько значений?


    Код:
    &НаСервереБезКонтекста
    Функция СерійнийНомерАвтоПодборНаСервере(Текст)
                            
                Запрос3 = Новый Запрос(
        "ВЫБРАТЬ *
        |ИЗ
        |    Документ.Заявки
        |ГДЕ
        |    (Документ.Заявки.ЗаводскойНомер = &СерНом)");
     
        Запрос3.УстановитьПараметр("СерНом", Текст);
        Результат3 = Запрос3.Выполнить();
        Выборка3 = Результат3.Выбрать();
              
        Пока Выборка3.Следующий() Цикл
          
      
          
        джерело = "Заявка №" + Выборка3.Номер+"    "+Выборка3.дата;
        
     
    КонецЦикла;
    
    Конецфункции
    
    Код:
    &НаКлиенте
    Процедура СерійнийНомерАвтоПодбор(Элемент, Текст, ДанныеВыбора, ПараметрыПолученияДанных, Ожидание, СтандартнаяОбработка)
      
          СтандартнаяОбработка = Ложь;
      
      
        СерійнийНомерАвтоПодборНаСервере(Текст);
       
    КонецПроцедуры
    
  2. nickpugachev
    Offline

    nickpugachev Профессионал в 1С Команда форума

    Регистрация:
    28 май 2012
    Сообщения:
    3.397
    Симпатии:
    155
    Баллы:
    104
    вернуть структуру с этими значениями
  3. TopicStarter Overlay
    Andriy
    Offline

    Andriy

    Регистрация:
    9 мар 2017
    Сообщения:
    18
    Симпатии:
    0
    Баллы:
    1
    А в примере можете показать?
  4. nickpugachev
    Offline

    nickpugachev Профессионал в 1С Команда форума

    Регистрация:
    28 май 2012
    Сообщения:
    3.397
    Симпатии:
    155
    Баллы:
    104
    Код:
    &НаКлиенте
    Процедура ОбновитьСостояние()
        СтруктураСостояния = ПолучитьДанныеСостояния(Объект.Клиент);
        АдресКлиента = СтруктураСостояния.Адрес;
        Задолженность = СтруктураСостояния.Задолженность;
    КонецПроцедуры
    
    &НаСервереБезКонтекста
    Функция ПолучитьДанныеСостояния(КлиентСсылка)
        СтруктураСостояния = Новый Структура;
        СтруктураСостояния.Вставить("Адрес", ПолучитьАдресКлиента(КлиентСсылка));
        СтруктураСостояния.Вставить("Задолженность", ПолучитьЗадолженностьКлиента(КлиентСсылка));
        Возврат СтруктураСостояния;
    КонецФункции
    
Похожие темы
  1. funtik1983
    Ответов:
    7
    Просмотров:
    3.887
  2. stanik
    Ответов:
    1
    Просмотров:
    2.509
  3. svet
    Ответов:
    0
    Просмотров:
    1.606
  4. hukzet
    Ответов:
    1
    Просмотров:
    1.282
  5. Дорс
    Ответов:
    4
    Просмотров:
    1.777
Загрузка...