8.х Вопросы по созданию Внешних обработок?

Тема в разделе "Общие вопросы "1С:Предприятие 8"", создана пользователем Accountantrf, 23 май 2012.

  1. TopicStarter Overlay
    Accountantrf
    Offline

    Accountantrf

    Регистрация:
    23 май 2012
    Сообщения:
    4
    Симпатии:
    0
    Баллы:
    1
    Добрый день!
    Решил попытаться автоматизировать свой труд, но возникла масса вопросов, на которые не могу найти ответа в интернете.

    Описание проблеммы:
    Организация ежемесячно оказывает одинаковые услуги контрагентам. При этом контрагентов больше 100 и ежемесячное нажатие на кнопку "вставить копированием" существенно портит мою нервную систему.

    Описание предполагаемой обработки:
    Формирование списка документов ОказаниеУслуг за период - предыдущий месяц. Пользователь проставляет флажки напротив документов, которые надо скопировать в этом месяце. При нажатии на кнопку "Любую" создаются копированием выделенные документы.

    Вопросы возникшие на данный момент:
    1) Т.К. опыт разработки крайне мал, не могу оценить возможность реализации поставленной задачи, может нет смысла ломать голову над такой задачей?
    2) При написании Функции СведенияОВнешнейОбработке() встречается следующая команда:
    // Допустимые типы: ДополнительнаяОбработка, ДополнительныйОтчет, ЗаполнениеОбъекта, Отчет, ПечатнаяФорма, СозданиеСвязанныхОбъектов
    ПараметрыРегистрации.Вставить("Вид", "ПечатнаяФорма");

    Я не знаю, какой вид мне выбрать, где можно про них почитать, чем они отличаются, облазил много ресурсов но ответа так и не нашел. Может знающие люди подскажут ссылку или объяснят на пальцах?

    Заранее благодарен.
  2. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.781
    Симпатии:
    509
    Баллы:
    204
    Нет смысла, вы сами ответили на свой вопрос, обратитесь к спецам со своим ТЗ, и занимайтесь своим делом:)))
  3. TopicStarter Overlay
    Accountantrf
    Offline

    Accountantrf

    Регистрация:
    23 май 2012
    Сообщения:
    4
    Симпатии:
    0
    Баллы:
    1
    Это как последний вариант. Пока есть время и возможность позаниматься 1С хотелось бы научиться, но без помощи к сожалению проблематично. Может быть все-таки найдутся люди, способные уделить немного времени для ответов на простенькие вопросы, возникающие в процессе обучения.
  4. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.781
    Симпатии:
    509
    Баллы:
    204
    А наком этапе у вас обучение? Можете отличить РС от РН ? Работа с запросами? Работа с документами? Клиент-серверное взаимодействие в 8.2 ?
    Думаю что если учиться - учиться с азов, а не с того как создать обмен данными с различными конфами и т.п.
    Я не хочу вас ни чем обидеть, это мое личное мнение :)
    Задавайте вопрос на нашем форуме, только уже если что-то наработано и что-то не получается:), а рассказывать как программно создавать доки или записи регистров - думаю никто не будет:), все ленивые до ужаса:)))))
  5. TopicStarter Overlay
    Accountantrf
    Offline

    Accountantrf

    Регистрация:
    23 май 2012
    Сообщения:
    4
    Симпатии:
    0
    Баллы:
    1
    Мое обучение на данный момент ограничено прочтением и созданием конфигурации по книге от 1С "Версия по обучению програмированию" 8.2 + видеокурсы, статьи в интернете иные книги по 1с програмированию. Я подстроил конфигурацию 1С:Бухгалтерия под себя на сколько смог и озадачился дальнейшим продвижением в познание 1С. Я и не прошу мне расказывать, как что-либо создавать, я уперся в проблемму, указанную в п.2 моего первого поста. Если в добавок подскажете на основании какой литературы или интернет ресурсов можно научиться азам, я обязательно воспользуюсь или может кто-нибудь поделиться полезной ссылочкой по схожим проблемам.
  6. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.781
    Симпатии:
    509
    Баллы:
    204
    Это нововведение в 8.2, инфу можно почитать на ИТС по созданию внешних отчетов/обработок. Так же можно немного прочитать тут :)
  7. TopicStarter Overlay
    Accountantrf
    Offline

    Accountantrf

    Регистрация:
    23 май 2012
    Сообщения:
    4
    Симпатии:
    0
    Баллы:
    1
    На данный момент удалось реализовать получение необходимых данных в табличную часть формы из документа ОказаниеУслуг. Не могу реализовать заполнение нового документа ОказаниеУслуг на основании полученных данных, может быть кто-нибудь подскажет в чем моя ошибка и заодно прилагаю код обработки для критики и дельных советов =).

    Код:
    &НаКлиенте
    Процедура Выгрузить(Команда)
    ОтборИнформации()
    КонецПроцедуры
    Процедура ОтборИнформации() Экспорт
    Запрос = Новый Запрос();
    // КДС Запроос данных из формы Документы.ОказаниеУслуг
    Запрос.Текст = "ВЫБРАТЬ
    |Ссылка.Контрагент.Наименование	    КАК Контрагент,
    |Ссылка.Дата,
    |Ссылка.СуммаДокумента			  КАК Сумма,
    |Ссылка.ВидВзаиморасчетов,
    |Ссылка.Номенклатура,
    |Ссылка.СтавкаНДС,
    |Ссылка.СуммаВключаетНДС,
    |Контрагент.Наименование,
    |ДоговорКонтрагента.Наименование, 
    |Количество,						
    |Цена,
    |СчетУчетаРасчетовСКонтрагентом,
    |СчетУчетаРасчетовПоАвансам,
    |ВыданСФ,
    |Ссылка.Субконто КАК Тест
    |ИЗ
    |Документ.ОказаниеУслуг.Контрагенты
    |";
    // КДС Получение Данных из Документы.ОказаниеУслуг их выгрузка
    //в таблицу значений
    Результат = Запрос.Выполнить().Выгрузить();
    // КДС Загрузка в табличную часть формы
    Таблица.Загрузить(Результат);
    
    КонецПроцедуры
    
    &НаКлиенте
    Процедура СформироватьАкты(Команда)
    ФормированиеАктов()
    КонецПроцедуры
    Процедура ФормированиеАктов() Экспорт
    Для Каждого Строка из Таблица Цикл
    НовыйДокумент = Документы.ОказаниеУслуг.СоздатьДокумент();
    НовыйДокумент.Дата = КонецМесяца(ТекущаяДата());
    НовыйДокумент.Контрагент = Таблица.Контрагент;
    НовыйДокумент.Записать();
    КонецЦикла
    
    
    КонецПроцедуры
    

Поделиться этой страницей