8.х Вопросы новичка по языку!

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем TODD22, 5 апр 2009.

  1. TopicStarter Overlay
    TODD22
    Offline

    TODD22 Профессионал в 1С Команда форума

    Регистрация:
    23 фев 2009
    Сообщения:
    4.755
    Симпатии:
    146
    Баллы:
    104
    "Нужно просто надыбать где-нибудь коробку с программой (из-под программы) и посмотреть описание встроенного языка. На данный момент это 7 (!) томов."

    пока нет возможности, но если представиться то обязательно утяну!

    я маленько понимаю в регистрах накопления и сведений.
    у меня есть радченко "примеры разработки", "практическое пособие"(по ней и делаю)
    хрусталёва "разработка отчётов"
    "администрирование и конфигурирование" 2 тома+диски из коробки обучения программированию.
    ну и электронных много разных.
    меня именно язык интересует: то есть примеры как работать с коллекциями, обьектами, методы, мне порекомендовали сначало учить СКД и XML, а остальное потом.
    но я чего то за язык взялся, хочу сначало хоть маленько его освоить. вот завтра буду тексты распечатывать из модулей и разбирать сидеть.
    ещё попробую сделать пример который с форума про внешние печатные формы. а на практике что чаще всего приходиться делать если например в франшизе работать? что бы я так сказать в нужном направление двигался?
  2. vitaly_mnpz
    Offline

    vitaly_mnpz Опытный в 1С

    Регистрация:
    15 фев 2009
    Сообщения:
    267
    Симпатии:
    0
    Баллы:
    26
    С функционалом у типовых решений всё нормально. Доработки делаются в основном из-за незнания типового функционала как пользователями, так и внедренцами. Так что двигаться нужно к освоению типового функционала.
  3. TopicStarter Overlay
    TODD22
    Offline

    TODD22 Профессионал в 1С Команда форума

    Регистрация:
    23 фев 2009
    Сообщения:
    4.755
    Симпатии:
    146
    Баллы:
    104
    понятно! я как маленько освоюсь пойду на курсы по бух. учёту. я думаю с небольшими познаниями в прогаммирование да и с толковыми курсами по буху будет проще и в освоение функционала. а вот про внешние печатные формы, их часто приходиться переделывать/доделывать? я тут по форуму посмотрел вроде частенько вопросы по ним.
    ну всё завтра распечатаю коды буду и вопросы по теме задавать.
  4. BabySG
    Offline

    BabySG Администраторы Команда форума Администратор

    Регистрация:
    10 июн 2007
    Сообщения:
    11.853
    Симпатии:
    12
    Баллы:
    29
    + 1000!
  5. TopicStarter Overlay
    TODD22
    Offline

    TODD22 Профессионал в 1С Команда форума

    Регистрация:
    23 фев 2009
    Сообщения:
    4.755
    Симпатии:
    146
    Баллы:
    104
    а можно пару примеров? желательно разные обьекты! например по константам, документам, справочникам, регистрам сведений, накоплений, перечислениям в них немного понимаю. что бы мне эту суть уловить!
    то есть именно тонкое деление, как бы функционал обьектов понимаю да и прочитать знаю где. а вот с тонким делением потёмки.
  6. Эмин
    Offline

    Эмин Руководитель проектов

    Регистрация:
    25 май 2007
    Сообщения:
    1.178
    Симпатии:
    1
    Баллы:
    26
    Ну, тут я не соглашусь ни с вами, ни с Никитой :)
    Типовые местами стоит переписывать или дорабатывать. Много лишнего и мало полезного. У серьезных организаций либо приходится приводить их процессы к УПП какому-нибудь (или УСО) - либо достраивать УТ и БП под их нужды. Не каждый готов менять свои бизнес-процессы под типовые :) И в этом они правы.

    Константа, например - это валюта управленческого учета, это заголовок окна системы (последняя моя система "с нуля" содержит всего 5 констант)
    Справочник - это некоторый каталог однородной информации, например Контрагенты, Номенклатура
    Документ - это объект, который регистрирует в системе определенные изменения периодические. Например появление товара (приходная накладная) или Оплата поставщику (платежное поручение).
    Перечисление - это перечислимый тип (аналог enum)
    Регистр сведений - это уже внутренний объект, содержащий какие-то значения, которые могут меняться (со временем или просто так). Например хороший аналог - это курсы валют. Есть справочник "Валюты" и есть регистр сведений, хранящий для каждой валюты на каждый день курс.
    Регистр накопления - это один из важнейших объектов. Он хранит изменения, например:
    01.01.09 Пришел товар 1 в количестве 100 шт.
    02.01.09 Ушел товар 1 50 шт.
    03.01.09 Пришел товар 1 150 шт.
    И в итоге на каждый момент мы можем получить остаток товара. Ну и там дальше разберетесь.
  7. vitaly_mnpz
    Offline

    vitaly_mnpz Опытный в 1С

    Регистрация:
    15 фев 2009
    Сообщения:
    267
    Симпатии:
    0
    Баллы:
    26
    Не каждый, но многих при правильном подходе удается убедить "прогнуться под программу". Взамен люди получают снижение издержек на поддержку. Этот вопрос обязательно должен быть решен еще на этапе обследования.
    Я и не говорил, что типовой функционал- панацея, но в ОСНОВНОМ его достаточно.
    В общем отмазался я :)
  8. Эмин
    Offline

    Эмин Руководитель проектов

    Регистрация:
    25 май 2007
    Сообщения:
    1.178
    Симпатии:
    1
    Баллы:
    26
    Под программу прогибаются те, у кого четких процессов и нет и им типовые вполне подходят. А так - на самом деле типовые, конечно, лажа, но зато во всех ошибках можно винить только 1Ску ;)
  9. TopicStarter Overlay
    TODD22
    Offline

    TODD22 Профессионал в 1С Команда форума

    Регистрация:
    23 фев 2009
    Сообщения:
    4.755
    Симпатии:
    146
    Баллы:
    104
    доброго времени суток!
    на днях прочитал что в фирму требуеться программист по 1с и тд. т.п.
    ну так как опыта и знаний у меня очень мало решил узнать следующее. там написано что требуеться создавать отчёты. конфа у них УТ. вот и вопрос если я в ней наделаю своих отчётов то как она будет обновляться? и как их делать что бы небыло проблем с обновлением? или проблем не будет?
    и можно ли их делать как внешние печатные формы?
    и ещё такой вопрос как работать с "штрих-м" я думаю сдесь это где нибудь обсуждалось? и что можно по этому "штрих-м" почитать?
    подскажите пожалуйста! заранее благодарен.
  10. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.735
    Симпатии:
    508
    Баллы:
    204
    Ну при обновлении можно задать настройку обновления(при объединении конфигурации). Про штрих-м можно почитать на www.shtrih-m.ru
  11. Vadson
    Offline

    Vadson

    Регистрация:
    14 мар 2008
    Сообщения:
    18
    Симпатии:
    0
    Баллы:
    1
    Делай "Внешние отчеты", они никаким образом на обновление не влияют.
  12. TopicStarter Overlay
    TODD22
    Offline

    TODD22 Профессионал в 1С Команда форума

    Регистрация:
    23 фев 2009
    Сообщения:
    4.755
    Симпатии:
    146
    Баллы:
    104
    ну вот и дошёл я до ВПФ. хотелось бы сделать. меня интересует а есть ли конфа УТ демо? как БП, уже заполненая, а то мне бы было бы с неё удобней начать.
  13. TopicStarter Overlay
    TODD22
    Offline

    TODD22 Профессионал в 1С Команда форума

    Регистрация:
    23 фев 2009
    Сообщения:
    4.755
    Симпатии:
    146
    Баллы:
    104
    подскажите пожалуйста как сделать подбор: то есть у меня есть документ, при указании в нём группы(студентов) мне надо что бы из справочника в табличную часть подбирались студенты.
  14. TopicStarter Overlay
    TODD22
    Offline

    TODD22 Профессионал в 1С Команда форума

    Регистрация:
    23 фев 2009
    Сообщения:
    4.755
    Симпатии:
    146
    Баллы:
    104
    подскажите пожалуйста: мне надо сделать что бы цвет строки табличного поля документа изменялся в зависимости от условия, где в конфе Бух 1.6 или УТ10.3 это можно посмотреть? интересует сам механизм. а то сам что то додуматься не могу.
  15. x_under
    Offline

    x_under Модераторы Команда форума Модератор

    Регистрация:
    25 апр 2007
    Сообщения:
    2.576
    Симпатии:
    13
    Баллы:
    29
  16. TopicStarter Overlay
    TODD22
    Offline

    TODD22 Профессионал в 1С Команда форума

    Регистрация:
    23 фев 2009
    Сообщения:
    4.755
    Симпатии:
    146
    Баллы:
    104
    подскажите пожалуйста, как получить разность между двумя датами в днях?
    даты в табличном часте документа.
    написал следующее:
    Код:
    Процедура РаботаСДатой(СтрокаТЧ) Экспорт
    ДлинаСуток = "86400";
    СтрокаТЧ.КоличествоДней = Окр((НачалоДня(СтрокаТЧ.ДатаПогашения))-(НачалоДня(СтрокаТЧ.ДатаОткрытия))/ДлинаСуток);
    КонецПроцедуры
    
    пишет: Преобразование значения к типу Число не может быть выполнено. подскажите что не так.
  17. x_under
    Offline

    x_under Модераторы Команда форума Модератор

    Регистрация:
    25 апр 2007
    Сообщения:
    2.576
    Симпатии:
    13
    Баллы:
    29
    Со скобками натупили. Разберите внимательно: вы дату вначале делите на число. Потом это непонятно что пытаетесь вычесть из даты, а потом как контрольный выстрел - округлить.
  18. PavelBaryshev
    Offline

    PavelBaryshev Опытный в 1С

    Регистрация:
    9 сен 2008
    Сообщения:
    316
    Симпатии:
    0
    Баллы:
    26
    Процедура ОбработкаПроведения(Отказ, Режим)

    Запрос=Новый Запрос;
    если Режим=РежимПроведенияДокумента.Оперативный Тогда
    Запрос.Текст=
    "ВЫБРАТЬ
    | ОказаниеУслугиПереченьНоменклатуры.Номенклатура,
    | ОказаниеУслугиПереченьНоменклатуры.Количество,
    | ОказаниеУслугиПереченьНоменклатуры.Сумма,
    | ОстаткиМатериаловОстатки.КоличествоОстаток,
    | ОстаткиМатериаловОстаткиНаСкладе.КоличествоОстаток КАК КоличествоНаСкладе,
    | СтоимостьМатериаловОстатки.СтоимостьОстаток,
    | ОказаниеУслугиПереченьНоменклатуры.Номенклатура.ВидНоменклатуры КАК ВидНоменклатуры
    |ИЗ
    | Документ.ОказаниеУслуги.ПереченьНоменклатуры КАК ОказаниеУслугиПереченьНоменклатуры
    | ЛЕВОЕ СОЕДИНЕНИЕ РегистрНакопления.СтоимостьМатериалов.Остатки(&МоментВремени, Материал В (&СписокНоменклатурыДокумента)) КАК СтоимостьМатериаловОстатки
    | ПО ОказаниеУслугиПереченьНоменклатуры.Номенклатура = СтоимостьМатериаловОстатки.Материал
    | ЛЕВОЕ СОЕДИНЕНИЕ РегистрНакопления.ОстаткиМатериалов.Остатки(&МоментВремени, Материал В (&СписокНоменклатурыДокумента)) КАК ОстаткиМатериаловОстатки
    | ПО ОказаниеУслугиПереченьНоменклатуры.Номенклатура = ОстаткиМатериаловОстатки.Материал
    | ЛЕВОЕ СОЕДИНЕНИЕ РегистрНакопления.ОстаткиМатериалов.Остатки(
    | &МоментВремени,
    | Материал В (&СписокНоменклатурыДокумента)
    | И Склад = &СкладВДокументе) КАК ОстаткиМатериаловОстаткиНаСкладе
    | ПО ОказаниеУслугиПереченьНоменклатуры.Номенклатура = ОстаткиМатериаловОстаткиНаСкладе.Материал
    |ГДЕ
    | ОказаниеУслугиПереченьНоменклатуры.Ссылка = &Ссылка
    |
    |ДЛЯ ИЗМЕНЕНИЯ
    | РегистрНакопления.СтоимостьМатериалов.Остатки,
    | РегистрНакопления.ОстаткиМатериалов.Остатки";
    Запрос.УстановитьПараметр("СкладВДокументе", Склад);
    Иначе
    Запрос.Текст=
    "ВЫБРАТЬ
    | ОказаниеУслугиПереченьНоменклатуры.Номенклатура,
    | ОказаниеУслугиПереченьНоменклатуры.Количество,
    | ОказаниеУслугиПереченьНоменклатуры.Сумма,
    | ОстаткиМатериаловОстатки.КоличествоОстаток,
    | СтоимостьМатериаловОстатки.СтоимостьОстаток,
    | ОказаниеУслугиПереченьНоменклатуры.Номенклатура.ВидНоменклатуры КАК ВидНоменклатуры
    |ИЗ
    | Документ.ОказаниеУслуги.ПереченьНоменклатуры КАК ОказаниеУслугиПереченьНоменклатуры
    | ЛЕВОЕ СОЕДИНЕНИЕ РегистрНакопления.СтоимостьМатериалов.Остатки(&МоментВремени, Материал В (&СписокНоменклатурыДокумента)) КАК СтоимостьМатериаловОстатки
    | ПО ОказаниеУслугиПереченьНоменклатуры.Номенклатура = СтоимостьМатериаловОстатки.Материал
    | ЛЕВОЕ СОЕДИНЕНИЕ РегистрНакопления.ОстаткиМатериалов.Остатки(&МоментВремени, Материал В (&СписокНоменклатурыДокумента)) КАК ОстаткиМатериаловОстатки
    | ПО ОказаниеУслугиПереченьНоменклатуры.Номенклатура = ОстаткиМатериаловОстатки.Материал
    |
    |ГДЕ
    | ОказаниеУслугиПереченьНоменклатуры.Ссылка = &Ссылка
    |
    |ДЛЯ ИЗМЕНЕНИЯ
    | РегистрНакопления.СтоимостьМатериалов.Остатки,
    | РегистрНакопления.ОстаткиМатериалов.Остатки";

    КонецЕсли;
    Запрос.УстановитьПараметр("МоментВремени", МоментВремени());
    Запрос.УстановитьПараметр("СписокНоменклатурыДокумента", ПереченьНоменклатуры.ВыгрузитьКолонку("Номенклатура"));
    Запрос.УстановитьПараметр("Ссылка", Ссылка);

    ВыборкаРезультатовЗапроса=Запрос.Выполнить().Выбрать();
    пока ВыборкаРезультатовЗапроса.Следующий()цикл
    //проверить остаток при оперативном проведении
    Если Режим=РежимПроведенияДокумента.Оперативный Тогда
    Если ВыборкаРезультатовЗапроса.ВидНоменклатуры=Перечисления.ВидыНоменклатуры.Материал Тогда
    Остаток=?(ВыборкаРезультатовЗапроса.КоличествоНаСкладе=Null,0,ВыборкаРезультатовЗапроса.КоличествоНаСкладе); //изм
    Если Остаток<ВыборкаРезультатовЗапроса.Количество Тогда
    Сообщить("Материала "+СокрЛП(ВыборкаРезультатовЗапроса.Номенклатура)+" имеется только "+Остаток);
    Отказ=Истина;
    Возврат;
    КонецЕсли;
    КонецЕсли;
    КонецЕсли;

    //сформировать движения
    Если ВыборкаРезультатовЗапроса.ВидНоменклатуры=Перечисления.ВидыНоменклатуры.Материал Тогда
    //регистр ОстаткиМатериалов Расход
    Движение=Движения.ОстаткиМатериалов.Добавить();
    Движение.ВидДвижения=ВидДвиженияНакопления.Расход;
    Движение.Период=Дата;
    Движение.Материал=ВыборкаРезультатовЗапроса.Номенклатура;
    Движение.Склад=Склад;
    Движение.Количество=ВыборкаРезультатовЗапроса.Количество();

    //регистр СтоимостьМатериалов Расход
    Движение=Движения.СтоимостьМатериалов.Добавить();
    Движение.ВидДвижения=ВидДвиженияНакопления.Расход;
    Движение.Период=Дата;
    Движение.Материал=ВыборкаРезультатовЗапроса.Номенклатура;
    //расчитать стоимость материала
    СтоимостьМатериала=?(ВыборкаРезультатовЗапроса.КоличествоОстаток=Null,0,ВыборкаРезультатовЗапроса.СтоимостьОстаток/ВыборкаРезультатовЗапроса.КоличествоОстаток);
    Движение.Стоимость=СтоимостьМатериала*ВыборкаРезультатовЗапроса.Количество;

    //по регистру Управленческий

    //первая проводка
    //Д62(дебиторскаяЗадолженность) - К90(Капитал)
    //розничная сумма
    Движение = Движения.Управленческий.Добавить();
    Движение.СчетДт=ПланыСчетов.Основной.ДебиторскаяЗадолженность;
    Движение.СчетКт=ПланыСчетов.Основной.Капитал;
    Движение.Период=Дата;
    Движение.Сумма=ВыборкаРезультатовЗапроса.Сумма;
    Движение.СубконтоДт[ПланыВидовХарактеристик.ВидыСубконто.Клиенты]=Клиент;
    //вторая проводка:
    //Д90(капитал)-К41(товары)- себестоимость
    Движение=Движения.Управленческий.Добавить();
    Движение.СчетДт=ПланыСчетов.Основной.Капитал;
    Движение.СчетКт=ПланыСчетов.Основной.Товары;
    Движение.Период=Дата;
    Движение.Сумма=СтоимостьМатериала*ВыборкаРезультатовЗапроса.Количество;
    Движение.КоличествоКт=ВыборкаРезультатовЗапроса.Количество;
    Движение.СубконтоКт[ПланыВидовХарактеристик.ВидыСубконто.Материалы]=ВыборкаРезультатовЗапроса.Номенклатура;

    КонецЕсли;
    //регистр Продажи
    Движение=Движения.Продажи.Добавить();
    Движение.Период=Дата;
    Движение.Номенклатура=ВыборкаРезультатовЗапроса.Номенклатура;
    Движение.Клиент=Клиент;
    Движение.Мастер=Мастер;
    Движение.Количество=ВыборкаРезультатовЗапроса.Количество;
    Движение.Выручка=ВыборкаРезультатовЗапроса.Сумма;
    если ВыборкаРезультатовЗапроса.ВидНоменклатуры=Перечисления.ВидыНоменклатуры.Материал Тогда
    Движение.Стоимость=СтоимостьМатериала*ВыборкаРезультатовЗапроса.Количество;
    иначе Движение.Стоимость=0;
    КонецЕсли;
    КонецЦикла;

    //записать движения регистров
    Движения.ОстаткиМатериалов.Записать();
    Движения.СтоимостьМатериалов.Записать();
    Движения.Продажи.Записать();

    КонецПроцедуры
  19. TopicStarter Overlay
    TODD22
    Offline

    TODD22 Профессионал в 1С Команда форума

    Регистрация:
    23 фев 2009
    Сообщения:
    4.755
    Симпатии:
    146
    Баллы:
    104
    подскажите пожалуйста как реализовать получение курса валют из интернета? и где это можно посмотреть в типовых конфах? интересует полностью механизм.
  20. ASh
    Offline

    ASh Опытный в 1С

    Регистрация:
    10 сен 2008
    Сообщения:
    568
    Симпатии:
    0
    Баллы:
    26
    Обработка КурсыВалютРБК

Поделиться этой страницей