7.7 Вопрос реагирует не правильно

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем ZEMA, 15 окт 2007.

  1. TopicStarter Overlay
    ZEMA
    Offline

    ZEMA Опытный в 1С

    Регистрация:
    5 окт 2007
    Сообщения:
    231
    Симпатии:
    0
    Баллы:
    26
    Помогите,что не так???????? вопрос (Пер=Вопрос("Показать","Да+Нет");)должен выводиться 1 раз когда (иначеЕсли Лев(Регион,3)="Сиб" тогда )), а не так как у меня,после каждого выбора,т.е обнаружел слово и выводит вопрос. Если я Пер=Вопрос("Показать","Да+Нет") ставлю иначеЕсли Лев(Регион,3)="Сиб" тогда
    Если Пер = "Да" Тогда
    Менеджер.Наименование="00000000";
    ИначеЕсли Пер = "Нет" Тогда
    Менеджер.Наименование="2222222";
    ,то при появлении вопроса зацикливается П


    Процедура приоткрытии()
    Пер=Вопрос("Показать","Да+Нет");
    Спр=СоздатьОбъект("Справочник.Клиенты");
    Спр.ВыбратьЭлементы();

    Пока Спр.ПолучитьЭлемент()=1 цикл
    Если Лев(Регион,3)="Южн" тогда

    Менеджер.Наименование="Беньковская";
    иначеЕсли Лев(Регион,3)="Дал" тогда
    Менеджер.Наименование="00000000";
    иначеЕсли Лев(Регион,3)="Цен" тогда
    Менеджер.Наименование="11111111";
    иначеЕсли Лев(Регион,3)="Сев" тогда
    Менеджер.Наименование="22222222";
    иначеЕсли Лев(Регион,3)="Ура" тогда
    Менеджер.Наименование="33333333";
    иначеЕсли Лев(Регион,3)="При" тогда
    Менеджер.Наименование="44444444";
    иначеЕсли Лев(Регион,3)="Сиб" тогда

    Если Пер = "Да" Тогда
    Менеджер.Наименование="00000000";
    ИначеЕсли Пер = "Нет" Тогда
    Менеджер.Наименование="2222222";
    КонецЕсли;
    КонецЕсли;
    КонецЦикла;
    КонецПроцедуры
  2. AndreySc
    Offline

    AndreySc

    Регистрация:
    11 окт 2007
    Сообщения:
    40
    Симпатии:
    0
    Баллы:
    1
    честно говоря не понял что иметься ввиду.
  3. ЧКДзержинский
    Offline

    ЧКДзержинский Опытный в 1С

    Регистрация:
    7 дек 2006
    Сообщения:
    487
    Симпатии:
    3
    Баллы:
    29
    Пиши повнятнее, какой выбор еще?
  4. MaxxaM
    Offline

    MaxxaM Опытный в 1С

    Регистрация:
    16 окт 2007
    Сообщения:
    288
    Симпатии:
    2
    Баллы:
    29
    тут чего то нехватает, в данном варианте все работает правильно. :unsure:
    если я конечно правильно к своей базе прекрутил

    Процедура Сформировать()
    Пер=Вопрос("Показать","Да+Нет");
    Спр=СоздатьОбъект("Справочник.Контрагенты");
    Спр.ВыбратьЭлементы();

    Пока Спр.ПолучитьЭлемент()=1 цикл
    Регион=Спр.ТекущийЭлемент().Наименование;
    Если Лев(Регион,3)="Южн" тогда
    Менеджер="Беньковская";
    иначеЕсли Лев(Регион,3)="Дал" тогда
    Менеджер="00000000";
    иначеЕсли Лев(Регион,3)="Цен" тогда
    Менеджер="11111111";
    иначеЕсли Лев(Регион,3)="Сев" тогда
    Менеджер="22222222";
    иначеЕсли Лев(Регион,3)="Ура" тогда
    Менеджер="33333333";
    иначеЕсли Лев(Регион,3)="При" тогда
    Менеджер="44444444";
    иначеЕсли Лев(Регион,3)="ООО" тогда
    сообщить("+");
    Если Пер = "Да" Тогда
    Менеджер="00000000";
    ИначеЕсли Пер = "Нет" Тогда
    Менеджер="2222222";
    КонецЕсли;
    КонецЕсли;
    КонецЦикла;
    сообщить(Менеджер);
    КонецПроцедуры

Поделиться этой страницей