8.х РОЗ Вопрос про обмен новой розницы 2.1.4 с сайтом.

Тема в разделе ""1С:Розница"", создана пользователем Alex123, 13 июн 2015.

  1. TopicStarter Overlay
    Alex123
    Offline

    Alex123 Опытный в 1С

    Регистрация:
    20 июл 2012
    Сообщения:
    208
    Симпатии:
    0
    Баллы:
    26
    Появился значит у нас сайт. И о чудо розница без всяких манипуляции загрузила все товары с картинками, остатками и ценами на сайт. Я, честно говоря, не ожидал от нее такой прыти))
    Но не работает обмен заказов клиента с сайтом. Сама возможность имеется, но непонятно Заказ клиента и Заказ покупателя (он не шевелится при обмене) одно и тоже?. И у заказа покупателя нет имени клиента, есть только карточка дисконтная.
    Еще я тут прочитал на другом форуме
    А значит и работа с сайтом возможна, но как эти чертовы заказы запихнуть в розницу?
  2. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.735
    Симпатии:
    508
    Баллы:
    204
    Смотрите код, который эти все дела связывает.
  3. TerANik
    Offline

    TerANik Профессионал в 1С

    Регистрация:
    19 ноя 2014
    Сообщения:
    997
    Симпатии:
    70
    Баллы:
    54
    Скрин настроек дайте..
  4. TopicStarter Overlay
    Alex123
    Offline

    Alex123 Опытный в 1С

    Регистрация:
    20 июл 2012
    Сообщения:
    208
    Симпатии:
    0
    Баллы:
    26
    Скрины

    Вложения:

    • Capture.JPG
      Capture.JPG
      Размер файла:
      269,6 КБ
      Просмотров:
      13
    • Capture1.JPG
      Capture1.JPG
      Размер файла:
      242,9 КБ
      Просмотров:
      13
    • Capture2.JPG
      Capture2.JPG
      Размер файла:
      153 КБ
      Просмотров:
      14
  5. TerANik
    Offline

    TerANik Профессионал в 1С

    Регистрация:
    19 ноя 2014
    Сообщения:
    997
    Симпатии:
    70
    Баллы:
    54
    Ам.. а что за сайт? Вообще по факту заказы должны формироваться динамически на стороне сайта..
    Сайт на чем на писан? Посмотрите процедуру которая отвечает за заказы, она отправляет на сайт запрос, сайт формирует (либо с периодичностью выгружает на ftp) заказы и 1С забирает файл.
    Тут изнутри надо смотреть.
  6. TopicStarter Overlay
    Alex123
    Offline

    Alex123 Опытный в 1С

    Регистрация:
    20 июл 2012
    Сообщения:
    208
    Симпатии:
    0
    Баллы:
    26
    SaaS версия CS-Cart
    Я кода не видел. Заказы приходят на почту, и в админке есть. А 1с какой то периодичностью наведывается на сайт и по протоколу CommercML забирает заказы и обновляет товары.
    Это через конфигуратор? я запустил конфигуратор, начал отладку, открыл окно с обменом с сайтом, а как теперь увидеть код этой процедуры обмена?
  7. TerANik
    Offline

    TerANik Профессионал в 1С

    Регистрация:
    19 ноя 2014
    Сообщения:
    997
    Симпатии:
    70
    Баллы:
    54
    Посмотрите как называется флажок Обмен заказами..
    и от него ищите.
    Да в конфигураторе
  8. TopicStarter Overlay
    Alex123
    Offline

    Alex123 Опытный в 1С

    Регистрация:
    20 июл 2012
    Сообщения:
    208
    Симпатии:
    0
    Баллы:
    26
    Вы меня не поняли. Раньше я находил нужную процедуру сделав условия выхода по ошибке в 1с и видел код того окна, где ошибка. А как увидеть код если ошибок не было....
  9. TerANik
    Offline

    TerANik Профессионал в 1С

    Регистрация:
    19 ноя 2014
    Сообщения:
    997
    Симпатии:
    70
    Баллы:
    54
    Объясняю как это работает.
    В настройках обмена с сайтом у вас есть флажок "Обмен заказами", этот флажок как то называется , например "ОбменЗаказами".

    Копируете имя реквизита и запускаете поиск по конфигурации. И у вас будет код

    Если ОбменЗаказами Тогда
    НекаяПроцедураОбменаЗаказами()
    КонецЕсли;

    Привожу пример:

    Код:
    Если ОбменЗаказами Тогда
           
            ЗаказыУспешноВыгружены = ВыполнитьОбменЗаказами(СтруктураИзменений);
           
            Если ВыгружатьТолькоИзменения
                И ЗаказыУспешноВыгружены Тогда
               
                ПланыОбмена.УдалитьРегистрациюИзменений(УзелОбменаЗаказами, СтруктураИзменений.НомерСообщенияЗаказы);
               
            КонецЕсли;
           
        Иначе
            ЗаказыУспешноВыгружены = Истина;
        КонецЕсли;
    
  10. TopicStarter Overlay
    Alex123
    Offline

    Alex123 Опытный в 1С

    Регистрация:
    20 июл 2012
    Сообщения:
    208
    Симпатии:
    0
    Баллы:
    26
    Код:
    // Процедура - обработчик события ПриИзменении поля флажка ОбменЗаказами.
    //
    &НаКлиенте
    Процедура ОбменЗаказамиПриИзменении(Элемент)
       
        ПриИзмененииОбменЗаказами();
       
    КонецПроцедуры
    
    &НаКлиенте
    Процедура ПриИзмененииОбменЗаказами()
       
        УстановитьВидимостьСтраницФормы();
        УстановитьДоступностьПолейОбменЗаказами();
       
    КонецПроцедуры
    
    Процедура УстановитьДоступностьПолейОбменЗаказами()
       
        Элементы.ФайлЗагрузки.Доступность = Объект.ОбменЗаказами;
       
    КонецПроцедуры
    
    
    Ну тут просто видимость и все
  11. TerANik
    Offline

    TerANik Профессионал в 1С

    Регистрация:
    19 ноя 2014
    Сообщения:
    997
    Симпатии:
    70
    Баллы:
    54
    не там смотрите. Вы смотрите модуль формы настройки обмена, а вам надо смотреть процедуру, которая тянется с кнопки Выполнить обмен.

    Вам надо смотреть не что происходит когда вы ставите или снимаете галку, а то что происходит при обмене.
  12. TopicStarter Overlay
    Alex123
    Offline

    Alex123 Опытный в 1С

    Регистрация:
    20 июл 2012
    Сообщения:
    208
    Симпатии:
    0
    Баллы:
    26
    Вот по этой кнопке же должны быть процедуры главные? но я не вижу

    Вложения:

    • Captur123.JPG
      Captur123.JPG
      Размер файла:
      199 КБ
      Просмотров:
      14
  13. TerANik
    Offline

    TerANik Профессионал в 1С

    Регистрация:
    19 ноя 2014
    Сообщения:
    997
    Симпатии:
    70
    Баллы:
    54
    Ну так справа в свойствах имя команды куда ведет? ПланОбмена.ОбменССайтом..... дальше нее видно по скрину.
  14. TopicStarter Overlay
    Alex123
    Offline

    Alex123 Опытный в 1С

    Регистрация:
    20 июл 2012
    Сообщения:
    208
    Симпатии:
    0
    Баллы:
    26
    Код:
    #Область ОбработчикиСобытийФормы
    
    // Процедура - обработчик события ПриСозданииНаСервере.
    //
    &НаСервере
    Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
       
        //Начало _Розница20
        ИспользоватьЗаказыПокупателей = ПолучитьФункциональнуюОпцию("ИспользоватьЗаказыПокупателей");
        //Конец _Розница20
       
        УзелОбменаЭтаИБ = ПроверитьУзелОбменаЭтаИБСервер();
       
        Если УзелОбменаЭтаИБ Тогда
            Возврат;
        КонецЕсли;
       
        УстановитьВидимостьИДоступностьЭлементов();
       
    КонецПроцедуры
    
    Вот что-то похожее
  15. TerANik
    Offline

    TerANik Профессионал в 1С

    Регистрация:
    19 ноя 2014
    Сообщения:
    997
    Симпатии:
    70
    Баллы:
    54
    Нее в угадай мелодию я не могу играть)... Будет возможность вечером гляну .. если не забуду. Розницы нет под рукой.
  16. TopicStarter Overlay
    Alex123
    Offline

    Alex123 Опытный в 1С

    Регистрация:
    20 июл 2012
    Сообщения:
    208
    Симпатии:
    0
    Баллы:
    26
    вот она ПланОбмена.ОбменССайтом.Команда.ВыполнитьОбменДанными
    --- Объединение сообщений, 15 июн 2015 ---
    а через тим виер взглянуть не можете?
  17. TerANik
    Offline

    TerANik Профессионал в 1С

    Регистрация:
    19 ноя 2014
    Сообщения:
    997
    Симпатии:
    70
    Баллы:
    54
    Ооо. Вот её и надо смотреть. Открывайте в конфигураторе план обмена и смотрите команду.
  18. TopicStarter Overlay
    Alex123
    Offline

    Alex123 Опытный в 1С

    Регистрация:
    20 июл 2012
    Сообщения:
    208
    Симпатии:
    0
    Баллы:
    26
    Ищу этот ВыполнитьОбменДанными.
    Но нету...

    Вложения:

    • C2223.JPG
      C2223.JPG
      Размер файла:
      205,9 КБ
      Просмотров:
      12
    • Ca11.JPG
      Ca11.JPG
      Размер файла:
      200 КБ
      Просмотров:
      12
    • upload_2015-6-15_13-13-15.png
      upload_2015-6-15_13-13-15.png
      Размер файла:
      412,1 КБ
      Просмотров:
      12
  19. TerANik
    Offline

    TerANik Профессионал в 1С

    Регистрация:
    19 ноя 2014
    Сообщения:
    997
    Симпатии:
    70
    Баллы:
    54
    Пф... Уважаемый склоняясь к вашему первому посту у меня возникает вопрос интересный вопрос, ни когда у вас появился сайт и о чудо, а когда у вас появилась Розница? Вы вообще программист или нет?

    В конфигураторе есть объект ПланОбмена.ОбменССайтом . У этого объекта метаданных есть команда ВыполнитьОбменДанными. Нужно смотреть что делает эта команда. Закройте вы измученную форму настроек. ТАм ничего не будет.
  20. TopicStarter Overlay
    Alex123
    Offline

    Alex123 Опытный в 1С

    Регистрация:
    20 июл 2012
    Сообщения:
    208
    Симпатии:
    0
    Баллы:
    26
    розница 2 года, конфигуратор открыл второй раз)

Поделиться этой страницей