8.х Вопрос по заданию параметров компановщика из формы отчета.

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем maritime, 12 июл 2011.

  1. TopicStarter Overlay
    maritime
    Offline

    maritime

    Регистрация:
    22 апр 2011
    Сообщения:
    26
    Симпатии:
    0
    Баллы:
    1
    Задаю параметры начало и конец периода в форме отчета.
    отчет сделан на компановке.
    у него в параметрах началоПериода КонецПериода и Период

    Период не лает удалить хотя в качестве параметров запроса он нигде не используется

    при открытии отчет выдает ошибку что параметр период не найден.



    Код:
    Процедура ДоработатьКомпоновщикПередВыводом() Экспорт
    
    ЗначениеПараметра = КомпоновщикНастроек.Настройки.ПараметрыДанных.НайтиЗначениеПараметра(Новый ПараметрКомпоновкиДанных("Период"));
    Если ЗначениеПараметра = Неопределено Тогда
    ЗначениеПараметра.Значение = КонецДня(ТекущаяДата());
    
    //Возврат;
    КонецЕсли;
    
    Если ЗначениеПараметра.Значение = '00010101' Тогда
    ЗначениеПараметра.Значение = КонецДня(ТекущаяДата());
    КонецЕсли;
    ЗначениеПараметра.Использование = Истина;
    
    КонецПроцедуры
    
    
    
    Процедура ПолеВводаПериодПриИзменении(Элемент)
    //Настройка = Новый НастройкаПериода;
    //
    //Настройка.ВариантНастройки = ВариантНастройкиПериода.Период;
    //Настройка.ДатаОкончания =КонецДня (Период);
    //	
    //	Период = Настройка.ПолучитьДатуОкончания();
    //	ТиповыеОтчеты.ОбновитьПараметрыПериодаПоФорме(КомпоновщикНастроек, ЭтаФорма);
    ТиповыеОтчеты.ОбновитьПараметрыПериодаПоФорме(КомпоновщикНастроек, ЭтаФорма);
    ТиповыеОтчеты.ОбработкаИзмененияТиповогоОтчетаНаФормеОтчета(ОтчетОбъект, ЭтаФорма);
    
    
    КонецПроцедуры
    
    Функция СформироватьОтчет(Результат = Неопределено, ДанныеРасшифровки = Неопределено, ВыводВФормуОтчета = Истина) Экспорт
    
    Возврат ТиповыеОтчеты.СформироватьТиповойОтчет(ЭтотОбъект, Результат, ДанныеРасшифровки, ВыводВФормуОтчета);
    
    КонецФункции
    
    Процедура Сформировать(Кнопка)     
    
    СформироватьОтчет(ЭтаФорма.ЭлементыФормы.Результат, ЭтаФорма.ДанныеРасшифровки);
    
    УправлениеОтчетами.УстановитьКолонтитулыПоУмолчанию(ЭтаФорма.ЭлементыФормы.Результат, ЭтотОбъект.Метаданные().Синоним, Строка(глЗначениеПеременной("глТекущийПользователь")));
    
    КонецПроцедуры
    
    Процедура Кнопка1Нажатие(Элемент)
    //Настройка = Новый НастройкаПериода;
    //
    //Настройка.ВариантНастройки = ВариантНастройкиПериода.Период;
    //Настройка.ДатаОкончания =КонецМесяца (КонецПериода);
    //Настройка.ДатаНачала =НачалоМесяца (НачалоПериода);
    //	
    //Если НЕ Настройка.Редактировать() Тогда 
    //	Возврат;
    //КонецЕсли;
    //
    //	КонецПериода = Настройка.ПолучитьДатуОкончания();
    //	НачалоПериода = Настройка.ПолучитьДатуНачала();
    //	ТиповыеОтчеты.ОбновитьПараметрыПериодаПоФорме(КомпоновщикНастроек, ЭтаФорма);
    //	//ТиповыеОтчеты.ОбработкаИзмененияТиповогоОтчетаНаФормеОтчета(ОтчетОбъект, ЭтаФорма);
    
    НастройкаПериода = Новый НастройкаПериода;
    
    
    ТиповыеОтчеты.НастроитьПериод(НастройкаПериода, НачалоПериода, КонецПериода);
    ТиповыеОтчеты.ОбновитьПараметрыПериодаПоФорме(КомпоновщикНастроек, ЭтаФорма);
    ТиповыеОтчеты.ОбработкаИзмененияТиповогоОтчетаНаФормеОтчета(ОтчетОбъект, ЭтаФорма);
    
    
    
    // Вставить содержимое обработчика.
    КонецПроцедуры
    
    Процедура ПриОткрытии()
    ДоработатьКомпоновщикПередВыводом();	
    КонецПериода= КонецМесяца(ТекущаяДата());
    НачалоПериода = НачалоМесяца(Текущаядата());
    
    //	ТиповыеОтчеты.ОбновитьПараметрыПериодаПоФорме(КомпоновщикНастроек, ЭтаФорма);
    //	ТиповыеОтчеты.ОбработкаИзмененияТиповогоОтчетаНаФормеОтчета(ОтчетОбъект,ЭтаФорма);
    
    КонецПроцедуры
    
    Процедура ПриЗакрытии()
    КонецПроцедуры
    

    Вложения:

  2. has
    Offline

    has Опытный в 1С

    Регистрация:
    18 июн 2009
    Сообщения:
    708
    Симпатии:
    0
    Баллы:
    26
    Процедуру ОбновитьПараметрыПериодаПоФорме общего модуля ТиповыеОтчеты посмотрите, станет все понятно.
    П.С.: Код оформляйте тегами, так читабельнее.

Поделиться этой страницей