8.х Вопрос по Выборке

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Prorok, 20 мар 2007.

  1. TopicStarter Overlay
    Prorok
    Offline

    Prorok

    Регистрация:
    15 мар 2007
    Сообщения:
    3
    Симпатии:
    0
    Баллы:
    1
    Имеется Справочник ФизическиеЛица
    при выполнении

    Код:
    Процедура КнопкаВыполнитьНажатие(Кнопка)
    Отбор = Новый Структура ("Пол","Муж");
    СпрФизЛица = Справочники.ФизическиеЛица;
    выборка = СпрФизЛица.Выбрать(,,Отбор,);
    Пока выборка.Следующий() = Истина цикл
    сообщить(выборка.Наименование);
    КонецЦикла;
    КонецПроцедуры
    
    Вылетает ошибка:
    Ошибка при вызове метода контекста (Выбрать): Недопустимое значение параметра (параметр номер "3")
    выборка = СпрФизЛица.Выбрать(,,Отбор,);
    по причине:
    Недопустимое значение параметра (параметр номер "3")

    причем если Процедура имеет такой вид, то никакой ошибки нет! Хотя разницы принципиальной не вижу :
    Код:
    Процедура КнопкаВыполнитьНажатие(Кнопка)
    Отбор = Новый Структура ("Наименование","Иванов");
    СпрФизЛица = Справочники.ФизическиеЛица;
    выборка = СпрФизЛица.Выбрать(,,Отбор,);
    Пока выборка.Следующий() = Истина цикл
    сообщить(выборка.Наименование);
    КонецЦикла;
    КонецПроцедуры
    
  2. Vladoff
    Offline

    Vladoff

    Регистрация:
    16 мар 2007
    Сообщения:
    31
    Симпатии:
    0
    Баллы:
    1
    1. Проверить, есть ли у вас в справочнике реквизит Пол.
    2. Проверить, является ли его тип «Строка».
  3. TopicStarter Overlay
    Prorok
    Offline

    Prorok

    Регистрация:
    15 мар 2007
    Сообщения:
    3
    Симпатии:
    0
    Баллы:
    1
    Спасибо, тип был число)

Поделиться этой страницей