8.х Вопрос по технологии создания внешних печатных форм

Тема в разделе "Отчеты и обработки для "1С:Предприятие 8"", создана пользователем Yury, 6 июл 2012.

  1. TopicStarter Overlay
    Yury
    Offline

    Yury Опытный в 1С

    Регистрация:
    22 дек 2011
    Сообщения:
    355
    Симпатии:
    4
    Баллы:
    29
    Так да. И как тогда быть?
  2. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.735
    Симпатии:
    508
    Баллы:
    204
    Еба....ый в рот, говорил же, пилите функцию печати!!!!!!!!!!!!

    Извиняюсь, но я сейчас заплачу :((((((
  3. TopicStarter Overlay
    Yury
    Offline

    Yury Опытный в 1С

    Регистрация:
    22 дек 2011
    Сообщения:
    355
    Симпатии:
    4
    Баллы:
    29
    И я тоже. :(
    Так она серверная, а мне все что нужно сделать -- на клиенте (показать форму, запустить приложение)
  4. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.735
    Симпатии:
    508
    Баллы:
    204
    И кстати, вы не подумали почему данная процедура Экспортная ????
    Я вам отвечу, потому что она вызывается из обработки команды Печать, документа или справочника:))))), которые хранятся в конфигурации:), если допиливать, то и конфу тоже придется пилить:)
    Мой вам совет, сделайте обработку, которая будет доставать необходимые файлы из документов и печатать их.
  5. TopicStarter Overlay
    Yury
    Offline

    Yury Опытный в 1С

    Регистрация:
    22 дек 2011
    Сообщения:
    355
    Симпатии:
    4
    Баллы:
    29
    Я видел, что команда обрабатывается на клиенте, но туда не подлезть. Конфигурацию пилить не нужно.
    Похоже так и придется делать отдельную обработку для печати.
  6. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.735
    Симпатии:
    508
    Баллы:
    204
    Обработки также можно подключить к объекту. Но там технология немного другая. ВПФ предназначена для вывода на печать печатной формы, но никак не для "обработки" каких-либо данных, а тем более для их изменения.
  7. TopicStarter Overlay
    Yury
    Offline

    Yury Опытный в 1С

    Регистрация:
    22 дек 2011
    Сообщения:
    355
    Симпатии:
    4
    Баллы:
    29
    Может как-то можно заставить его выполниться на клиенте?
    Код:
    Функция СведенияОВнешнейОбработке() Экспорт
    ПараметрыРегистрации = Новый Структура;
    МассивНазначений = Новый Массив;
    МассивНазначений.Добавить("Справочник.ВнутренниеДокументы");
    
    ПараметрыРегистрации.Вставить("Вид", "ПечатнаяФорма");
    ПараметрыРегистрации.Вставить("Назначение", МассивНазначений);
    ПараметрыРегистрации.Вставить("Наименование", "Печать сканок прикрепленных к карточке документа");
    ПараметрыРегистрации.Вставить("БезопасныйРежим", Истина);
    ПараметрыРегистрации.Вставить("Версия", "2.0");   
    ПараметрыРегистрации.Вставить("Информация", "Печать сканок прикрепленных к карточке документа");
    
    ТаблицаКоманд = ПолучитьТаблицуКоманд();
    ДобавитьКоманду(ТаблицаКоманд, "Печать сканок прикрепленных к карточке документа", "Печать сканок", "ВызовСерверногоМетода", Истина, "ПечатьMXL");
    
    ПараметрыРегистрации.Вставить("Команды", ТаблицаКоманд);
    
    Возврат ПараметрыРегистрации;
    КонецФункции
    
    При добавлении команды используем "ВызовСерверногоМетода", но есть еще "ВызовКлиентскогоМетода", "ОткрытиеФормы".
    Если использовать "ВызовКлиентскогоМетода", но не находить при выполнении Печать () : "Метод объекта не обнаружен (Печать)"
  8. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.735
    Симпатии:
    508
    Баллы:
    204
    Я вот что-то догнать не могу. Вот вы написали Справочник.ВнутренниеДокументы и "Наименование", "Печать сканок прикрепленных к карточке документа, как документ и справочник м/у собой связаны ? Они связаны конечно реквизитом, так вам потребуется дополнительно обращаться к этому справочнику или документу, чтобы выдернуть необходимые данные.
    Посмотрите как сделана обработка табличных частей.
  9. TopicStarter Overlay
    Yury
    Offline

    Yury Опытный в 1С

    Регистрация:
    22 дек 2011
    Сообщения:
    355
    Симпатии:
    4
    Баллы:
    29
    А вы видели конфигурацию Документооборот? Там именно так. Все карточки документов храняться в справочниках, в сами справочники называются ВнутренниеДокументы, ВходящиеДокументы, ИсходящиеДокументы.
    Но это как к делу относиться? К вызову серверноного или клиентского метода?? :) Только если косвенно :)))))
  10. TopicStarter Overlay
    Yury
    Offline

    Yury Опытный в 1С

    Регистрация:
    22 дек 2011
    Сообщения:
    355
    Симпатии:
    4
    Баллы:
    29
    Вопрос: можно ли используя параметры команды ("ВызовСерверногоМетода", "ВызовКлиентскогоМетода", "ОткрытиеФормы") "перетащить" Печать () на клиента???
  11. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.735
    Симпатии:
    508
    Баллы:
    204
    Нет, дело в том что в процедуре Печать() идет сбор данных, которые потом отражаются клиенту. У вас никак не получится выбрать данные на клиенте, только обработка, и то, есть ограничения.
  12. TopicStarter Overlay
    Yury
    Offline

    Yury Опытный в 1С

    Регистрация:
    22 дек 2011
    Сообщения:
    355
    Симпатии:
    4
    Баллы:
    29
    Так с клиента я могу вызвать серверную функцию, которая и выполнить запрос. Вопрос возможно встанет как вернуть результат на клиента.
    В общем надо прощаться с этим методом и писать отдельную обработку. Я правильно понимаю???
  13. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.735
    Симпатии:
    508
    Баллы:
    204
    Результат = ВашаСервернаяФункция()
    Вот так вы вернете результат выполненя функции ВашаСервернаяФункция на клиента.
    Да, лучше бы написать свою обработку, и прицепить ее к доку.
  14. x_under
    Offline

    x_under Модераторы Команда форума Модератор

    Регистрация:
    25 апр 2007
    Сообщения:
    2.576
    Симпатии:
    13
    Баллы:
    29
  15. Yuriy_Alexandrovich
    Offline

    Yuriy_Alexandrovich Профессионал в 1С Команда форума

    Регистрация:
    15 сен 2011
    Сообщения:
    1.275
    Симпатии:
    76
    Баллы:
    54
    Доброго Всем,
    Поясните нубу, а что мешает во внешней печатной форме добавить форму, назначить ее основной, в модуле формы на кнопку "Выполнить" привязать вызов процедуры "Печать()" и таким образом ее отладить.
    Еще не понятно, разве в процедуре "Печать()" не срабортает код :
    #Если &НаКлиенте
    Форма = ЭтотОбъект.ПолучитьФорму("НашаФорма");
    Если НЕ Форма.Открыта() Тогда
    Форма.Открыть();
    КонецЕсли;
    #КонецЕсли

Поделиться этой страницей