8.х Вопрос по редактированию в ФормеСписка документа

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем AmoZ, 23 май 2011.

  1. TopicStarter Overlay
    AmoZ
    Offline

    AmoZ Опытный в 1С

    Регистрация:
    25 дек 2008
    Сообщения:
    123
    Симпатии:
    0
    Баллы:
    26
    Доброго времени всем!
    Есть, грубо говоря, документ в конфигурации с двумя видами форм: ФормаДокумента и ФормаСписка.
    Необходимо производить редактирование в ФормеСписка.
    Пользуюсь обработчиком
    ДокументСписокВыбор(Элемент, ВыбраннаяСтрока, Колонка, СтандартнаяОбработка).
    В документе есть реквизиты как ссылки на справочники, так и просто числовые значения.

    Там где ссылается на справочники, сделал так:
    Код:
    	
    Если Колонка.Имя = "НаименованиеОбъекта" Тогда
    Строка = Справочники.НаименованиеОбъекта.ПолучитьФормуВыбора().ОткрытьМодально();
    Если НЕ Строка.Пустая() Тогда
    Док = ЭлементыФормы.ДокументСписок.ТекущиеДанные.Ссылка.ПолучитьОбъект();
    Док.НаименованиеОбъекта = Строка;
    Док.Записать();
    СтандартнаяОбработка = Ложь;
    КонецЕсли;
    КонецЕсли;
    
    
    А вот как сделать редактирование обычных числовых значений?
  2. Lugano
    Offline

    Lugano

    Регистрация:
    4 мар 2011
    Сообщения:
    27
    Симпатии:
    0
    Баллы:
    1
    Если я Вас правильно понял, попробуйте функцию ВвестиЧисло().
    ВвестиЧисло(<Число>, <Подсказка>, <Длина>, <Точность>)
  3. vartanet
    Offline

    vartanet Опытный в 1С Команда форума

    Регистрация:
    16 ноя 2010
    Сообщения:
    2.698
    Симпатии:
    15
    Баллы:
    29
    может быть использовать процедуру ВвестиЗначение()?
  4. TopicStarter Overlay
    AmoZ
    Offline

    AmoZ Опытный в 1С

    Регистрация:
    25 дек 2008
    Сообщения:
    123
    Симпатии:
    0
    Баллы:
    26
    Еще столкнулся с такой проблемой:
    ниже приведен код, с помощью которого вывожу в формесписка документа итоги по колонкам.
    Только если много документов в списке, жутко тормозит.
    Подскажите, как выйти из ситуации?
    Код:
       
    Процедура ДокументСписокПриПолученииДанных(Элемент, ОформленияСтрок)
    Построитель = Новый ПостроительЗапроса;
    Построитель.ИсточникДанных = Новый ОписаниеИсточникаДанных(ДокументСписок);
    Результат = Построитель.Результат; //отобранные строки типа РезультатЗапроса
    
    ТЗ = Результат.Выгрузить();
    ЭлементыФормы.ДокументСписок.Колонки.НаименованиеОбъекта.ТекстПодвала = "Общее количество документов: " + ТЗ.Количество();
    ЭлементыФормы.ДокументСписок.Колонки.КоличествоМ3.ТекстПодвала = ТЗ.Итог("КоличествоМ3");
    ЭлементыФормы.ДокументСписок.Колонки.СуммаДоставки.ТекстПодвала = ТЗ.Итог("СуммаДоставки");
    ЭлементыФормы.ДокументСписок.Колонки.СуммаНеДогруза.ТекстПодвала = ТЗ.Итог("СуммаНеДогруза");
    ЭлементыФормы.ДокументСписок.Колонки.СуммаЗаРейс.ТекстПодвала = ТЗ.Итог("СуммаЗаРейс");
    ЭлементыФормы.ДокументСписок.Колонки.СуммаЗаПростой.ТекстПодвала = ТЗ.Итог("СуммаЗаПростой");
    КонецПроцедуры
    
    

Поделиться этой страницей