7.7 вопрос по правам доступа

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем Ket, 25 ноя 2008.

  1. TopicStarter Overlay
    Ket
    Offline

    Ket

    Регистрация:
    29 янв 2008
    Сообщения:
    7
    Симпатии:
    0
    Баллы:
    1
    Доброго времени суток!
    У меня такой вопросик, необходимо закрыть права на изменение документов. И не просто закрыть доступ, а запретить изменять документы дата создания которых больше двух месяцев. то есть если документ создан в мае, а сейчас ноябрь, то его менять нельзя. созданный документ в октябре или ноябре я могу редактировать и изменять, а старые документы нет.
    Подскажите где-нибудь можно такое установить?
  2. Stado_adama
    Offline

    Stado_adama Модераторы Модератор

    Регистрация:
    27 ноя 2007
    Сообщения:
    1.086
    Симпатии:
    0
    Баллы:
    26
    посмотри операции / константы / дата запрета редактирования
  3. bob
    Offline

    bob Опытный в 1С

    Регистрация:
    7 май 2008
    Сообщения:
    386
    Симпатии:
    0
    Баллы:
    26
    в глобальном модуле в бухгалтерии я так делал когдато
    Код:
    Процедура глПроверкаРазрешенияРедактирования(Конт) Экспорт
    Если Конт.Выбран() = 1 Тогда
    //ооо
    Если СокрЛП(глПользователь)="Пупкин" ТОгда
    Если РабочаяДата() > Конт.ДатаДок+30 Тогда
    Конт.Форма.ТолькоПросмотр(1);
    КонецЕсли;	
    КонецЕсли;
    Если СокрЛП(глПользователь)="Пупкина" ТОгда
    Если Конт.ПредставлениеВида()="Авансовый отчет" Тогда
    Если РабочаяДата() > Конт.ДатаДок+14 Тогда
    Конт.Форма.ТолькоПросмотр(1);
    КонецЕсли;
    
    
  4. Stado_adama
    Offline

    Stado_adama Модераторы Модератор

    Регистрация:
    27 ноя 2007
    Сообщения:
    1.086
    Симпатии:
    0
    Баллы:
    26
    Боб, а че ты делал когда у тебя пользователи менялись? или у тебя в конторе нет текучки?
  5. bob
    Offline

    bob Опытный в 1С

    Регистрация:
    7 май 2008
    Сообщения:
    386
    Симпатии:
    0
    Баллы:
    26
    там пользователи не по фамилиям заведены, а по должностям. Так же ничего не мешает привязать к правам доступа. ПРедложи свой вариант.
  6. Stado_adama
    Offline

    Stado_adama Модераторы Модератор

    Регистрация:
    27 ноя 2007
    Сообщения:
    1.086
    Симпатии:
    0
    Баллы:
    26
    bob, ну как вариант универсальности - это стандартные для ТиСа полномочия пользователей... через них сделать... а что касается топика, то я думаю там всего лишь надо найти константу про дату запрета...

Поделиться этой страницей